summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2023-02-13 22:28:18 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-02-15 15:09:17 -0500
commit96870b97127c234f139fdf3ec7477b9bec9969bb (patch)
tree4fe16d46f816279f33830c0186c595e5d7907706
parent147e78a2aff5cb6a29e7f45dd5c4351200cdb117 (diff)
downloadmeta-virtualization-96870b97127c234f139fdf3ec7477b9bec9969bb.tar.gz
meta-virt: sync SRC_URIs between k8s and k3s
k3s is using a lot of SRC_URIs and some of them have corrsponding recipe in meta-virt, which are used by k8s. These components' SRC_URIs are better to be kept in sync, because this avoids two local git repos (Yocto supports fetching locally) which are totally the same. Remove the '.git' suffix from these recipes to sync the SRC_URIs. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/go-digest/go-digest_git.bb2
-rw-r--r--recipes-containers/go-errors/go-errors_git.bb2
-rw-r--r--recipes-containers/go-spf13-cobra/spf13-cobra_git.bb2
-rw-r--r--recipes-containers/go-spf13-pflag/spf13-pflag_git.bb2
-rw-r--r--recipes-containers/oci-image-spec/oci-image-spec_git.bb2
-rw-r--r--recipes-containers/oci-runtime-spec/oci-runtime-spec_git.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/recipes-containers/go-digest/go-digest_git.bb b/recipes-containers/go-digest/go-digest_git.bb
index c06a1420..ad2da25d 100644
--- a/recipes-containers/go-digest/go-digest_git.bb
+++ b/recipes-containers/go-digest/go-digest_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE.code;md5=9cd86830b557232ce55e
7SRCNAME = "go-digest" 7SRCNAME = "go-digest"
8 8
9PKG_NAME = "github.com/opencontainers/${SRCNAME}" 9PKG_NAME = "github.com/opencontainers/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master;protocol=https" 10SRC_URI = "git://${PKG_NAME};destsuffix=git/src/${PKG_NAME};branch=master;protocol=https"
11 11
12SRCREV = "b6234c321f263c503268e3b205f3d9755f9d14ed" 12SRCREV = "b6234c321f263c503268e3b205f3d9755f9d14ed"
13PV = "v1.0.0-rc0+git${SRCPV}" 13PV = "v1.0.0-rc0+git${SRCPV}"
diff --git a/recipes-containers/go-errors/go-errors_git.bb b/recipes-containers/go-errors/go-errors_git.bb
index f1d7ef3b..678b0242 100644
--- a/recipes-containers/go-errors/go-errors_git.bb
+++ b/recipes-containers/go-errors/go-errors_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=6fe682a02df52c6653f33bd0f
7SRCNAME = "errors" 7SRCNAME = "errors"
8 8
9PKG_NAME = "github.com/pkg/${SRCNAME}" 9PKG_NAME = "github.com/pkg/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master;protocol=https" 10SRC_URI = "git://${PKG_NAME};destsuffix=git/src/${PKG_NAME};branch=master;protocol=https"
11 11
12SRCREV = "5dd12d0cfe7f152f80558d591504ce685299311e" 12SRCREV = "5dd12d0cfe7f152f80558d591504ce685299311e"
13PV = "v0.8.1+git${SRCPV}" 13PV = "v0.8.1+git${SRCPV}"
diff --git a/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb b/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb
index b272f164..b2ae9191 100644
--- a/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb
+++ b/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE.txt;md5=920d76114a32b0fb75b3f
7SRCNAME = "cobra" 7SRCNAME = "cobra"
8 8
9PKG_NAME = "github.com/spf13/${SRCNAME}" 9PKG_NAME = "github.com/spf13/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master;protocol=https" 10SRC_URI = "git://${PKG_NAME};destsuffix=git/src/${PKG_NAME};branch=master;protocol=https"
11 11
12SRCREV = "b5d8e8f46a2f829f755b6e33b454e25c61c935e1" 12SRCREV = "b5d8e8f46a2f829f755b6e33b454e25c61c935e1"
13PV = "v0.0.1+git${SRCPV}" 13PV = "v0.0.1+git${SRCPV}"
diff --git a/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb b/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb
index ea63029a..5d66de3a 100644
--- a/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb
+++ b/recipes-containers/go-spf13-pflag/spf13-pflag_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=1e8b7dc8b906737639131047a
7SRCNAME = "pflag" 7SRCNAME = "pflag"
8 8
9PKG_NAME = "github.com/spf13/${SRCNAME}" 9PKG_NAME = "github.com/spf13/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master;protocol=https" 10SRC_URI = "git://${PKG_NAME};destsuffix=git/src/${PKG_NAME};branch=master;protocol=https"
11 11
12SRCREV = "d5e0c0615acee7028e1e2740a11102313be88de1" 12SRCREV = "d5e0c0615acee7028e1e2740a11102313be88de1"
13PV = "v1.0.5+git${SRCPV}" 13PV = "v1.0.5+git${SRCPV}"
diff --git a/recipes-containers/oci-image-spec/oci-image-spec_git.bb b/recipes-containers/oci-image-spec/oci-image-spec_git.bb
index d13e3d63..22cb8913 100644
--- a/recipes-containers/oci-image-spec/oci-image-spec_git.bb
+++ b/recipes-containers/oci-image-spec/oci-image-spec_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=27ef03aa2da6e424307f102e8
7SRCNAME = "image-spec" 7SRCNAME = "image-spec"
8 8
9PKG_NAME = "github.com/opencontainers/${SRCNAME}" 9PKG_NAME = "github.com/opencontainers/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=main;protocol=https" 10SRC_URI = "git://${PKG_NAME};destsuffix=git/src/${PKG_NAME};branch=main;protocol=https"
11 11
12SRCREV = "02efb9a75ee11e05937b535cc5f228f9343ab2f5" 12SRCREV = "02efb9a75ee11e05937b535cc5f228f9343ab2f5"
13PV = "v1.0.2+git${SRCPV}" 13PV = "v1.0.2+git${SRCPV}"
diff --git a/recipes-containers/oci-runtime-spec/oci-runtime-spec_git.bb b/recipes-containers/oci-runtime-spec/oci-runtime-spec_git.bb
index 5e0be285..e5a9ef04 100644
--- a/recipes-containers/oci-runtime-spec/oci-runtime-spec_git.bb
+++ b/recipes-containers/oci-runtime-spec/oci-runtime-spec_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=b355a61a394a504dacde901c9
7SRCNAME = "runtime-spec" 7SRCNAME = "runtime-spec"
8 8
9PKG_NAME = "github.com/opencontainers/${SRCNAME}" 9PKG_NAME = "github.com/opencontainers/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=main;protocol=https" 10SRC_URI = "git://${PKG_NAME};destsuffix=git/src/${PKG_NAME};branch=main;protocol=https"
11 11
12SRCREV = "7ceeb8af52593e37d8ef28bd350f50044b7adf1d" 12SRCREV = "7ceeb8af52593e37d8ef28bd350f50044b7adf1d"
13PV = "v1.0.2+git${SRCPV}" 13PV = "v1.0.2+git${SRCPV}"