summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-12-11 12:28:23 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-12-15 08:47:25 -0500
commit9772ddbec385f08a3b92bd70a0de898c6e982aa7 (patch)
tree0f333e295ba529fcf2ba53e3e51fff3d2ebb8795
parent26a3e2c0d8502f424a92ab6cd588d78ca53b9f05 (diff)
downloadmeta-virtualization-9772ddbec385f08a3b92bd70a0de898c6e982aa7.tar.gz
openvswitch: drop version 1.10.0 and 2.1.3
There are some changes that we need to make in the .inc file to properly support more recent releases of openvswitch. These changes are not compatible with these older versions of openvswitch, so rather than make accommodations in the .inc file to continue to support this version we will simply drop them. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-networking/openvswitch/openvswitch_1.10.0.bb16
-rw-r--r--recipes-networking/openvswitch/openvswitch_2.1.3.bb29
2 files changed, 0 insertions, 45 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_1.10.0.bb b/recipes-networking/openvswitch/openvswitch_1.10.0.bb
deleted file mode 100644
index 85b2709c..00000000
--- a/recipes-networking/openvswitch/openvswitch_1.10.0.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1require openvswitch.inc
2
3RRECOMMENDS_${PN} += "kernel-module-openvswitch"
4
5PR = "r4"
6
7SRC_URI += "\
8 http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \
9 file://configure-Only-link-against-libpcap-on-FreeBSD.patch \
10 "
11
12SRC_URI[md5sum] = "fe8b49efe9f86b57abab00166b971106"
13SRC_URI[sha256sum] = "803966c89d6a5de6d710a2cb4ed73ac8d8111a2c44b12b846dcef8e91ffab167"
14LIC_FILES_CHKSUM = "file://COPYING;md5=49eeb5acb1f5e510f12c44f176c42253"
15
16inherit pkgconfig
diff --git a/recipes-networking/openvswitch/openvswitch_2.1.3.bb b/recipes-networking/openvswitch/openvswitch_2.1.3.bb
deleted file mode 100644
index dc6c7e3d..00000000
--- a/recipes-networking/openvswitch/openvswitch_2.1.3.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1require openvswitch.inc
2
3RRECOMMENDS_${PN} += "kernel-module-openvswitch"
4
5RDEPENDS_${PN}-ptest += "\
6 python-logging python-syslog python-argparse python-io \
7 python-fcntl python-shell python-lang python-xml python-math \
8 python-datetime python-netclient python sed \
9 "
10
11SRC_URI += "\
12 http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \
13 file://openvswitch-add-more-target-python-substitutions.patch \
14 file://openvswitch-add-ptest.patch \
15 file://run-ptest \
16 "
17
18SRC_URI[md5sum] = "d3c8a69df3d1b1a9eaef5a896576fd2a"
19SRC_URI[sha256sum] = "43a2562fe5e8e48e997bfdb04691ffaaaefe73069b5699654538bf2f16ebfb1a"
20
21LIC_FILES_CHKSUM = "file://COPYING;md5=e03b0d9c4115c44518594e5618e653f8"
22
23inherit ptest
24
25EXTRA_OEMAKE += "TEST_DEST=${D}${PTEST_PATH} TEST_ROOT=${PTEST_PATH}"
26
27do_install_ptest() {
28 oe_runmake test-install
29}