diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-03-15 23:08:59 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-03-16 09:30:48 -0400 |
commit | 98daf1fa937643a1a155e0de3f2ebdadc57da27f (patch) | |
tree | 62bb1937532dd2b885a56c51af623615e5a74c25 | |
parent | 5ee98852fb8e5f7b27980f1bdae69d4702cc3ed6 (diff) | |
download | meta-virtualization-98daf1fa937643a1a155e0de3f2ebdadc57da27f.tar.gz |
k3s: add seccomp distro feature requirement
k3s requires seccomp, and a runc with seccomp enabled for proper
operation. runc has a distro feature check to enable seccomp, so
if we enforce it as k3s feature, we'll also get a properly built
runc and we'll work out of the box.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/k3s/k3s_git.bb | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-containers/k3s/k3s_git.bb b/recipes-containers/k3s/k3s_git.bb index 8d59987e..6c11f9c2 100644 --- a/recipes-containers/k3s/k3s_git.bb +++ b/recipes-containers/k3s/k3s_git.bb | |||
@@ -33,6 +33,9 @@ GO_BUILD_LDFLAGS = "-X github.com/rancher/k3s/pkg/version.Version=${PV} \ | |||
33 | " | 33 | " |
34 | BIN_PREFIX ?= "${exec_prefix}/local" | 34 | BIN_PREFIX ?= "${exec_prefix}/local" |
35 | 35 | ||
36 | inherit features_check | ||
37 | REQUIRED_DISTRO_FEATURES ?= "seccomp" | ||
38 | |||
36 | do_compile() { | 39 | do_compile() { |
37 | export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" | 40 | export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" |
38 | export CGO_ENABLED="1" | 41 | export CGO_ENABLED="1" |