summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Eriksson <jonas.eriksson@enea.com>2014-02-27 17:10:08 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-02-28 10:43:27 -0500
commit9b5d1d158a78d50c55a86d8e9f245b3f84c88893 (patch)
tree7e01f8901e4b79246b2797d609f6a6304def75f9
parent5876038deff36f37dbadefa29d87ccff806598ad (diff)
downloadmeta-virtualization-9b5d1d158a78d50c55a86d8e9f245b3f84c88893.tar.gz
libvirt: Use DISTRO_FEATURES to enable Xen support
The Xen drivers in libvirt is needed when the build file system image and kernel are running as dom0. The parts of the kernel needed to run as dom0 are controlled by DISTRO_FEATURES, and thus there is no need for the Xen drivers if DISTRO_FEATURES does not contain 'xen'. Signed-off-by: Jonas Eriksson <jonas.eriksson@enea.com> Acked-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_1.2.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.2.1.bb b/recipes-extended/libvirt/libvirt_1.2.1.bb
index 76d3f42b..5365b8de 100644
--- a/recipes-extended/libvirt/libvirt_1.2.1.bb
+++ b/recipes-extended/libvirt/libvirt_1.2.1.bb
@@ -109,9 +109,10 @@ INITSCRIPT_PARAMS_${PN}-libvirtd = "defaults 72"
109#PACKAGECONFIG ??= "xen libxl xen-inotify test remote libvirtd" 109#PACKAGECONFIG ??= "xen libxl xen-inotify test remote libvirtd"
110 110
111# full config 111# full config
112PACKAGECONFIG ??= "qemu yajl xen libxl xen-inotify uml openvz vmware vbox esx iproute2 \ 112PACKAGECONFIG ??= "qemu yajl uml openvz vmware vbox esx iproute2 polkit lxc test \
113 polkit lxc test remote macvtap libvirtd netcf udev python ebtables \ 113 remote macvtap libvirtd netcf udev python ebtables \
114 ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \ 114 ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
115 ${@base_contains('DISTRO_FEATURES', 'xen', 'xen libxl xen-inotify', '', d)} \
115 " 116 "
116 117
117# enable,disable,depends,rdepends 118# enable,disable,depends,rdepends