diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-02-10 11:51:05 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-02-10 12:58:29 -0500 |
commit | a04b3f6c9d8c5485677e64e884f4e09bfb76e81f (patch) | |
tree | 1ea460502dfc4e1442aa07fac5460c5caf9066ca | |
parent | 2318da517d7e15770abe5067bdd6d6ce8200caab (diff) | |
download | meta-virtualization-a04b3f6c9d8c5485677e64e884f4e09bfb76e81f.tar.gz |
moby: update to v23.0.1
Refresh two patches for context in the udpated docker-moby.
Bumping moby to version v23.0.1, which comprises the following commits:
4002fa877b vendor: update buildkit to latest v0.10
e697c9365f builder: define GetRemotes for the worker
4c544c3d5f ci: fix branch filter pattern in buildkit workflow
06aca27cc1 ci: enhance tests distribution
001b2e778a ci: update gotestlist to 0.3.1
38b70ebc3b apparmor: Check if apparmor_parser is available
8a5d341d94 [23.0] vendor: github.com/moby/buildkit v0.10.7-0.20230206124303-b8fdb4b78da0
427101f656 libnet/d/ipvlan: gracefully migrate from older dbs
5b7142073f Dockerfile: configure code dir as "safe" directory
7e03250780 graphdriver/overlay2: usingMetacopy ENOTSUP is non-fatal
975bdb2c96 daemon: identify container exits by ProcessID
610250f06e vendor: github.com/containerd/containerd v1.6.16
63a0f1fe09 vendor: github.com/pelletier/go-toml v1.9.5
699e853be3 hack: display build cmd when DOCKER_DEBUG set
b7e0725e98 hack: remove unnecessary vars in make.sh script
96746238b2 hack: remove ORIG_BUILDFLAGS var
df2fe70049 hack: remove -installsuffix build flag
8b83e09b9c client: improve error messaging on crash
26e9face5a [23.0] update containerd binary to v1.6.16
6641852d51 rootless: support `--ipc=host`
8fc49af4ab hack: check if cross-compiling before setting ARM target name
30134ab177 vendor: github.com/moby/swarmkit/v2 v2.0.0-20230119195359-904c221ac281
3da45c0fe7 fix blockThreshold full bug
941a07b339 ioutils: add regression test for bytespipe deadlock
a21381a55a Dockerfile: prefer ld for building against arm64
2616ebc5ac libnetwork: Support IPv6 in arrangeUserFilterRule()
7a5f3f8053 libnetwork: fix empty-lines (revive)
7cfd4b3471 libnetwork/config: rename ParseConfigOptions() to New()
1090c5fd4c libnetwork/config: inline LoadDefaultScopes()
c93e1e9e66 libnetwork/config: merge DaemonCfg into Config
031fb72313 libnetwork: remove old integration tests
a96a97bf47 libnetwork/config: remove ParseConfig()
9b383dbd51 libnetwork/config: inline ProcessOptions
bed115e664 libnetwork/config: remove "Experimental" and "Debug" options
64cbbaa883 Dockerfile: smoke tests for static builds
4100226e27 Dockerfile: use clang to build dockerd/docker-proxy
dadeec4205 Disable chrootarchive.init() on Windows
f328486cb3 Add GetLibHome stub for non-linux OS
8e83d28f31 vendor: golang.org/x/net v0.5.0
06eb6ab794 vendor: golang.org/x/text v0.6.0
31cf0bf181 vendor: golang.org/x/sys v0.4.0
0e4548bbe1 Dockerfile: fix PKG_CONFIG for xx
8c12a6648b hack: name for target ARM architecture not specified
10c4ada049 hack: typo in displayed platform name
322149038a Add additional loggig in case of error of renaming runtimes-old and removing it
a8926de2a1 Handle docker start inside overlayfs
524de97334 daemon/config: inform the user when the input JSON contains invalid UTF-8
0b2eecdc8a daemon/config: support alternate (common) unicode encodings using a BOM
abff66b283 daemon/config: clean up tests to use common helper
d9bdb61992 cmd/dockerd: use default SIGQUIT behaviour
c627132dc8 vendor: github.com/moby/ipvs v1.1.0
13a31b67de vendor: github.com/vishvananda/netns v0.0.2
bd5d9f3190 vendor: github.com/vishvananda/netns v0.0.1
c8262e912f libnetwork: Remove iptables nat rule when hairpin is disabled
12e3398f64 update to go1.19.5
076d57104a docs: api: synchronise versioned API docs (v1.39 - v1.41)
8ce4ae1345 docs: api: synchronise versioned API docs (v1.42)
f0fe353ca6 api: swagger: add errorDetail to CreateImageInfo
04371160f8 api: docs: add errorDetail to CreateImageInfo (v1.42)
e753cce70f docs: add 401 to possible status codes of /auth
4d7792417e ci: update buildkit to fix integration tests
5802ca9e08 rootless: move ./rootless to ./pkg/rootless
33572e98c1 Use user paths for plugin discovery in rootless mode
52c7a5d96b daemon/config: New(): initialize config with platform-specific defaults
101bd10d0e daemon/config: group JSON preprocessing steps
def679d0e0 daemon/config: ignore UTF-8 BOM in config JSON
cf8c728f3c graphdriver/btrfs: needs kernel headers >= 4.12, not >= 4.7
e40c2410ca Dockerfile.*: drop libbtrfs
51a65e01ac PACKAGERS: update Btrfs graphdriver dependencies
0cf2b14994 graphdriver/btrfs: use free wrapper consistently
21e6c282e6 graphdriver/btrfs: use kernel UAPI headers
42e7a15a63 graphdriver/btrfs: drop version information
01883e1177 daemon/graphdriver: use strconv instead of fmt.Sprintf
25939ee45e libnetwork: improve logs for DNS failures
691b44b4c3 vendor: github.com/containerd/containerd v1.6.15
5aa0c2cae2 [23.0] update containerd binary to v1.6.15
6acc1701ea integration-cli: Fix hanging TestLogsFollowGoroutines*
8dfd907478 hack: restore copy_binaries func
0d1aba547e hack/make: Don't add -buildmode=pie with -race
4da19e2dca Clear conntrack entries for published UDP ports
fe097e018c Fix volume CreatedAt being altered on initialization
d778bbab84 docs: contributing docs update for cross comp
2dd577955c Dockerfile: add "all" stage to build binaries and extra tools
3ef71f9085 ci: add extra steps to check artifacts
8fbfc2676f Dockerfile: rename dev stages
7e286efcd3 ci: use GITHUB_REF and GITHUB_SHA to set version and commit
f29fe2daec bake: define additional vars
3b90bb6ad3 bake: define DESTDIR
171471b613 hack: update buildmode pie condition
7d8c689923 hack: do not set buildmode pie for statically linked binary
75596bee28 hack: use PKG_CONFIG var when checking libdevmapper
29758a067f IAmStatic not used anymore
5d4ddce5ed hack: remove containerutility script
a85bdbe1ca Dockerfile: use TARGETPLATFORM to build Docker
6a0a2c4f79 Always use iptables -C to look for rules
91f2d963c6 Merge iptables.probe() into iptables.detectIptables()
2bf66f725c Check ipt options before looking for ip6t
1b27ab4c73 libnetwork/iptables: Fix test panic when execute only one test
316231cced daemon/graphdriver/devicemapper: simplify Udev log, and update link
770ace39d8 daemon/logger/gcplogs: remove ensureHomeIfIAmStatic workaround
5e4464798f api: can marshal and unmarshal when args.fields is empty
515219b716 Update delve version
0393897695 daemon/graphdriver/btrfs: workaround field rename in btrfs-progs 6.1
7199300239 cmd/docker-proxy: add "-v / --version" flag
e9075f70c7 gha: update buildkit to fix integration tests
b2d2f012b4 errdefs: FromStatusCode() don't log "FIXME" debug message
9980e64341 vendor: github.com/containerd/containerd v1.6.14
5ebd78d5f8 update containerd binary to v1.6.14
f6c2f20cee Dockerfile: delve cross build with TARGETPLATFORM
3d6908c79b Dockerfile: swagger cross build with TARGETPLATFORM
1dc34e889c Dockerfile: containerutility cross build with TARGETPLATFORM
effd7661df Dockerfile: registry cross build with TARGETPLATFORM
f3e3266373 Dockerfile: dockercli cross build with TARGETPLATFORM
fd6316e631 Dockerfile: rootlesskit cross build with TARGETPLATFORM
fbe4db5be0 Dockerfile: tini cross build with TARGETPLATFORM
f9a356c7e9 Dockerfile: runc cross build with TARGETPLATFORM
6e7cc3b7e3 Dockerfile: containerd cross build with TARGETPLATFORM
582b29f587 Dockerfile: DOCKER_STATIC arg
daa28fcf2d Dockerfile: add dummy stage
4cab584a9c Dockerfile: add cross compilation helper
0b12468116 vendor: github.com/containerd/containerd v1.6.13
6570b654f4 vendor: github.com/Microsoft/hcsshim v0.9.6
d8d11bca37 update containerd binary to v1.6.13
a72fb70eb0 vendor: github.com/moby/swarmkit/v2 v2.0.0-20221215132206-0da442b2780f
dca58c654a daemon: drop side effect from registerLinks()
6149c333ff daemon: don't checkpoint container until registered
42bffae5ff daemon: fix GetContainer() returning (nil, nil)
a6818fd4cb hack: introduce validate/no-module
45fe08c93c hack: replace go-mod-prepare.sh with wrapper script
c508d13372 hack/go-mod-prepare.sh: find root robustly; make steps transparent
036398f512 hack/validate/vendor: clean up license validation step
a4957d2585 hack/validate/vendor: split tidy from vendor
394eaa8495 hack/vendor.sh: allow running tidy & vendor separately
d80f235c47 vendor: github.com/tinylib/msgp v1.1.6
5ca9231b44 vendor: github.com/philhofer/fwd v1.1.2
ffa2c0b517 image/store: Use errdefs for errors
c0c146fc82 Remove uses of deprecated go-digest.NewDigestFromHex, go-digest.Digest.Hex
6295320d91 use consistent alias for gotest.tools/v3/assert/cmp
1cc1395fae vendor: golang.org/x/net v0.4.0
0163808dbe vendor: github.com/prometheus/client_golang v1.14.0
9b62b83429 vendor: github.com/go-logr/logr v1.2.3
d5ffdeb76c vendor: golang.org/x/crypto v0.2.0
4da8dedaab vendor: golang.org/x/net v0.2.0
b14ffffffd vendor: github.com/opencontainers/runc v1.1.3
173df30ac5 vendor: github.com/klauspost/compress v1.15.12
fe62290eed go.mod: github.com/miekg/dns v1.1.43
4ee3cc2531 vendor: github.com/containerd/containerd v1.6.12
48a0d8a8d1 [23.0] update containerd binary to v1.6.12 (addresses CVE-2022-23471)
4952dc2844 distribution: remove unused RequireSchema2
e7b26fa1b1 use ad-hoc libtrust key
f2463e1e86 distribution: use ad-hoc trustkey for tests
139080d093 daemon/config: remove and local trustkey utilities
46e0317bc1 [23.0] remove libtrust tests
Bumping libnetwork to version v0.7.0-dev.3-1857-g05b93e0d, which comprises the following commits:
f7cdd0e7 Always use iptables -C to look for rules
a6106f66 Merge iptables.probe() into iptables.detectIptables()
49bb4902 Check ipt options before looking for ip6t
51413ef1 libnetwork: processEndpointCreate: Fix deadlock between getSvcRecords and processEndpointCreate
e460ffec skip TestPortMappingV6Config
64b196bd circleci: update to "next-gen" convenience image
50f192e9 circleci: update to docker 20.10
88744155 update to go1.18.9, gofmt, and regenerate proto
9ed130d8 fix linting issues
5e08bdb1 Revert: Added API to set ephemeral port allocator range
047ac186 Cleanup servicebindings only on Windows
6f36306d Delay network deletion until after lb cleanup
a9c349a6 Log HNS policylist removal failures
docker-moby/cli: update to 23.0.x
27b19a6ac ci: fix branch filter pattern
14aac2c23 vendor: github.com/docker/docker v23.0.0
0cd15abfd vendor: github.com/containerd/containerd v1.6.16
168f1b55e cli/command/container: exit 126 on EISDIR error
53ed25d9b Fix bad ThrottleDevice path
9e3d5d152 Fix issue where one bad credential helper causes none to be returned
1e3622c50 docs: move doc generation scripts to subdir
9b54d860c rm: allow `docker container remove` as an alias
00070e6e2 docs: add note about MKE CA rotation, which is potentially dangerous
67b961789 manifest: save raw manifest content on download
285e137aa manifest: explicitly error if whitespace reconstruction has failed
070825bc7 manifest: add support for oci image types
551c4e9ab Fix typo in reference doc for docker Signed-off-by: Craig Osterhou <craig.osterhout@docker.com>
8672540f8 vendor: github.com/docker/docker v23.0.0-rc.3
c4fff9da1 vendor: github.com/moby/swarmkit/v2 v2.0.0-20230119195359-904c221ac281
526e5e7c9 vendor: golang.org/x/net v0.5.0
d7f21ea9c vendor: golang.org/x/term v0.4.0
ae43eb0e0 vendor: golang.org/x/text v0.6.0
caf8b152c vendor: golang.org/x/sys v0.4.0
be30cb370 Fix section docker ps --size
5d04b1c49 note `--user` args usage restriction
9bb70217f Add extra newline after additionalHelp output
59e74b44a cli: additionalHelp() don't decorate output if it's piped
fc6be6ad3 cli: pass dockerCLI's in/out/err to cobra cmds
d347678cd README: fix badges
e04f3dd0d docs: fix duplicated format anchor in plugin_ls
c453cc687 vendor: github.com/docker/docker v23.0.0-rc.2
0d16330dd vendor: github.com/containerd/containerd v1.6.15
b9e1ad3d1 update to go1.19.5
d1f02a273 deprecated: update deprecation for btrfs on CentOS/RHEL 7
bdc7e37b3 deprecation: mark btrfs driver as deprecated for CentOS 7 and RHEL7
35d7fbc81 docs: inspect: remove trailing whitespace from example
79c9e527a docs: generate markdown
186dcf30b docs: fix anchors
c49f1ccb4 update cli-docs-tool to v0.5.1
5a5b7a61d contrib: fix engine logging docs link
4595ce588 cmd: set double quotes as code delimiter
81b051298 docs: fix some more anchors
71e561780 docs: fix anchor links
3613fcc86 docs: deprecated: fix link to Docker Desktop 3.2.0 release notes
b81105718 cli/rm_test: Fix TestRemoveForce race condition
42de5cc7f service/logs: use strings.Cut
3fa18636e internal/test: use strings.Cut
c8bd8932a cli/config: use strings.Cut
3bed830a2 cli/compose: use strings.Cut
cb19bf9f7 cli/command: use strings.Cut
acc45f549 cli/command/volume: use strings.Cut
806f9eab6 cli/command/swarm: use strings.Cut
b3557b284 cli/command/stack: use strings.Cut
2b06c0c42 cli/command/service: use strings.Cut
f29992c0f cli/command/network: use strings.Cut
424401233 cli/command/container: use strings.Cut
6c39bc1f6 opts: use strings.Cut for handling key/value pairs
a473c5b38 opts: rename logOptsValidator, fix unhandled errors in tests
d84256132 remove redundant conversions and braces
720a6a823 docs/run: Fix url to blog "Docker can now run within Docker"
946bb9471 Missing exec_die event
784f66014 cli/command/container: remove unused NetworkDisabled field
6fe14e61f vendor: github.com/docker/docker v23.0.0-rc.1 (use tag)
c5982f373 vendor: github.com/inconshreveable/mousetrap v1.1.0
cc859412c vendor: github.com/docker/docker v23.0.0-beta.1.0.20221221173850-cba986b34090
70d24e854 vendor: github.com/moby/swarmkit/v2 v2.0.0-20221215132206-0da442b2780f
bab905a44 vendor: golang.org/x/crypto v0.2.0
929f23fcf vendor: golang.org/x/net v0.4.0
2df9ff91e vendor: golang.org/x/term v0.3.0
1b75c7c52 vendor: golang.org/x/text v0.5.0
e3e0b7a6c vendor: golang.org/x/sys v0.3.0
6f2f021b6 vendor: github.com/prometheus/client_golang v1.14.0
dedbcec46 vendor: github.com/opencontainers/runc v1.1.3
cd2098c46 vendor: github.com/klauspost/compress v1.15.12
d7869bead vendor: github.com/containerd/containerd v1.6.14
06eba426d cmd/docker: fix typo in deprecation warning
895e7a3df Added missing backslash to documentation sites cli snippet
2f733b87f cli/flags: remove outdated TODO
60d62fb72 cmd/docker: improve error message if BUILDKIT_ENABLED=0
e547881e2 Fix ssh process killed when context is done
35b42efad [completion/zsh] add volume completion
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
3 files changed, 25 insertions, 23 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb index 0aed206a..19f4763b 100644 --- a/recipes-containers/docker/docker-moby_git.bb +++ b/recipes-containers/docker/docker-moby_git.bb | |||
@@ -34,14 +34,14 @@ DESCRIPTION = "Linux container runtime \ | |||
34 | # - The common components of this recipe and docker-ce do need to be moved | 34 | # - The common components of this recipe and docker-ce do need to be moved |
35 | # to a docker.inc recipe | 35 | # to a docker.inc recipe |
36 | 36 | ||
37 | SRCREV_moby = "3fd34324a8abc7573fa3b06190a1338263ef1ee7" | 37 | SRCREV_moby = "bc3805a0a0d3b5bd3f0e6c69f46ac08dd53377c7" |
38 | SRCREV_libnetwork = "dcdf8f176d1e13ad719e913e796fb698d846de98" | 38 | SRCREV_libnetwork = "05b93e0d3a95952f70c113b0bc5bdb538d7afdd7" |
39 | SRCREV_cli = "83ca73f9aa7a1c442171ef2602af4d303d9de9c2" | 39 | SRCREV_cli = "a5ee5b1dfc9b8f08ed9e020bb54fc18550173ef6" |
40 | SRCREV_FORMAT = "moby_libnetwork" | 40 | SRCREV_FORMAT = "moby_libnetwork" |
41 | SRC_URI = "\ | 41 | SRC_URI = "\ |
42 | git://github.com/moby/moby.git;branch=23.0;name=moby;protocol=https \ | 42 | git://github.com/moby/moby.git;branch=23.0;name=moby;protocol=https \ |
43 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ | 43 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ |
44 | git://github.com/docker/cli;branch=master;name=cli;destsuffix=git/cli;protocol=https \ | 44 | git://github.com/docker/cli;branch=23.0;name=cli;destsuffix=git/cli;protocol=https \ |
45 | file://docker.init \ | 45 | file://docker.init \ |
46 | file://0001-libnetwork-use-GO-instead-of-go.patch \ | 46 | file://0001-libnetwork-use-GO-instead-of-go.patch \ |
47 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ | 47 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ |
@@ -56,7 +56,7 @@ require docker.inc | |||
56 | LICENSE = "Apache-2.0" | 56 | LICENSE = "Apache-2.0" |
57 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" | 57 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" |
58 | 58 | ||
59 | DOCKER_VERSION = "23.0-beta" | 59 | DOCKER_VERSION = "23.0.1" |
60 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" | 60 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" |
61 | 61 | ||
62 | CVE_PRODUCT = "docker mobyproject:moby" | 62 | CVE_PRODUCT = "docker mobyproject:moby" |
diff --git a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch index c19d9f50..c10e69d3 100644 --- a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch +++ b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch | |||
@@ -14,12 +14,12 @@ Index: git/src/import/hack/make/.binary | |||
14 | =================================================================== | 14 | =================================================================== |
15 | --- git.orig/src/import/hack/make/.binary | 15 | --- git.orig/src/import/hack/make/.binary |
16 | +++ git/src/import/hack/make/.binary | 16 | +++ git/src/import/hack/make/.binary |
17 | @@ -81,7 +81,7 @@ | 17 | @@ -66,7 +66,7 @@ |
18 | if [ -n "$DOCKER_DEBUG" ]; then | ||
19 | set -x | ||
20 | fi | ||
21 | - go build -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" ${GO_PACKAGE} | ||
22 | + ${GO} build -trimpath -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" ${GO_PACKAGE} | ||
23 | ) | ||
18 | 24 | ||
19 | echo "Building: $DEST/$BINARY_FULLNAME" | 25 | echo "Created binary: $DEST/$BINARY_FULLNAME" |
20 | echo "GOOS=\"${GOOS}\" GOARCH=\"${GOARCH}\" GOARM=\"${GOARM}\"" | ||
21 | - go build \ | ||
22 | + ${GO} build -trimpath \ | ||
23 | -o "$DEST/$BINARY_FULLNAME" \ | ||
24 | "${BUILDFLAGS[@]}" \ | ||
25 | -ldflags " | ||
diff --git a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch index 10b180b6..f94f73e4 100644 --- a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch +++ b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch | |||
@@ -17,27 +17,29 @@ Index: git/libnetwork/Makefile | |||
17 | =================================================================== | 17 | =================================================================== |
18 | --- git.orig/libnetwork/Makefile | 18 | --- git.orig/libnetwork/Makefile |
19 | +++ git/libnetwork/Makefile | 19 | +++ git/libnetwork/Makefile |
20 | @@ -45,9 +45,9 @@ | 20 | @@ -45,10 +45,10 @@ |
21 | build-local: | 21 | build-local: |
22 | @echo "🐳 $@" | 22 | @echo "🐳 $@" |
23 | @mkdir -p "bin" | 23 | @mkdir -p "bin" |
24 | - go build -tags experimental -o "bin/dnet" ./cmd/dnet | 24 | - GO111MODULE=off go build -tags experimental -o "bin/dnet" ./cmd/dnet |
25 | - go build -o "bin/docker-proxy" ./cmd/proxy | 25 | - GO111MODULE=off go build -o "bin/docker-proxy" ./cmd/proxy |
26 | - CGO_ENABLED=0 go build -o "bin/diagnosticClient" ./cmd/diagnostic | 26 | - CGO_ENABLED=0 go build -o "bin/diagnosticClient" ./cmd/diagnostic |
27 | + $(GO) build -trimpath -tags experimental -o "bin/dnet" ./cmd/dnet | 27 | - CGO_ENABLED=0 go build -o "bin/testMain" ./cmd/networkdb-test/testMain.go |
28 | + $(GO) build -trimpath -o "bin/proxy" ./cmd/proxy | 28 | + GO111MODULE=off $(GO) build -trimpath -tags experimental -o "bin/dnet" ./cmd/dnet |
29 | + GO111MODULE=off $(GO) build -trimpath -o "bin/docker-proxy" ./cmd/proxy | ||
29 | + CGO_ENABLED=0 $(GO) build -trimpath -o "bin/diagnosticClient" ./cmd/diagnostic | 30 | + CGO_ENABLED=0 $(GO) build -trimpath -o "bin/diagnosticClient" ./cmd/diagnostic |
30 | CGO_ENABLED=0 go build -o "bin/testMain" ./cmd/networkdb-test/testMain.go | 31 | + CGO_ENABLED=0 $(GO) build -trimpath -o "bin/testMain" ./cmd/networkdb-test/testMain.go |
31 | 32 | ||
32 | build-images: | 33 | build-images: |
34 | @echo "🐳 $@" | ||
33 | @@ -82,8 +82,8 @@ | 35 | @@ -82,8 +82,8 @@ |
34 | 36 | ||
35 | cross-local: | 37 | cross-local: |
36 | @echo "🐳 $@" | 38 | @echo "🐳 $@" |
37 | - go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet | 39 | - GO111MODULE=off go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet |
38 | - go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy | 40 | - GO111MODULE=off go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy |
39 | + @$(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy | 41 | + GO111MODULE=off $(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet |
40 | + @$(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet | 42 | + GO111MODULE=off $(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy |
41 | 43 | ||
42 | # Rebuild protocol buffers. | 44 | # Rebuild protocol buffers. |
43 | # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt. | 45 | # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt. |