summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-08-22 15:40:23 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-08-22 15:40:23 -0400
commita2fab33ace916f68168e2444f47d0cce9cd04ea5 (patch)
treef63e1a74d3904ab7f8a154a377140ed0a60277e5
parentd6ae4fc295e71245c995271f5e3f2c78e2883d8a (diff)
downloadmeta-virtualization-a2fab33ace916f68168e2444f47d0cce9cd04ea5.tar.gz
protobuf: respect autotools build/source split
Tweak the ptest build rule to look for artifacts in the build directory instead of source, since build and source are split on the latest oe-core. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/criu/protobuf_2.5.0.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-containers/criu/protobuf_2.5.0.bb b/recipes-containers/criu/protobuf_2.5.0.bb
index 5c7454b5..a85fd87a 100644
--- a/recipes-containers/criu/protobuf_2.5.0.bb
+++ b/recipes-containers/criu/protobuf_2.5.0.bb
@@ -34,12 +34,14 @@ do_compile_ptest() {
34 # Modify makefile to use the cross-compiler 34 # Modify makefile to use the cross-compiler
35 sed -e "s|c++|${CXX}|g" -i "${S}/${TEST_SRC_DIR}/Makefile" 35 sed -e "s|c++|${CXX}|g" -i "${S}/${TEST_SRC_DIR}/Makefile"
36 36
37 mkdir -p "${B}/${TEST_SRC_DIR}"
38
37 # Add the location of the cross-compiled header and library files 39 # Add the location of the cross-compiled header and library files
38 # which haven't been installed yet. 40 # which haven't been installed yet.
39 cp "${S}/protobuf.pc" "${S}/${TEST_SRC_DIR}/protobuf.pc" 41 cp "${B}/protobuf.pc" "${B}/${TEST_SRC_DIR}/protobuf.pc"
40 sed -e 's|Cflags:|Cflags: -I${S}/src|' -i "${S}/${TEST_SRC_DIR}/protobuf.pc" 42 sed -e 's|Cflags:|Cflags: -I${S}/src|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
41 sed -e 's|Libs:|Libs: -L${S}/src/.libs|' -i "${S}/${TEST_SRC_DIR}/protobuf.pc" 43 sed -e 's|Libs:|Libs: -L${B}/src/.libs|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
42 export PKG_CONFIG_PATH="${S}/${TEST_SRC_DIR}" 44 export PKG_CONFIG_PATH="${B}/${TEST_SRC_DIR}"
43 45
44 # Save the pkgcfg sysroot variable, and update it to nothing so 46 # Save the pkgcfg sysroot variable, and update it to nothing so
45 # that it doesn't append the sysroot to the beginning of paths. 47 # that it doesn't append the sysroot to the beginning of paths.