diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-08-24 14:49:36 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-08-24 15:15:14 +0000 |
commit | a5417e8084c7901a66f76b508892472db98a97fb (patch) | |
tree | 071a59d38d8edd91928dab0327e31873e87ff414 | |
parent | 08ec648efa1c3ff48d5fbc4d909cd54199d9009e (diff) | |
download | meta-virtualization-a5417e8084c7901a66f76b508892472db98a97fb.tar.gz |
go-context: update to v1.1
Bumping context to version v1.1-14-g1cbd4c1, which comprises the following commits:
1cbd4c1 Update go version, add tools for verification and testing (#43)
a01379d Update README.md
8559d4a Update README.md (#40)
dc31bb2 Create config.yml (#39)
30a41ee Update README.md (#38)
51ce91d README.md: Update site URL
08b5f42 [docs] godoc fix. (#34)
f81bcf7 [docs] Note http.Request.WithContext() conflict. (#33)
01ef6ff .travis.yml: Add go1.7
531bdb2 Fix typo
ffc4422 [ci] .travis.yml go vet fix.
b53bb42 Update .travis.yml to build Go 1.6
1c83b3e Update .travis.yml
ecbca1c Add Travis-ci tests build on Go version 1.3 / 1.4
50c25fb benchmark: fix parallelWriter.
9af5636 Fix racy code in Get
We tweak the license checksum, as the year has changed.
We also drop do_compile, as go install is now being used to
fetch linting modules at build time.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-devtools/go/go-context_git.bb | 8 |
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-devtools/go/go-context_git.bb b/recipes-devtools/go/go-context_git.bb index 0959054b..132da98c 100644 --- a/recipes-devtools/go/go-context_git.bb +++ b/recipes-devtools/go/go-context_git.bb | |||
@@ -2,17 +2,21 @@ DESCRIPTION = "A golang registry for global request variables." | |||
2 | HOMEPAGE = "https://github.com/gorilla/context" | 2 | HOMEPAGE = "https://github.com/gorilla/context" |
3 | SECTION = "devel/go" | 3 | SECTION = "devel/go" |
4 | LICENSE = "BSD-3-Clause" | 4 | LICENSE = "BSD-3-Clause" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c50f6bd9c1e15ed0bad3bea18e3c1b7f" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c30eee78985cf2584cded5f89ba3d787" |
6 | 6 | ||
7 | SRCNAME = "context" | 7 | SRCNAME = "context" |
8 | 8 | ||
9 | PKG_NAME = "github.com/gorilla/${SRCNAME}" | 9 | PKG_NAME = "github.com/gorilla/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git;branch=main;protocol=https" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=main;protocol=https" |
11 | 11 | ||
12 | SRCREV = "14f550f51af52180c2eefed15e5fd18d63c0a64a" | 12 | SRCREV = "1cbd4c16de64273a6e63fc710b0d89bfad72cd32" |
13 | 13 | ||
14 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
15 | 15 | ||
16 | do_compile() { | ||
17 | true | ||
18 | } | ||
19 | |||
16 | do_install() { | 20 | do_install() { |
17 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | 21 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} |
18 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | 22 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ |