diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-09-28 18:27:51 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-09-28 18:27:51 -0400 |
commit | b17bd2c4b0c2e7e440cedc29f32469622c31fca3 (patch) | |
tree | 0cbc89cefd737af7ceabe0788c4e582cd5c9baa6 | |
parent | 0ac91aa8f2283828fe638bfd603205e33e3a98ad (diff) | |
download | meta-virtualization-b17bd2c4b0c2e7e440cedc29f32469622c31fca3.tar.gz |
busybox-initrd: move static configuration to 'vmsep' distro feature
We already have a distro feature that controls the static/non-static
configuration of libgcrypt: 'vmsep'
To avoid build errors on distros that don't have static libgcrypt
available, we move the CONFIG_STATIC config to a fragment and only
enable it whent he distro feature is set.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-core/busybox/busybox-initrd/initrd.cfg | 2 | ||||
-rw-r--r-- | recipes-core/busybox/busybox-initrd/static.cfg | 1 | ||||
-rw-r--r-- | recipes-core/busybox/busybox-initrd_1.32.0.bb | 1 |
3 files changed, 2 insertions, 2 deletions
diff --git a/recipes-core/busybox/busybox-initrd/initrd.cfg b/recipes-core/busybox/busybox-initrd/initrd.cfg index 9f64c4c6..04896713 100644 --- a/recipes-core/busybox/busybox-initrd/initrd.cfg +++ b/recipes-core/busybox/busybox-initrd/initrd.cfg | |||
@@ -10,5 +10,3 @@ CONFIG_INIT_TERMINAL_TYPE="" | |||
10 | 10 | ||
11 | # CONFIG_FEATURE_SHADOWPASSWDS is not set | 11 | # CONFIG_FEATURE_SHADOWPASSWDS is not set |
12 | CONFIG_USE_BB_PWD_GRP=y | 12 | CONFIG_USE_BB_PWD_GRP=y |
13 | |||
14 | CONFIG_STATIC=y | ||
diff --git a/recipes-core/busybox/busybox-initrd/static.cfg b/recipes-core/busybox/busybox-initrd/static.cfg new file mode 100644 index 00000000..25902bb7 --- /dev/null +++ b/recipes-core/busybox/busybox-initrd/static.cfg | |||
@@ -0,0 +1 @@ | |||
CONFIG_STATIC=y | |||
diff --git a/recipes-core/busybox/busybox-initrd_1.32.0.bb b/recipes-core/busybox/busybox-initrd_1.32.0.bb index 82edb570..5ce5fa52 100644 --- a/recipes-core/busybox/busybox-initrd_1.32.0.bb +++ b/recipes-core/busybox/busybox-initrd_1.32.0.bb | |||
@@ -5,6 +5,7 @@ require recipes-core/busybox/busybox_${PV}.bb | |||
5 | SRC_URI += "file://init.cfg \ | 5 | SRC_URI += "file://init.cfg \ |
6 | file://mdev.cfg \ | 6 | file://mdev.cfg \ |
7 | file://runx.cfg \ | 7 | file://runx.cfg \ |
8 | ${@bb.utils.contains('DISTRO_FEATURES', 'vmsep', 'file://static.cfg', '', d)} \ | ||
8 | file://initrd.cfg" | 9 | file://initrd.cfg" |
9 | 10 | ||
10 | S = "${WORKDIR}/busybox-${PV}" | 11 | S = "${WORKDIR}/busybox-${PV}" |