diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-05-25 13:49:14 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-06-04 08:43:08 -0400 |
commit | b22003973b19f1ee03337b9a47839563c9d3d19e (patch) | |
tree | b1467ae90f419975c2ba48436cd2936ec63e5b75 | |
parent | f964aeb898a48128a0a79304ac6025e82e995131 (diff) | |
download | meta-virtualization-b22003973b19f1ee03337b9a47839563c9d3d19e.tar.gz |
skope: update to 1.3.x
Updating skopeo to the 1.3.x series. Along with the version bump, we
patch the Makefile to stop using gpgme-config and instead using
pkg-config, since OE taints gpgme-config and the build will break if
we call it directly.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/skopeo/files/0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch | 35 | ||||
-rw-r--r-- | recipes-containers/skopeo/skopeo_git.bb | 9 |
2 files changed, 41 insertions, 3 deletions
diff --git a/recipes-containers/skopeo/files/0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch b/recipes-containers/skopeo/files/0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch new file mode 100644 index 00000000..f12734c9 --- /dev/null +++ b/recipes-containers/skopeo/files/0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 4f60614b51df50f5d28495cf2e270dd6ab5fea7d Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Tue, 25 May 2021 13:42:56 -0400 | ||
4 | Subject: [PATCH] Makefile: use pkg-config instead of gpgme-config | ||
5 | |||
6 | OE taints gpgme-config to produce the following flag when called: | ||
7 | |||
8 | --should-not-have-used-/usr/bin/gpgme-config | ||
9 | |||
10 | Which breaks the build. We change to use pkg-config, and skopeo | ||
11 | builds as it did before. | ||
12 | |||
13 | Upstream-Status: inappropriate OE specific | ||
14 | |||
15 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
16 | --- | ||
17 | Makefile | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/src/import/Makefile b/src/import/Makefile | ||
21 | index 6bacd12e..8a94b236 100644 | ||
22 | --- a/src/import/Makefile | ||
23 | +++ b/src/import/Makefile | ||
24 | @@ -8,7 +8,7 @@ export GOPROXY=https://proxy.golang.org | ||
25 | # supports only pkg-config, not general shell scripts, and gpgme does not install a pkg-config file. | ||
26 | # If gpgme is not installed or gpgme-config can’t be found for other reasons, the error is silently ignored | ||
27 | # (and the user will probably find out because the cgo compilation will fail). | ||
28 | -GPGME_ENV := CGO_CFLAGS="$(shell gpgme-config --cflags 2>/dev/null)" CGO_LDFLAGS="$(shell gpgme-config --libs 2>/dev/null)" | ||
29 | +GPGME_ENV := CGO_CFLAGS="$(shell pkg-config gpgme --cflags 2>/dev/null)" CGO_LDFLAGS="$(shell pkg-config gpgme --libs 2>/dev/null)" | ||
30 | |||
31 | # Normally empty, DESTDIR can be used to relocate the entire install-tree | ||
32 | DESTDIR ?= | ||
33 | -- | ||
34 | 2.19.1 | ||
35 | |||
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb index 05baefb3..2c292463 100644 --- a/recipes-containers/skopeo/skopeo_git.bb +++ b/recipes-containers/skopeo/skopeo_git.bb | |||
@@ -20,13 +20,14 @@ RDEPENDS_${PN} = " \ | |||
20 | " | 20 | " |
21 | 21 | ||
22 | SRC_URI = " \ | 22 | SRC_URI = " \ |
23 | git://github.com/containers/skopeo;branch=release-1.2 \ | 23 | git://github.com/containers/skopeo;branch=master \ |
24 | file://0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch \ | ||
24 | file://storage.conf \ | 25 | file://storage.conf \ |
25 | file://registries.conf \ | 26 | file://registries.conf \ |
26 | " | 27 | " |
27 | 28 | ||
28 | SRCREV = "e7880c4a8991966f16e367f085d42375ad70197e" | 29 | SRCREV = "8efffce8befc2de87670ba75d6c86ada61e869fd" |
29 | PV = "v1.2.3-dev+git${SRCPV}" | 30 | PV = "v1.3.0+git${SRCPV}" |
30 | GO_IMPORT = "import" | 31 | GO_IMPORT = "import" |
31 | 32 | ||
32 | S = "${WORKDIR}/git" | 33 | S = "${WORKDIR}/git" |
@@ -63,6 +64,8 @@ do_compile() { | |||
63 | export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" | 64 | export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" |
64 | cd ${S}/src/import | 65 | cd ${S}/src/import |
65 | 66 | ||
67 | export GO111MODULE=off | ||
68 | |||
66 | oe_runmake bin/skopeo | 69 | oe_runmake bin/skopeo |
67 | } | 70 | } |
68 | 71 | ||