diff options
author | Dengke Du <dengke.du@windriver.com> | 2019-02-14 11:36:20 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2019-02-14 14:03:49 +0000 |
commit | b513fda51969eaad61b6cb4625e4b4a75b55d537 (patch) | |
tree | a370a51a53d818352273366c37b80861c39134cf | |
parent | 72a920412f0eead836cd2128144988152534882f (diff) | |
download | meta-virtualization-b513fda51969eaad61b6cb4625e4b4a75b55d537.tar.gz |
ceph: disable ccache
When enable ccache for ceph, error occurs:
-----------------------------------------------------
ccache: invalid option -- 'E'
...
Unable to determine C++ standard library, got .
-----------------------------------------------------
This is because variable "CXX_STDLIB" was null in CMakeLists.txt line: 637,
The "CXX_STDLIB" come from:
-----------------------------------------------------
execute_process(
COMMAND ./librarytest.sh ${CMAKE_CXX_COMPILER} ${CMAKE_CXX_FLAGS}
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
OUTPUT_VARIABLE CXX_STDLIB
)
-----------------------------------------------------
The script librarytest.sh in ceph accept argument: compile and flags, but when
enable ccache, the compile replace by ccache, so that script failed.
So we disable ccache for ceph now.
Signed-off-by: Dengke Du <dengke.du@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/ceph/ceph_13.2.2.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-extended/ceph/ceph_13.2.2.bb b/recipes-extended/ceph/ceph_13.2.2.bb index 08021cf7..0cba08a5 100644 --- a/recipes-extended/ceph/ceph_13.2.2.bb +++ b/recipes-extended/ceph/ceph_13.2.2.bb | |||
@@ -101,3 +101,4 @@ PACKAGES += " \ | |||
101 | " | 101 | " |
102 | INSANE_SKIP_${PN}-python += "ldflags" | 102 | INSANE_SKIP_${PN}-python += "ldflags" |
103 | INSANE_SKIP_${PN} += "dev-so" | 103 | INSANE_SKIP_${PN} += "dev-so" |
104 | CCACHE_DISABLE = "1" | ||