diff options
author | Chandana kalluri <ckalluri@xilinx.com> | 2020-08-11 22:27:30 -0700 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-08-12 22:37:24 -0400 |
commit | b5e6a0d0afa91b7fc5fe891caa0d689932c4b09f (patch) | |
tree | f18665e0d34569574f71426b8816fdb8f3f28f22 | |
parent | 535a3e82791322b0484ac4a6a05600afe3cf0647 (diff) | |
download | meta-virtualization-b5e6a0d0afa91b7fc5fe891caa0d689932c4b09f.tar.gz |
runx: Fix linux kernel versions referenced in the recipe
Fix the linux kernel versions referenced in the recipe. For ease of use, add
variables KERNEL_SRC_VER and KERNEL_URL_VER that can be used to udpate the
linux versions.
Signed-off-by: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-core/runx/runx_git.bb | 10 |
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-core/runx/runx_git.bb b/recipes-core/runx/runx_git.bb index 991e6e1f..a2600711 100644 --- a/recipes-core/runx/runx_git.bb +++ b/recipes-core/runx/runx_git.bb | |||
@@ -3,9 +3,13 @@ SUMMARY = "runx stuff" | |||
3 | DESCRIPTION = "Xen Runtime for OCI" | 3 | DESCRIPTION = "Xen Runtime for OCI" |
4 | 4 | ||
5 | SRCREV_runx = "f24efd33fb18469e9cfe4d1bfe8e2c90ec8c4e93" | 5 | SRCREV_runx = "f24efd33fb18469e9cfe4d1bfe8e2c90ec8c4e93" |
6 | |||
7 | KERNEL_SRC_VER="linux-5.4" | ||
8 | KERNEL_URL_VER="v5.x" | ||
9 | |||
6 | SRC_URI = "\ | 10 | SRC_URI = "\ |
7 | git://github.com/lf-edge/runx;nobranch=1;name=runx \ | 11 | git://github.com/lf-edge/runx;nobranch=1;name=runx \ |
8 | https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.4.tar.xz;destsuffix=git/kernel/build \ | 12 | https://www.kernel.org/pub/linux/kernel/${KERNEL_URL_VER}/${KERNEL_SRC_VER}.tar.xz;destsuffix=git/kernel/build \ |
9 | file://0001-make-kernel-cross-compilation-tweaks.patch \ | 13 | file://0001-make-kernel-cross-compilation-tweaks.patch \ |
10 | file://0001-make-initrd-cross-install-tweaks.patch \ | 14 | file://0001-make-initrd-cross-install-tweaks.patch \ |
11 | " | 15 | " |
@@ -45,12 +49,12 @@ do_compile() { | |||
45 | # building. | 49 | # building. |
46 | mkdir -p ${S}/kernel/build | 50 | mkdir -p ${S}/kernel/build |
47 | mkdir -p ${S}/kernel/src | 51 | mkdir -p ${S}/kernel/src |
48 | cp ${DL_DIR}/linux-4.15.tar.xz ${S}/kernel/build/ | 52 | cp ${DL_DIR}/${KERNEL_SRC_VER}.tar.xz ${S}/kernel/build/ |
49 | 53 | ||
50 | # In the future, we might want to link the extracted kernel source (if | 54 | # In the future, we might want to link the extracted kernel source (if |
51 | # we move patches to recipe space, but for now, we need make-kernel to | 55 | # we move patches to recipe space, but for now, we need make-kernel to |
52 | # extract a copy and possibly patch it. | 56 | # extract a copy and possibly patch it. |
53 | # ln -sf ${WORKDIR}/linux-4.15 ${S}/kernel/src/ | 57 | # ln -sf ${WORKDIR}/${KERNEL_SRC_VER} ${S}/kernel/src/ |
54 | 58 | ||
55 | # build the kernel | 59 | # build the kernel |
56 | echo "[INFO]: runx: building the kernel" | 60 | echo "[INFO]: runx: building the kernel" |