summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2020-03-11 23:15:04 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-03-13 21:53:18 -0400
commitbbbda2aff9282b1615fcf6b2ec4c7e4e347a8f01 (patch)
tree07f7df72e235eff102739139086a8b7616fa4c80
parentdcc50fe2f2de573c5530e824c13ecb0604ee6d14 (diff)
downloadmeta-virtualization-bbbda2aff9282b1615fcf6b2ec4c7e4e347a8f01.tar.gz
podman: add system service for podman
Add system service for podman which starts a podman instance allow to access the new HTTP based API (apiv2). Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/podman/podman_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb
index c9960287..aa6b25b3 100644
--- a/recipes-containers/podman/podman_git.bb
+++ b/recipes-containers/podman/podman_git.bb
@@ -97,6 +97,12 @@ do_install() {
97 if ${@bb.utils.contains('PACKAGECONFIG', 'docker', 'true', 'false', d)}; then 97 if ${@bb.utils.contains('PACKAGECONFIG', 'docker', 'true', 'false', d)}; then
98 oe_runmake install.docker DESTDIR="${D}" 98 oe_runmake install.docker DESTDIR="${D}"
99 fi 99 fi
100 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
101 install -d ${D}${systemd_unitdir}/system
102 install -m 644 ${S}/src/import/contrib/systemd/system/podman.service ${D}/${systemd_unitdir}/system
103 install -m 644 ${S}/src/import/contrib/systemd/system/podman.socket ${D}/${systemd_unitdir}/system
104 rm -f ${D}/${systemd_unitdir}/system/docker.service.rpm
105 fi
100} 106}
101 107
102FILES_${PN} += " \ 108FILES_${PN} += " \
@@ -106,6 +112,8 @@ FILES_${PN} += " \
106 ${sysconfdir}/cni \ 112 ${sysconfdir}/cni \
107" 113"
108 114
115SYSTEMD_SERVICE_${PN} = "podman.service podman.socket"
116
109RDEPENDS_${PN} += "conmon virtual/runc iptables cni skopeo" 117RDEPENDS_${PN} += "conmon virtual/runc iptables cni skopeo"
110RRECOMMENDS_${PN} += "slirp4netns" 118RRECOMMENDS_${PN} += "slirp4netns"
111RCONFLICTS_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'docker', 'docker', '', d)}" 119RCONFLICTS_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'docker', 'docker', '', d)}"