summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2025-04-17 18:34:47 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2025-04-17 18:34:53 +0000
commitbd1a95853f8cb79101c200c175c3372a74f20961 (patch)
tree0ea5a8a64388308aa00e70c2e0ab88dd02ecd1b1
parentf3feb82026b268912d627a4a04df979266137181 (diff)
downloadmeta-virtualization-bd1a95853f8cb79101c200c175c3372a74f20961.tar.gz
devtools: update to latest
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/python/python3-boto3_1.37.35.bb (renamed from recipes-devtools/python/python3-boto3_1.17.51.bb)2
-rw-r--r--recipes-devtools/python/python3-botocore/0001-Fix-rejecting-URLs-with-unsafe-characters-in-is_vali.patch61
-rw-r--r--recipes-devtools/python/python3-botocore_1.37.35.bb (renamed from recipes-devtools/python/python3-botocore_1.20.51.bb)4
-rw-r--r--recipes-devtools/python/python3-bugsnag_4.7.1.bb (renamed from recipes-devtools/python/python3-bugsnag_4.1.0.bb)2
-rw-r--r--recipes-devtools/python/python3-docker_7.1.0.bb (renamed from recipes-devtools/python/python3-docker_7.0.0.bb)8
-rw-r--r--recipes-devtools/python/python3-dotenv_0.17.0.bb12
-rw-r--r--recipes-devtools/python/python3-dotenv_1.1.0.bb12
-rw-r--r--recipes-devtools/python/python3-flask-cors-virt_3.0.10.bb16
-rw-r--r--recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch34
-rw-r--r--recipes-devtools/python/python3-newrelic_10.9.0.bb (renamed from recipes-devtools/python/python3-newrelic_6.2.0.156.bb)4
-rw-r--r--recipes-devtools/python/python3-sphinx-420.bb15
-rw-r--r--recipes-devtools/python/python3-webob_1.8.9.bb (renamed from recipes-devtools/python/python3-webob_1.8.7.bb)4
12 files changed, 23 insertions, 151 deletions
diff --git a/recipes-devtools/python/python3-boto3_1.17.51.bb b/recipes-devtools/python/python3-boto3_1.37.35.bb
index 9c94a34d..6fe8007d 100644
--- a/recipes-devtools/python/python3-boto3_1.17.51.bb
+++ b/recipes-devtools/python/python3-boto3_1.37.35.bb
@@ -9,7 +9,7 @@ SECTION = "devel/python"
9LICENSE = "MIT" 9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" 10LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
11 11
12SRC_URI[sha256sum] = "c45e7d3aef8965ae1b42c9855c31ded19fbb38cfad0a34cc37dc880ded3672c2" 12SRC_URI[sha256sum] = "751ed599c8fd9ca24896edcd6620e8a32b3db1b68efea3a90126312240e668a2"
13 13
14inherit pypi setuptools3 14inherit pypi setuptools3
15 15
diff --git a/recipes-devtools/python/python3-botocore/0001-Fix-rejecting-URLs-with-unsafe-characters-in-is_vali.patch b/recipes-devtools/python/python3-botocore/0001-Fix-rejecting-URLs-with-unsafe-characters-in-is_vali.patch
deleted file mode 100644
index 95b30a08..00000000
--- a/recipes-devtools/python/python3-botocore/0001-Fix-rejecting-URLs-with-unsafe-characters-in-is_vali.patch
+++ /dev/null
@@ -1,61 +0,0 @@
1From 370cdf7d708c92bf21a42f15392f7be330cf8f80 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
3Date: Fri, 7 May 2021 19:54:16 +0200
4Subject: [PATCH] Fix rejecting URLs with unsafe characters in
5 is_valid_endpoint_url() (#2381)
6
7Detect unsafe characters in is_valid_endpoint_url()
8and is_valid_ipv6_endpoint_url() early, in order to fix rejecting
9invalid URLs with Python 3.9.5+ and other versions carrying bpo-43882
10fix. In these versions, urlsplit() silently strips LF, CR and HT
11characters while splitting the URL, effectively disarming the validator
12in botocore.
13
14The solution is based on a similar fix in Django.
15
16Fixes #2377
17
18Upstream-Status: Backport
19
20---
21 botocore/utils.py | 10 ++++++++++
22 1 file changed, 10 insertions(+)
23
24diff --git a/botocore/utils.py b/botocore/utils.py
25index 378972248..d35dd64bb 100644
26--- a/botocore/utils.py
27+++ b/botocore/utils.py
28@@ -173,6 +173,10 @@ ZONE_ID_PAT = "(?:%25|%)(?:[" + UNRESERVED_PAT + "]|%[a-fA-F0-9]{2})+"
29 IPV6_ADDRZ_PAT = r"\[" + IPV6_PAT + r"(?:" + ZONE_ID_PAT + r")?\]"
30 IPV6_ADDRZ_RE = re.compile("^" + IPV6_ADDRZ_PAT + "$")
31
32+# These are the characters that are stripped by post-bpo-43882 urlparse().
33+UNSAFE_URL_CHARS = frozenset('\t\r\n')
34+
35+
36 def ensure_boolean(val):
37 """Ensures a boolean value if a string or boolean is provided
38
39@@ -977,6 +981,8 @@ class ArgumentGenerator(object):
40
41
42 def is_valid_ipv6_endpoint_url(endpoint_url):
43+ if UNSAFE_URL_CHARS.intersection(endpoint_url):
44+ return False
45 netloc = urlparse(endpoint_url).netloc
46 return IPV6_ADDRZ_RE.match(netloc) is not None
47
48@@ -990,6 +996,10 @@ def is_valid_endpoint_url(endpoint_url):
49 :return: True if the endpoint url is valid. False otherwise.
50
51 """
52+ # post-bpo-43882 urlsplit() strips unsafe characters from URL, causing
53+ # it to pass hostname validation below. Detect them early to fix that.
54+ if UNSAFE_URL_CHARS.intersection(endpoint_url):
55+ return False
56 parts = urlsplit(endpoint_url)
57 hostname = parts.hostname
58 if hostname is None:
59--
602.25.1
61
diff --git a/recipes-devtools/python/python3-botocore_1.20.51.bb b/recipes-devtools/python/python3-botocore_1.37.35.bb
index f71db1fc..edafd2da 100644
--- a/recipes-devtools/python/python3-botocore_1.20.51.bb
+++ b/recipes-devtools/python/python3-botocore_1.37.35.bb
@@ -3,10 +3,8 @@ HOMEPAGE = "https://github.com/boto/botocore"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93" 4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
5 5
6SRC_URI[sha256sum] = "c853d6c2321e2f2328282c7d49d7b1a06201826ba0e7049c6975ab5f22927ea8" 6SRC_URI[sha256sum] = "197a9bf8251c45b9d882c405ec0d0ab40c10e2d2a55ee66960185daec4beb6ec"
7 7
8inherit pypi setuptools3 8inherit pypi setuptools3
9 9
10RDEPENDS:${PN} += "python3-jmespath python3-dateutil python3-logging" 10RDEPENDS:${PN} += "python3-jmespath python3-dateutil python3-logging"
11
12SRC_URI += "file://0001-Fix-rejecting-URLs-with-unsafe-characters-in-is_vali.patch"
diff --git a/recipes-devtools/python/python3-bugsnag_4.1.0.bb b/recipes-devtools/python/python3-bugsnag_4.7.1.bb
index 595cc8c7..379d07c0 100644
--- a/recipes-devtools/python/python3-bugsnag_4.1.0.bb
+++ b/recipes-devtools/python/python3-bugsnag_4.7.1.bb
@@ -10,7 +10,7 @@ SECTION = "devel/python"
10LICENSE = "MIT" 10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489" 11LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
12 12
13SRC_URI[sha256sum] = "dcbd59cd9edea26cc92efb6518aed83a2f356f81bfd5acc730bfe202fb27c1c1" 13SRC_URI[sha256sum] = "98408fe17d4a7f300a56535407a6448b9844d9b528c44527908868fc3646e873"
14 14
15inherit pypi setuptools3 15inherit pypi setuptools3
16 16
diff --git a/recipes-devtools/python/python3-docker_7.0.0.bb b/recipes-devtools/python/python3-docker_7.1.0.bb
index 39567c04..cef0af4f 100644
--- a/recipes-devtools/python/python3-docker_7.0.0.bb
+++ b/recipes-devtools/python/python3-docker_7.1.0.bb
@@ -3,11 +3,12 @@ HOMEPAGE = "https://github.com/docker/docker-py"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
5 5
6SRC_URI[md5sum] = "b08eeccf6a5efd11c316c08207edfeef" 6SRC_URI[md5sum] = "04e92a7b6dc8b88dde3c7cca6850b277"
7SRC_URI[sha256sum] = "323736fb92cd9418fc5e7133bc953e11a9da04f4483f828b527db553f1e7e5a3" 7SRC_URI[sha256sum] = "ad8c70e6e3f8926cb8a92619b832b4ea5299e2831c14284663184e200546fa6c"
8 8
9DEPENDS += "python3-pip-native" 9DEPENDS += "python3-pip-native"
10DEPENDS += "python3-setuptools-scm-native" 10DEPENDS += "python3-setuptools-scm-native"
11DEPENDS += "python3-hatch-vcs-native"
11 12
12RDEPENDS:${PN} += " \ 13RDEPENDS:${PN} += " \
13 python3-misc \ 14 python3-misc \
@@ -16,5 +17,6 @@ RDEPENDS:${PN} += " \
16 python3-requests \ 17 python3-requests \
17 python3-websocket-client \ 18 python3-websocket-client \
18 python3-packaging \ 19 python3-packaging \
20 python3-hatch-vcs \
19" 21"
20inherit pypi python_setuptools_build_meta 22inherit pypi python_hatchling
diff --git a/recipes-devtools/python/python3-dotenv_0.17.0.bb b/recipes-devtools/python/python3-dotenv_0.17.0.bb
deleted file mode 100644
index 1fd13b70..00000000
--- a/recipes-devtools/python/python3-dotenv_0.17.0.bb
+++ /dev/null
@@ -1,12 +0,0 @@
1HOMEPAGE = "https://github.com/pedroburon/dotenv"
2SUMMARY = "Python Dot Env Handler"
3DESCRIPTION = "Shell Command and Library to write and read .env like files."
4SECTION = "devel/python"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=55ee2c3471d386636a719c8ccac40b31"
7
8PYPI_PACKAGE = "python-dotenv"
9
10SRC_URI[sha256sum] = "471b782da0af10da1a80341e8438fca5fadeba2881c54360d5fd8d03d03a4f4a"
11
12inherit pypi setuptools3
diff --git a/recipes-devtools/python/python3-dotenv_1.1.0.bb b/recipes-devtools/python/python3-dotenv_1.1.0.bb
new file mode 100644
index 00000000..f297e6a6
--- /dev/null
+++ b/recipes-devtools/python/python3-dotenv_1.1.0.bb
@@ -0,0 +1,12 @@
1HOMEPAGE = "https://github.com/theskumar/python-dotenv"
2SUMMARY = "Python Dot Env Handler"
3DESCRIPTION = "Shell Command and Library to write and read .env like files."
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e914cdb773ae44a732b392532d88f072"
7
8PYPI_PACKAGE = "python_dotenv"
9
10SRC_URI[sha256sum] = "41f90bc6f5f177fb41f53e87666db362025010eb28f60a01c9143bfa33a2b2d5"
11
12inherit pypi setuptools3
diff --git a/recipes-devtools/python/python3-flask-cors-virt_3.0.10.bb b/recipes-devtools/python/python3-flask-cors-virt_3.0.10.bb
deleted file mode 100644
index 2b2e2ce6..00000000
--- a/recipes-devtools/python/python3-flask-cors-virt_3.0.10.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1HOMEPAGE = "https://pypi.python.org/pypi/Flask-Cors/"
2SUMMARY = "A Flask extension adding a decorator for CORS support"
3DESCRIPTION = "\
4 A Flask extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible \
5 "
6SECTION = "devel/python"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=118fecaa576ab51c1520f95e98db61ce"
9
10DEPENDS += "python3-six python3-flask"
11
12PYPI_PACKAGE = "Flask-Cors"
13
14SRC_URI[sha256sum] = "b60839393f3b84a0f3746f6cdca56c1ad7426aa738b70d6c61375857823181de"
15
16inherit pypi setuptools3
diff --git a/recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch b/recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch
deleted file mode 100644
index 75fb6558..00000000
--- a/recipes-devtools/python/python3-newrelic/0001-setup.py-tweak-setuptools_scm-version-dependency.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From a61cea5053730f8180eb1fc8b4cb0f94ff4fc176 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 9 Feb 2021 21:31:19 -0500
4Subject: [PATCH] setup.py: tweak setuptools_scm version dependency
5
6The version dependency of <4 isn't showing any issues in builds.
7The oe-core version is 5+, and carrying a secondary version is
8not trivial or something we want to do.
9
10So we tweak the version to accept what we have in oe-core.
11
12Upstream-Status: Inappropriate [embedded specific]
13
14Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
15---
16 setup.py | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/setup.py b/setup.py
20index ade43a9..889a74f 100644
21--- a/setup.py
22+++ b/setup.py
23@@ -132,7 +132,7 @@ kwargs = dict(
24 "git_describe_command": "git describe --dirty --tags --long --match *.*.*.*",
25 "write_to": "newrelic/version.txt",
26 },
27- setup_requires=["setuptools_scm>=3.2,<4"],
28+ setup_requires=["setuptools_scm>=3.2"],
29 description = "New Relic Python Agent",
30 long_description = open(readme_file).read(),
31 url = "https://newrelic.com/docs/python/new-relic-for-python",
32--
332.19.1
34
diff --git a/recipes-devtools/python/python3-newrelic_6.2.0.156.bb b/recipes-devtools/python/python3-newrelic_10.9.0.bb
index 62371f60..a390aff8 100644
--- a/recipes-devtools/python/python3-newrelic_6.2.0.156.bb
+++ b/recipes-devtools/python/python3-newrelic_10.9.0.bb
@@ -8,14 +8,12 @@ SECTION = "devel/python"
8LICENSE = "BSD-3-Clause & MIT & Python-2.0 & BSD-2-Clause & NewRelic" 8LICENSE = "BSD-3-Clause & MIT & Python-2.0 & BSD-2-Clause & NewRelic"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=2b42edef8fa55315f34f2370b4715ca9" 9LIC_FILES_CHKSUM = "file://LICENSE;md5=2b42edef8fa55315f34f2370b4715ca9"
10 10
11SRC_URI[sha256sum] = "3dec4647de67609570c4e305f2b6432a00e0a0940a7ac69660ee92268b49d6e7" 11SRC_URI[sha256sum] = "0741de2138b41a1ae1cfad397878774de4131196d66f1443a23b055d9f47e706"
12 12
13inherit pypi setuptools3 13inherit pypi setuptools3
14 14
15DEPENDS += "python3-setuptools-scm-native" 15DEPENDS += "python3-setuptools-scm-native"
16 16
17SRC_URI += "file://0001-setup.py-tweak-setuptools_scm-version-dependency.patch"
18
19FILES:${PN}-dbg += "\ 17FILES:${PN}-dbg += "\
20 ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/*/.debug \ 18 ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/*/.debug \
21 ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/packages/*/.debug/ \ 19 ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/packages/*/.debug/ \
diff --git a/recipes-devtools/python/python3-sphinx-420.bb b/recipes-devtools/python/python3-sphinx-420.bb
deleted file mode 100644
index 67ecf416..00000000
--- a/recipes-devtools/python/python3-sphinx-420.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & BSD-3-Clause & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=82cc7d23060a75a07b820eaaf75abecf"
6
7PYPI_PACKAGE = "Sphinx"
8
9PV = "4.2.0"
10
11RCONFLICTS:${PN} = "python3-sphinx"
12
13SRC_URI[sha256sum] = "94078db9184491e15bce0a56d9186e0aec95f16ac20b12d00e06d4e36f1058a6"
14
15inherit setuptools3 pypi
diff --git a/recipes-devtools/python/python3-webob_1.8.7.bb b/recipes-devtools/python/python3-webob_1.8.9.bb
index d23ddfd2..4a3ed90e 100644
--- a/recipes-devtools/python/python3-webob_1.8.7.bb
+++ b/recipes-devtools/python/python3-webob_1.8.9.bb
@@ -4,9 +4,9 @@ SECTION = "devel/python"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://docs/license.txt;md5=8ed3584bcc78c16da363747ccabc5af5" 5LIC_FILES_CHKSUM = "file://docs/license.txt;md5=8ed3584bcc78c16da363747ccabc5af5"
6 6
7PYPI_PACKAGE = "WebOb" 7PYPI_PACKAGE = "webob"
8 8
9SRC_URI[sha256sum] = "b64ef5141be559cfade448f044fa45c2260351edcb6a8ef6b7e00c7dcef0c323" 9SRC_URI[sha256sum] = "ad6078e2edb6766d1334ec3dee072ac6a7f95b1e32ce10def8ff7f0f02d56589"
10 10
11inherit setuptools3 pypi 11inherit setuptools3 pypi
12 12