diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-12-01 10:05:22 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-12-07 16:12:33 -0500 |
commit | bf28d9735845d59bcbdbccffa7c1905d6dafe42e (patch) | |
tree | ee816b9ece5bb075851dd1c0afdd45a1ee724ca4 | |
parent | 4169fae1694d98b595922c2401317a6b53a7b652 (diff) | |
download | meta-virtualization-bf28d9735845d59bcbdbccffa7c1905d6dafe42e.tar.gz |
upx: update to latest devel release
The upx development branch history has been rebaseed, so we update
our SRCREV to match.
As part of this update, we can drop our patch as it has now been
merged into the project.
The cmake structure has changed slightly, so we inherit cmake-native
to make it available as part of the Makefile driven build.
And finally, the name and location of the binary has changed, so
we adapt our install rule to match.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/upx/upx/0001-MyCom.h-fix-build-with-gcc-11.patch | 31 | ||||
-rw-r--r-- | recipes-extended/upx/upx_git.bb | 9 |
2 files changed, 5 insertions, 35 deletions
diff --git a/recipes-extended/upx/upx/0001-MyCom.h-fix-build-with-gcc-11.patch b/recipes-extended/upx/upx/0001-MyCom.h-fix-build-with-gcc-11.patch deleted file mode 100644 index 8b07c77e..00000000 --- a/recipes-extended/upx/upx/0001-MyCom.h-fix-build-with-gcc-11.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 8fe8cd22163fe11b791aac15b642d122ea98b9b5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <martin.jansa@lge.com> | ||
3 | Date: Fri, 14 May 2021 02:26:13 -0700 | ||
4 | Subject: [PATCH] MyCom.h: fix build with gcc-11 | ||
5 | |||
6 | * fixes: | ||
7 | ./../src/lzma-sdk/C/7zip/Compress/LZMA/LZMAEncoder.h: In member function 'virtual ULONG NCompress::NLZMA::CEncoder::Release()': | ||
8 | ./../src/lzma-sdk/C/7zip/Compress/LZMA/../../../Common/MyCom.h:159:32: error: this 'if' clause does not guard... [-Werror=misleading-indentation] | ||
9 | 159 | STDMETHOD_(ULONG, Release)() { if (--__m_RefCount != 0) \ | ||
10 | | ^~ | ||
11 | |||
12 | Upstream-Status: Submitted [https://github.com/upx/upx-lzma-sdk/pull/5] | ||
13 | Signed-off-by: Martin Jansa <martin.jansa@lge.com> | ||
14 | --- | ||
15 | C/Common/MyCom.h | 3 +-- | ||
16 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/C/Common/MyCom.h b/C/Common/MyCom.h | ||
19 | index b8dbf38..2e3c54a 100644 | ||
20 | --- a/C/Common/MyCom.h | ||
21 | +++ b/C/Common/MyCom.h | ||
22 | @@ -156,8 +156,7 @@ public: | ||
23 | |||
24 | #define MY_ADDREF_RELEASE \ | ||
25 | STDMETHOD_(ULONG, AddRef)() { return ++__m_RefCount; } \ | ||
26 | -STDMETHOD_(ULONG, Release)() { if (--__m_RefCount != 0) \ | ||
27 | - return __m_RefCount; delete this; return 0; } | ||
28 | +STDMETHOD_(ULONG, Release)() { if (--__m_RefCount != 0) return __m_RefCount; delete this; return 0; } | ||
29 | |||
30 | #define MY_UNKNOWN_IMP_SPEC(i) \ | ||
31 | MY_QUERYINTERFACE_BEGIN \ | ||
diff --git a/recipes-extended/upx/upx_git.bb b/recipes-extended/upx/upx_git.bb index 9f400b1b..989b2776 100644 --- a/recipes-extended/upx/upx_git.bb +++ b/recipes-extended/upx/upx_git.bb | |||
@@ -1,15 +1,16 @@ | |||
1 | HOMEPAGE = "http://upx.sourceforge.net" | 1 | HOMEPAGE = "http://upx.sourceforge.net" |
2 | SUMMARY = "Ultimate executable compressor." | 2 | SUMMARY = "Ultimate executable compressor." |
3 | 3 | ||
4 | SRCREV = "4e1ae22a1a07be5135c68b25ff05058ae8ae48e1" | 4 | SRCREV = "8d1a98e03bf281b2cee459b6c27347e56d13c6a8" |
5 | SRC_URI = "gitsm://github.com/upx/upx;branch=devel;protocol=https \ | 5 | SRC_URI = "gitsm://github.com/upx/upx;branch=devel;protocol=https \ |
6 | file://0001-MyCom.h-fix-build-with-gcc-11.patch;patchdir=src/lzma-sdk \ | ||
7 | " | 6 | " |
8 | 7 | ||
9 | LICENSE = "GPL-2.0-only" | 8 | LICENSE = "GPL-2.0-only" |
10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=353753597aa110e0ded3508408c6374a" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=353753597aa110e0ded3508408c6374a" |
11 | 10 | ||
12 | DEPENDS = "zlib libucl xz" | 11 | DEPENDS = "zlib libucl xz cmake-native" |
12 | |||
13 | # inherit cmake | ||
13 | 14 | ||
14 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
15 | 16 | ||
@@ -29,7 +30,7 @@ do_compile() { | |||
29 | 30 | ||
30 | do_install:append() { | 31 | do_install:append() { |
31 | install -d ${D}${bindir} | 32 | install -d ${D}${bindir} |
32 | install -m 755 ${B}/src/upx.out ${D}${bindir}/upx | 33 | install -m 755 ${B}/build/release/upx ${D}${bindir}/upx |
33 | } | 34 | } |
34 | 35 | ||
35 | BBCLASSEXTEND = "native" | 36 | BBCLASSEXTEND = "native" |