summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-12-10 21:02:01 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-12-10 21:02:19 +0000
commitc1f668c337a56457acacbbefe4d1f1989202ba95 (patch)
treee3db32546163ebf41e699b3b40d1cfab6da6acdc
parent755520c5fd6afeb459c0f6583758e9b4c5e10630 (diff)
downloadmeta-virtualization-c1f668c337a56457acacbbefe4d1f1989202ba95.tar.gz
kernel: add v6.12 configuration and support
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-yocto_6.12_virtualization.inc4
-rw-r--r--recipes-kernel/linux/yocto-cfg-fragments-6.12.bb37
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto_6.12_virtualization.inc b/recipes-kernel/linux/linux-yocto_6.12_virtualization.inc
new file mode 100644
index 00000000..59311487
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_6.12_virtualization.inc
@@ -0,0 +1,4 @@
1# include the baseline meta virtualization configuration options
2# after this include, we can do version specific things
3
4include linux-yocto_virtualization.inc
diff --git a/recipes-kernel/linux/yocto-cfg-fragments-6.12.bb b/recipes-kernel/linux/yocto-cfg-fragments-6.12.bb
new file mode 100644
index 00000000..b5a98d4d
--- /dev/null
+++ b/recipes-kernel/linux/yocto-cfg-fragments-6.12.bb
@@ -0,0 +1,37 @@
1HOMEPAGE = "https://git.yoctoproject.org/cgit/cgit.cgi/yocto-kernel-cache/"
2SUMMARY = "Kernel configuration fragments"
3DESCRIPTION = "Typically used as part of a kernel clone, this is the standalone \
4fragment repository. Making it available to other fragment management schemes \
5"
6SECTION = "devel"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
10
11do_configure[noexec] = "1"
12do_compile[noexec] = "1"
13INHIBIT_DEFAULT_DEPS = "1"
14
15LINUX_VERSION ?= "6.12"
16PV = "v${LINUX_VERSION}+git${SRCREV}"
17
18SRCREV = "38b941ae2f4f28c0ba40b2ba6da466f6f5fe3ba0"
19SRC_URI = "\
20 git://git.yoctoproject.org/yocto-kernel-cache;branch=yocto-${LINUX_VERSION} \
21 "
22
23S = "${WORKDIR}/git"
24
25do_install() {
26 install -d ${D}${base_prefix}/kcfg
27
28 # copy the configuration fragments over to the native deploy
29 cp -r ${S}/* ${D}${base_prefix}/kcfg
30 # scripts bring in a bash dependency we don't want
31 rm -rf ${D}${base_prefix}/kcfg/scripts
32}
33
34FILES:${PN} += "kcfg/"
35SYSROOT_DIRS += "${base_prefix}/kcfg"
36BBCLASSEXTEND = "native nativesdk"
37