diff options
author | Jianchuan Wang <jianchuan.wang@windriver.com> | 2016-09-08 01:35:59 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2016-09-12 10:03:04 -0400 |
commit | c415f9786025622ff253ac21f24eef4755118e82 (patch) | |
tree | 28061c633566b8fadeb2ecbbee9f6fd4024fe0f2 | |
parent | 5e5e09a18199108de29bfee101c7b311ef094d94 (diff) | |
download | meta-virtualization-c415f9786025622ff253ac21f24eef4755118e82.tar.gz |
protobuf-c: uprev to 1.2.1 from 0.15
Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-devtools/protobuf/protobuf-c_0.15.bb | 20 | ||||
-rw-r--r-- | recipes-devtools/protobuf/protobuf-c_1.2.1.bb | 28 |
2 files changed, 28 insertions, 20 deletions
diff --git a/recipes-devtools/protobuf/protobuf-c_0.15.bb b/recipes-devtools/protobuf/protobuf-c_0.15.bb deleted file mode 100644 index 4876d337..00000000 --- a/recipes-devtools/protobuf/protobuf-c_0.15.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | SUMMARY = "protobuf-c" | ||
2 | DESCRIPTION = "This package provides a code generator and runtime libraries to use Protocol Buffers from pure C" | ||
3 | HOMEPAGE = "http://code.google.com/p/protobuf-c/" | ||
4 | SECTION = "console/tools" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://src/google/protobuf-c/protobuf-c.c;endline=33;md5=333140fae7cf8a38dc5f980ddb63704b" | ||
8 | |||
9 | PR = "r1" | ||
10 | |||
11 | DEPENDS = "protobuf" | ||
12 | |||
13 | SRC_URI[md5sum] = "73ff0c8df50d2eee75269ad8f8c07dc8" | ||
14 | SRC_URI[sha256sum] = "8fcb538e13a5431c46168fc8f2e6ad2574e2db9b684c0c72b066e24f010a0036" | ||
15 | SRC_URI = "https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/protobuf-c/protobuf-c-${PV}.tar.gz \ | ||
16 | file://disable_tests.patch" | ||
17 | |||
18 | inherit autotools | ||
19 | |||
20 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-devtools/protobuf/protobuf-c_1.2.1.bb b/recipes-devtools/protobuf/protobuf-c_1.2.1.bb new file mode 100644 index 00000000..ff2499e5 --- /dev/null +++ b/recipes-devtools/protobuf/protobuf-c_1.2.1.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | SUMMARY = "protobuf-c" | ||
2 | DESCRIPTION = "This package provides a code generator and runtime libraries to use Protocol Buffers from pure C" | ||
3 | HOMEPAGE = "http://code.google.com/p/protobuf-c/" | ||
4 | SECTION = "console/tools" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=235c3195a3968524dc1524b4ebea0c0e" | ||
8 | |||
9 | COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" | ||
10 | |||
11 | DEPENDS = "protobuf protobuf-c-native" | ||
12 | |||
13 | SRC_URI[md5sum] = "e544249c329391fff512c3874895cfbe" | ||
14 | SRC_URI[sha256sum] = "846eb4846f19598affdc349d817a8c4c0c68fd940303e6934725c889f16f00bd" | ||
15 | SRC_URI = "https://github.com/protobuf-c/protobuf-c/releases/download/v1.2.1/protobuf-c-1.2.1.tar.gz " | ||
16 | #SRC_URI_append_class-target ="file://0001-protobuf-c-Remove-the-rules-which-depend-on-the-nati.patch" | ||
17 | |||
18 | inherit autotools pkgconfig | ||
19 | |||
20 | BBCLASSEXTEND = "native nativesdk" | ||
21 | |||
22 | do_configure_prepend_class-target() { | ||
23 | export PKG_CONFIG_PATH="${STAGING_LIBDIR_NATIVE}/pkgconfig:${PKG_CONFIG_PATH}" | ||
24 | } | ||
25 | |||
26 | do_install_append_class-native() { | ||
27 | install -m 755 ${B}/t/generated-code2/cxx-generate-packed-data ${D}/${bindir} | ||
28 | } | ||