diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-05-18 13:44:39 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-06-07 16:40:22 -0400 |
commit | c772a5c230edf5a9bf3dc46d21816bd259d17eb2 (patch) | |
tree | 1cbcc0fd77d5f3ced9a7ca3e23db3a236f22d245 | |
parent | ea6911aea4a49a536a0ce7a21168ccb628490809 (diff) | |
download | meta-virtualization-c772a5c230edf5a9bf3dc46d21816bd259d17eb2.tar.gz |
cri-tools: update to v1.27.0
We refresh one patch for context, but otherwise no changes.
Bumping cri-tools to version v1.26.0-186-ge73a7139, which comprises the following commits:
00212a72 Bump github.com/docker/docker
f0bf767c Bump github.com/sirupsen/logrus from 1.9.0 to 1.9.1
c6ca9164 Bump github.com/onsi/ginkgo/v2 from 2.9.4 to 2.9.5
8c87ebfb Bump github.com/docker/distribution
b4fdcd33 Add validation when container OOMKilled
43675ad1 Bump github.com/docker/docker
3a32265d Bump github.com/onsi/ginkgo/v2 from 2.9.2 to 2.9.4
dd924127 Bump golang.org/x/net from 0.9.0 to 0.10.0
557024a5 Fix build flakiness
b2bee82a Bump github.com/urfave/cli/v2 from 2.25.1 to 2.25.3
801d6985 Bump golang.org/x/term from 0.7.0 to 0.8.0
f2e40682 Bump github.com/moby/term
dadffe3e test rm{,i,p} subcommands help message
13dbe21f Add CrictlExpect() to test framework
c714ecd6 Display help when running 'crictl rmi'
4eb6a64b Do not display help when deleting all pods/containers
ce6ad257 Bump github.com/opencontainers/runc from 1.1.6 to 1.1.7
c2c53b77 Bump github.com/docker/docker
deb3bf67 Download release notes tool binary directly
ae7a5eb7 Allow setting CGO_ENABLED
464d6452 Allow overriding GOFLAGS
e64d6e37 Allow providing (additional) custom GO_LDFLAGS
664ef74f Allow setting custom version but use git by default
a2ab0b20 Bump github.com/docker/docker
80bff8b3 Disable dependency gathering for release notes
74092cb9 Vendor Kubernetes v1.27.0
5c6a90bc Update CI badges
5c9d2ee0 Bump github.com/opencontainers/runc from 1.1.5 to 1.1.6
c953d28b golangci-lint: bump to 1.52.2 and fix errors
8d781b8f bump to go 1.20
554b1637 vendor: bump to kube 1.27.0
0497653a Improve text formatting
87cd4d48 Bump golang.org/x/net from 0.8.0 to 0.9.0
e2dc71a2 Bump golang.org/x/term from 0.6.0 to 0.7.0
b8009174 Bump github.com/docker/docker
1f393c4e Bump github.com/onsi/gomega from 1.27.5 to 1.27.6
1dbda3f7 Bump github.com/opencontainers/runc from 1.1.4 to 1.1.5
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch | 17 | ||||
-rw-r--r-- | recipes-containers/cri-tools/cri-tools_git.bb | 4 |
2 files changed, 9 insertions, 12 deletions
diff --git a/recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch b/recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch index 19b48b71..29e0367b 100644 --- a/recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch +++ b/recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch | |||
@@ -35,20 +35,17 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
35 | src/import/Makefile | 3 ++- | 35 | src/import/Makefile | 3 ++- |
36 | 1 file changed, 2 insertions(+), 1 deletion(-) | 36 | 1 file changed, 2 insertions(+), 1 deletion(-) |
37 | 37 | ||
38 | diff --git a/src/import/Makefile b/src/import/Makefile | 38 | Index: cri-tools-1.27.0+gite73a7139ed4986d6a0db784ae7a036841a02b351/src/import/Makefile |
39 | index 7c5b30ec..9b0dfeaf 100644 | 39 | =================================================================== |
40 | --- a/src/import/Makefile | 40 | --- cri-tools-1.27.0+gite73a7139ed4986d6a0db784ae7a036841a02b351.orig/src/import/Makefile |
41 | +++ b/src/import/Makefile | 41 | +++ cri-tools-1.27.0+gite73a7139ed4986d6a0db784ae7a036841a02b351/src/import/Makefile |
42 | @@ -72,7 +72,8 @@ crictl: | 42 | @@ -74,7 +74,8 @@ |
43 | @$(MAKE) -B $(CRICTL) | 43 | @$(MAKE) -B $(CRICTL) |
44 | 44 | ||
45 | $(CRICTL): | 45 | $(CRICTL): |
46 | - CGO_ENABLED=0 $(GO_BUILD) -o $@ \ | 46 | - CGO_ENABLED=$(CGO_ENABLED) $(GO_BUILD) -o $@ \ |
47 | + $(GO_BUILD) -o $@ \ | 47 | + $(GO_BUILD) -o $@ \ |
48 | + -a -pkgdir dontusecurrentpkgs \ | 48 | + -a -pkgdir dontusecurrentpkgs \ |
49 | -ldflags '$(GO_LDFLAGS)' \ | 49 | -ldflags '$(GO_LDFLAGS)' \ |
50 | -trimpath \ | 50 | $(GOFLAGS) \ |
51 | $(PROJECT)/cmd/crictl | 51 | $(PROJECT)/cmd/crictl |
52 | -- | ||
53 | 2.19.1 | ||
54 | |||
diff --git a/recipes-containers/cri-tools/cri-tools_git.bb b/recipes-containers/cri-tools/cri-tools_git.bb index af88998a..77c2f47c 100644 --- a/recipes-containers/cri-tools/cri-tools_git.bb +++ b/recipes-containers/cri-tools/cri-tools_git.bb | |||
@@ -16,7 +16,7 @@ What is not in scope for this project? \ | |||
16 | non-exist on the kube-apiserver. \ | 16 | non-exist on the kube-apiserver. \ |
17 | " | 17 | " |
18 | 18 | ||
19 | SRCREV_cri-tools = "4daea44918cc34b63617c6c9e9923f43d47ddfdd" | 19 | SRCREV_cri-tools = "e73a7139ed4986d6a0db784ae7a036841a02b351" |
20 | SRC_URI = "\ | 20 | SRC_URI = "\ |
21 | git://github.com/kubernetes-sigs/cri-tools.git;branch=master;name=cri-tools;protocol=https \ | 21 | git://github.com/kubernetes-sigs/cri-tools.git;branch=master;name=cri-tools;protocol=https \ |
22 | file://0001-build-allow-environmental-CGO-settings-and-pass-dont.patch \ | 22 | file://0001-build-allow-environmental-CGO-settings-and-pass-dont.patch \ |
@@ -27,7 +27,7 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c2 | |||
27 | 27 | ||
28 | GO_IMPORT = "import" | 28 | GO_IMPORT = "import" |
29 | 29 | ||
30 | PV = "1.26.1+git${SRCREV_cri-tools}" | 30 | PV = "1.27.0+git${SRCREV_cri-tools}" |
31 | 31 | ||
32 | RPROVIDES:${PN} += "crictl" | 32 | RPROVIDES:${PN} += "crictl" |
33 | PACKAGES =+ "${PN}-critest" | 33 | PACKAGES =+ "${PN}-critest" |