diff options
author | Stefan Agner <stefan.agner@toradex.com> | 2019-09-20 09:18:02 +0200 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2019-10-02 14:13:35 -0400 |
commit | c9316391df75fc366b63adbd56b92a7e6e62c46b (patch) | |
tree | 025c65a89fb9207ce9f92ea5c653b2a4faa9d7cb | |
parent | 467ce521e71e462f4f74ab965c110bad50885c67 (diff) | |
download | meta-virtualization-c9316391df75fc366b63adbd56b92a7e6e62c46b.tar.gz |
go-metalinter: add recipe for gometalinter
A tool that concurrently runs a whole bunch of go linters and
normalises their output to a standard format. Useful to build
podman.
Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-devtools/go/go-metalinter_git.bb | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-metalinter_git.bb b/recipes-devtools/go/go-metalinter_git.bb new file mode 100644 index 00000000..668b431a --- /dev/null +++ b/recipes-devtools/go/go-metalinter_git.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "Go Meta Linter." | ||
2 | HOMEPAGE = "https://github.com/alecthomas/gometalinter" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=dee20b35647295553d32faef05846a7b" | ||
6 | |||
7 | BBCLASSEXTEND = "native" | ||
8 | |||
9 | SRCNAME = "gometalinter" | ||
10 | |||
11 | PKG_NAME = "github.com/alecthomas/${SRCNAME}" | ||
12 | SRC_URI = "git://${PKG_NAME}.git" | ||
13 | |||
14 | SRCREV = "e8d801238da6f0dfd14078d68f9b53fa50a7eeb5" | ||
15 | PV = "0.0+git${SRCPV}" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | do_install() { | ||
20 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
21 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
22 | } | ||
23 | |||
24 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||