diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-04-12 15:14:05 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-04-12 15:15:39 -0400 |
commit | cbec1240f96456fc1d2c616af4c150b454e7939a (patch) | |
tree | 2af7c1efb9908849bc271bc204a705fca298b5ac | |
parent | ff18ca2317ff118f39e9f3e8ddfd4533eea55152 (diff) | |
download | meta-virtualization-cbec1240f96456fc1d2c616af4c150b454e7939a.tar.gz |
crun: bump to latest
As part of this update to crun, we now much run autogen.sh before
running configure.
Otherwise, these are incremental changes and comprise the following
commits:
9effaeb On exec, honor additional_gids from the process spec, not the container definition
c25a2db tests: add explicit python3-pip dependency
e67a756 NEWS: tag 0.19
18c0274 gitignore: update
471a7b8 libocispec: update from upstream
f642968 tests: fix check for cgroup v2
3e7fa1d linux: always remount bind mounts
78aeac9 linux: ignore unknown capabilities
f11d742 Add linuxdevicecgroup to maintain parity with runc spec
9aa382b cgroup: skip parsing empty file
d9c9fd0 container: initialize tmp_err
00371ae src: initialize statx struct
2e88d19 src: initialize first_arg
5e4efb7 seccomp: always NUL terminate lowercase_arch
7812572 tests: add test for seccomp listener
f80e98d init: add check for seccomp listener
5d9010b init: fix check for nargs
5a627f4 seccomp: support notify listener
c3361c1 status: use function to convert from yajl errors
873b62d container: use new error function for hooks JSON
14083ab error: new function to convert from yajl errors
6e19235 linux: pass own pid to container process
8fd3320 contrib: new tool to test seccomp notifications
8722858 crun: always use absolute path for the bundle
ae9ea92 container: improve OOM error message
919aac9 utils: receive fd detect closed connection
a52e480 cgroup: new function to detect OOM
2e37d2a sync-libocispec
75ad96b Let autogen.sh generate m4
14c260f libcrun_warn if newuidmap/newgidmap invoke fails
5598401 README.md: drop pids limit comparison
9ea6857 github: add fuzzing test
0fd03ba tests: add container image for fuzzing libcrun
bbd5c7d fuzzer: reap child processes
c7350ef tests: add more fuzzing tests
816f95b fuzzer: merge two tests
effa508 linux: cleanup zombie on errors
b32f1eb linux: release only on error
5ca72f5 status: attempt open again on interrupts
9b5d4c1 Added static analysis Adding clang compilation Fixing comparison of integers of different signs
3b199ef Update GNUmakefile
dcd1a34 linux: label the tmpfs for masked directories
edf7f15 seccomp: check if the action supports errnoRet
bc222b6 seccomp: fail if no default action specified
0c5b920 seccomp: honor default errno value
92c0afe yajl: support static link of containers/yajl
f3d920d src: fix unitialized variable
7d89a02 src: add error check
765971c status: fix memory leak on error
31274d8 utils: fix check for fd
62d1c4d tests: add test to feed honggfuzz
ab75091 ebpf: return the program instead of NULL
8b16552 src: check if seccomp is defined
f721efb container: fix error ownership
4472e35 container: allow config from memory
6b369b8 container: fix memory leak
0fede0f container: initialize variable
2b6c0b6 container: fix dereference of def->linux if NULL
1dd9b5b container: check for def->process before deref
1b1a691 fix: cross-compiling for Android
b25cb2d tests: add device access test
86251b0 ebpf: handle access(dev_name, F_OK) call correctly
e2d79dc fix: access violate if ret < -2
4f35406 cgroup: read controllers from /proc/self/cgroup
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/crun/crun_git.bb | 10 |
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-containers/crun/crun_git.bb b/recipes-containers/crun/crun_git.bb index 18d0c722..107e08b7 100644 --- a/recipes-containers/crun/crun_git.bb +++ b/recipes-containers/crun/crun_git.bb | |||
@@ -3,8 +3,8 @@ LICENSE = "GPLv2" | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
4 | PRIORITY = "optional" | 4 | PRIORITY = "optional" |
5 | 5 | ||
6 | SRCREV_crun = "858ff2f605983ed420b09fd716c9c8e0cee5c174" | 6 | SRCREV_crun = "f302dd8c02c6fddd2c50d1685d82b7a19aae8afe" |
7 | SRCREV_libocispec = "ece5f6aede6488396f9c84bc985df09f95204e1d" | 7 | SRCREV_libocispec = "c9b8b9524814550a489aa6d38b2dec95633ffa15" |
8 | SRCREV_ispec = "79b036d80240ae530a8de15e1d21c7ab9292c693" | 8 | SRCREV_ispec = "79b036d80240ae530a8de15e1d21c7ab9292c693" |
9 | SRCREV_rspec = "7413a7f753e1bd9a6a9c6dc7f96f55888cbbd476" | 9 | SRCREV_rspec = "7413a7f753e1bd9a6a9c6dc7f96f55888cbbd476" |
10 | 10 | ||
@@ -22,12 +22,16 @@ inherit autotools-brokensep pkgconfig | |||
22 | 22 | ||
23 | PACKAGECONFIG ??= "" | 23 | PACKAGECONFIG ??= "" |
24 | 24 | ||
25 | DEPENDS = "yajl libcap go-md2man-native" | 25 | DEPENDS = "yajl libcap go-md2man-native m4-native" |
26 | # TODO: is there a packageconfig to turn this off ? | 26 | # TODO: is there a packageconfig to turn this off ? |
27 | DEPENDS += "libseccomp" | 27 | DEPENDS += "libseccomp" |
28 | DEPENDS += "systemd" | 28 | DEPENDS += "systemd" |
29 | DEPENDS += "oci-image-spec oci-runtime-spec" | 29 | DEPENDS += "oci-image-spec oci-runtime-spec" |
30 | 30 | ||
31 | do_configure_prepend () { | ||
32 | ./autogen.sh | ||
33 | } | ||
34 | |||
31 | do_install() { | 35 | do_install() { |
32 | oe_runmake 'DESTDIR=${D}' install | 36 | oe_runmake 'DESTDIR=${D}' install |
33 | } | 37 | } |