summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-12-04 16:01:16 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-07 23:40:38 -0500
commitcf5a9a95ccfa7b8881a1a063299836b60d5bd529 (patch)
tree3d5ba1896d5300406922cf981cc774061a303ee6
parent35b90160068edb5033a9825f945a58db5939359d (diff)
downloadmeta-virtualization-cf5a9a95ccfa7b8881a1a063299836b60d5bd529.tar.gz
moby: update to v19.03.14
Incorporating the following moby commits: d3c5506330 update containerd binary to v1.3.9 (address CVE-2020-15257) 1babdf81e7 update containerd binary to v1.3.8 f80f6304e2 Bump libnetwork 4b181db52b bump up rootlesskit to v0.11.0 7487dca8a5 docs: fix builder-version swagger c7253a0e1a dockerd-rootless.sh: support containerd v1.4 shim socket path convention 88eec2e811 Also trim "~..." from AppArmor versions ecd3baca25 pkg/aaparser: support parsing version like "3.0.0-beta1" 74c0c5b7f1 Fix gcplogs memory/connection leak 5f32bd9ced awslogs: Update aws-sdk-go to support IMDSv2 8cf9d50fc0 [19.03] vendor: buildkit v0.6.4-32-gdf89d4dc a4e96a486f swagger: fix MemTotal units in SystemInfo endpoint 9fe291827a Bump Golang 1.13.15 a15a770e1b update containerd to v1.3.7 9380ec7397 update containerd to v1.3.6 80cef48453 update containerd to v1.3.5 fc8f88dc14 update containerd to v1.3.4 89a4208757 update containerd binary to v1.3.3 490c45b756 Update containerd to v1.3.2 56d897347d Update containerd to v1.3.1 d4c63720e9 update containerd binary v1.3.0 ec14dc44d1 Fix log file rotation test. a958fc3e65 Fix flakey test for log file rotate. 89da709cb7 Check for context error that is wrapped in url.Error 83baeafc3c oci: correctly use user.GetExecUser interface dae08c333e vendor: vishvananda/netns db3c7e526aae966c4ccfa6c8189b693d6ac5d202 93cb737687 [19.03] vendor: vishvananda/netns 0a2b9b5464df8343199164a0321edf3313202f7e and the following libnetwork commits: 90990763 service_linux: Fix null dereference in findLBEndpointSandbox 8565f0b1 log error instead if disabling IPv6 router advertisement failed and finally, the following cli commits: 01fc5a1ec3 Replace deprecated instruction 3b3e295c4b docs: update 20.03 -> 20.10 in deprecated.md d1b44aa298 docs: fix broken links in build reference 20bc15f618 docs/deprecated: remove minor versions 3172219932 docs: deprecate CLI options for experimental CLI features f132c8ad4a docs: add /go/experimental/ vanity URL df5ca0c950 docs: fix generated YAML due to trailing whitespace 5057d34272 docs: update URL for security landing page 278f30b82b Add test-case for env with, and without = f526bcdb53 builder: add note about alternative syntax 10973d6ddf builder: rephrase ENV section, remove examples for ENV key value without '=' 8c8fb03f15 docs: fix "docker logs" example missing container name c9a03ab5f4 Bash-completion: add CAP_AUDIT_READ ffa0e1d36e docs: document CAP_AUDIT_READ 3d74f7ab48 docs: document optional "CAP_" prefix for capabilities 0a207d5095 docs: sort list of capabilities alphabetically 75411a2233 Complete capabilites with and without "CAP_" prefix. 896eb7123a [19.03] vendor: stop using docker/engine fork for vendoring aebe8b0660 [19.03] vendor: buildkit v0.6.4-32-gdf89d4dc d6b05747dd [19.03] vendor: tonistiigi/fsutil v0.0.0-20191018213012-0f039a052ca1 9a65c1c861 docs/build: add note about git subdirectories with BuildKit a6c15a5e60 Replace vbom.ml/util with fvbommel/sortorder 36cdb166dc Bump Golang 1.13.15 5c5486d910 Replaces ADD with COPY in the COPY section 9152bf265e docs: remove docs for —-from=index e5e227672b Bump Golang 1.13.14 Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/docker/docker-moby.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-containers/docker/docker-moby.bb b/recipes-containers/docker/docker-moby.bb
index 2422c366..03f681a2 100644
--- a/recipes-containers/docker/docker-moby.bb
+++ b/recipes-containers/docker/docker-moby.bb
@@ -35,9 +35,9 @@ DESCRIPTION = "Linux container runtime \
35# to a docker.inc recipe 35# to a docker.inc recipe
36 36
37# moby commit matches the docker-engine bump on the 19.03 branch' 37# moby commit matches the docker-engine bump on the 19.03 branch'
38SRCREV_moby = "88820a4793eabd2a5624e7a16772207cfa073f98" 38SRCREV_moby = "7d75c1d40d88ddef08653dbd611f41df42bdf087"
39SRCREV_libnetwork = "026aabaa659832804b01754aaadd2c0f420c68b6" 39SRCREV_libnetwork = "55e924b8a84231a065879156c0de95aefc5f5435"
40SRCREV_cli = "80fd48bcb7e7cc525078d2cd11cf3cb20ca5bb32" 40SRCREV_cli = "fd3371eb7df1adeceff5935cf3ade0576a0f48d5"
41SRC_URI = "\ 41SRC_URI = "\
42 git://github.com/moby/moby.git;branch=19.03;name=moby \ 42 git://github.com/moby/moby.git;branch=19.03;name=moby \
43 git://github.com/docker/libnetwork.git;branch=bump_19.03;name=libnetwork;destsuffix=git/libnetwork \ 43 git://github.com/docker/libnetwork.git;branch=bump_19.03;name=libnetwork;destsuffix=git/libnetwork \
@@ -59,7 +59,7 @@ GO_IMPORT = "import"
59 59
60S = "${WORKDIR}/git" 60S = "${WORKDIR}/git"
61 61
62DOCKER_VERSION = "19.03.13" 62DOCKER_VERSION = "19.03.14"
63PV = "${DOCKER_VERSION}+git${SRCREV_moby}" 63PV = "${DOCKER_VERSION}+git${SRCREV_moby}"
64 64
65PACKAGES =+ "${PN}-contrib" 65PACKAGES =+ "${PN}-contrib"