diff options
author | sakib.sajal@windriver.com <sakib.sajal@windriver.com> | 2022-11-18 14:40:20 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-11-22 23:32:02 -0500 |
commit | d2cfa7fac8cecb8f843d83fb896795b7bbe86641 (patch) | |
tree | 1259dbd0d1d82811e15bb117654a9cc58fc73a71 | |
parent | 9f41aca8e6cd31ba2752dba5d375cf19009a6ec3 (diff) | |
download | meta-virtualization-d2cfa7fac8cecb8f843d83fb896795b7bbe86641.tar.gz |
ceph: support python 3.11
python3 has been upgraded to 3.11 in oe-core causing
ceph do_configure to fail with the error:
| Could NOT find Python3 (missing: Python3_LIBRARY Python3_INCLUDE_DIR
| Development) (found suitable version "3.6.9", minimum required is "3")
Support python 3.11 to fix the issue
Upstream-Status: sent to upstream (https://github.com/ceph/ceph/pull/48947)
Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.11.patch (renamed from recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.10.patch) | 2 | ||||
-rw-r--r-- | recipes-extended/ceph/ceph_15.2.15.bb | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.10.patch b/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.11.patch index 94c4b8a6..c0b718a2 100644 --- a/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.10.patch +++ b/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.11.patch | |||
@@ -25,7 +25,7 @@ index 6584699b79..c05bbe3306 100644 | |||
25 | endif() | 25 | endif() |
26 | if (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 3) | 26 | if (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 3) |
27 | - set(_${_PYTHON_PREFIX}_VERSIONS 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0) | 27 | - set(_${_PYTHON_PREFIX}_VERSIONS 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0) |
28 | + set(_${_PYTHON_PREFIX}_VERSIONS 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0) | 28 | + set(_${_PYTHON_PREFIX}_VERSIONS 3.11 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0) |
29 | elseif (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 2) | 29 | elseif (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 2) |
30 | set(_${_PYTHON_PREFIX}_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0) | 30 | set(_${_PYTHON_PREFIX}_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0) |
31 | else() | 31 | else() |
diff --git a/recipes-extended/ceph/ceph_15.2.15.bb b/recipes-extended/ceph/ceph_15.2.15.bb index 14b4c978..6312fd31 100644 --- a/recipes-extended/ceph/ceph_15.2.15.bb +++ b/recipes-extended/ceph/ceph_15.2.15.bb | |||
@@ -12,7 +12,7 @@ SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \ | |||
12 | file://0001-ceph-fix-build-errors-for-cross-compile.patch \ | 12 | file://0001-ceph-fix-build-errors-for-cross-compile.patch \ |
13 | file://0001-fix-host-library-paths-were-used.patch \ | 13 | file://0001-fix-host-library-paths-were-used.patch \ |
14 | file://ceph.conf \ | 14 | file://ceph.conf \ |
15 | file://0001-cmake-add-support-for-python3.10.patch \ | 15 | file://0001-cmake-add-support-for-python3.11.patch \ |
16 | file://0001-SnappyCompressor.h-fix-snappy-compiler-error.patch \ | 16 | file://0001-SnappyCompressor.h-fix-snappy-compiler-error.patch \ |
17 | file://0001-buffer.h-add-missing-header-file-due-to-gcc-upgrade.patch \ | 17 | file://0001-buffer.h-add-missing-header-file-due-to-gcc-upgrade.patch \ |
18 | file://0002-common-fix-FTBFS-due-to-dout-need_dynamic-on-GCC-12.patch \ | 18 | file://0002-common-fix-FTBFS-due-to-dout-need_dynamic-on-GCC-12.patch \ |