diff options
author | hongxu <hongxu.jia@eng.windriver.com> | 2025-02-10 16:31:45 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2025-02-18 01:56:29 +0000 |
commit | d329e8245e96eeabab3fe5f0bc35269bf055d01e (patch) | |
tree | 1bd758748b01137e63e68f7de3bbd0ee7b765d46 | |
parent | 7932f4a2fa5f409377cc2ffae09d5a3390988371 (diff) | |
download | meta-virtualization-d329e8245e96eeabab3fe5f0bc35269bf055d01e.tar.gz |
libvirt: fix installed-vs-shipped QA error
In commit [1], upstream added sysusers config file for qemu & kvm user/groups,
the install dir is "install_dir: prefix / 'lib' / 'sysusers.d'".
In commit [2], Yocto created an empty file libvirt-qemu.conf to override
sysusers config file which is added by commit [1]
While usrmerge not in DISTRO_FEATURES, nonarch_base_libdir does not match
install_dir and trigger an installed-vs-shipped QA error
...
ERROR: QA Issue: libvirt: Files/directories were installed but not shipped in any package:
/usr/lib/sysusers.d
/usr/lib/sysusers.d/libvirt-qemu.conf
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
libvirt: 2 installed and not shipped files. [installed-vs-shipped]
...
Use nonarch_libdir to intead of nonarch_base_libdir to match the install dir
in commit [1]
[1] https://github.com/libvirt/libvirt/commit/a2c3e390f7bedf36f4ddc544d09fe3b8772c5c6f
[2] https://git.yoctoproject.org/meta-virtualization/commit/?id=8138d9cc7e0c31171230110db0cfa881c46a821b
Suggested-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/libvirt/libvirt_git.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-extended/libvirt/libvirt_git.bb b/recipes-extended/libvirt/libvirt_git.bb index 432b5da8..b6539bfa 100644 --- a/recipes-extended/libvirt/libvirt_git.bb +++ b/recipes-extended/libvirt/libvirt_git.bb | |||
@@ -95,7 +95,7 @@ FILES:${PN} += "${libdir}/libvirt/connection-driver \ | |||
95 | ${datadir}/bash-completion/completions/vsh \ | 95 | ${datadir}/bash-completion/completions/vsh \ |
96 | ${datadir}/bash-completion/completions/virt-admin \ | 96 | ${datadir}/bash-completion/completions/virt-admin \ |
97 | /usr/lib/firewalld/ \ | 97 | /usr/lib/firewalld/ \ |
98 | ${nonarch_base_libdir}/sysusers.d/ \ | 98 | ${nonarch_libdir}/sysusers.d/ \ |
99 | " | 99 | " |
100 | 100 | ||
101 | FILES:${PN}-dbg += "${libdir}/libvirt/connection-driver/.debug ${libdir}/libvirt/lock-driver/.debug" | 101 | FILES:${PN}-dbg += "${libdir}/libvirt/connection-driver/.debug ${libdir}/libvirt/lock-driver/.debug" |
@@ -204,11 +204,11 @@ do_install:append() { | |||
204 | install -d ${D}/etc/init.d | 204 | install -d ${D}/etc/init.d |
205 | install -d ${D}/etc/libvirt | 205 | install -d ${D}/etc/libvirt |
206 | install -d ${D}/etc/dnsmasq.d | 206 | install -d ${D}/etc/dnsmasq.d |
207 | install -d ${D}${nonarch_base_libdir}/sysusers.d/ | 207 | install -d ${D}${nonarch_libdir}/sysusers.d/ |
208 | 208 | ||
209 | install -m 0755 ${UNPACKDIR}/libvirtd.sh ${D}/etc/init.d/libvirtd | 209 | install -m 0755 ${UNPACKDIR}/libvirtd.sh ${D}/etc/init.d/libvirtd |
210 | install -m 0644 ${UNPACKDIR}/libvirtd.conf ${D}/etc/libvirt/libvirtd.conf | 210 | install -m 0644 ${UNPACKDIR}/libvirtd.conf ${D}/etc/libvirt/libvirtd.conf |
211 | install -m 0644 ${UNPACKDIR}/libvirt-qemu.conf ${D}${nonarch_base_libdir}/sysusers.d/libvirt-qemu.conf | 211 | install -m 0644 ${UNPACKDIR}/libvirt-qemu.conf ${D}${nonarch_libdir}/sysusers.d/libvirt-qemu.conf |
212 | 212 | ||
213 | if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then | 213 | if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then |
214 | # This will wind up in the libvirtd package, but will NOT be invoked by default. | 214 | # This will wind up in the libvirtd package, but will NOT be invoked by default. |