diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-11-01 23:00:58 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-11-01 23:59:13 -0400 |
commit | d5bda44c064d56db98f203f6285bf3b6b9016870 (patch) | |
tree | ec8761c77618d389d085fa10649be4fc762cdd08 | |
parent | 72ea52031c045bb6b4e13856f324b3ec28e333df (diff) | |
download | meta-virtualization-d5bda44c064d56db98f203f6285bf3b6b9016870.tar.gz |
upx: update to -tip and return to indivdual fetches
Bumping upx to version v4.2.4-62-g44e4bd0b, which comprises the following commits:
44e4bd0b CI updates
1427b813 CI updates
a9cb3542 CI and cmake updates
b4db17ab cmake update
ba969fb9 CI updates
87ac252c CI updates
ada9081e CI updates
d6a29e58 CI updates
03c41840 all: misc cleanups
The upx repository has invalid git commits for SRCREVs
greater than 4.2.4 (and for commits that used to work).
This was reported on the mailing list by Javier Tia <javier.tia@linaro.org>
Older commits seem to work, but we'd have issues updating
the recipe to newer values (tip fo the tree is also broken
for gitsm fetching).
So for now, we switch back to individual fetches that we
can use to control the SRCREVs precisely.
SRCREVs are from:
git submodule status | awk '{ commit_hash = $1; sub(/vendor\//, "", $2); gsub("-", "_", $2); printf "SRCREV_vendor_%s = \"%s\"\n", $2, commit_hash }'
with two substitions for invalid SRCREVs (hence why the gitsm fetcher
has issues)
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/upx/upx_git.bb | 30 |
1 files changed, 27 insertions, 3 deletions
diff --git a/recipes-extended/upx/upx_git.bb b/recipes-extended/upx/upx_git.bb index 870f0883..14a986e2 100644 --- a/recipes-extended/upx/upx_git.bb +++ b/recipes-extended/upx/upx_git.bb | |||
@@ -2,12 +2,36 @@ SUMMARY = "Ultimate executable compressor." | |||
2 | HOMEPAGE = "https://upx.github.io/" | 2 | HOMEPAGE = "https://upx.github.io/" |
3 | LICENSE = "GPL-2.0-only" | 3 | LICENSE = "GPL-2.0-only" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=353753597aa110e0ded3508408c6374a" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=353753597aa110e0ded3508408c6374a" |
5 | SRCREV_upx = "03c4184067d8f6cf7a9f7bffd3b92d0035f64eda" | ||
6 | PV = "4.2.4+git${SRCPV}" | ||
7 | 5 | ||
8 | # Note: DO NOT use released tarball in favor of the git repository with submodules. | 6 | # Note: DO NOT use released tarball in favor of the git repository with submodules. |
9 | # it makes maintenance easier for CVEs or other issues. | 7 | # it makes maintenance easier for CVEs or other issues. |
10 | SRC_URI = "gitsm://github.com/upx/upx;protocol=https;;name=upx;branch=devel" | 8 | |
9 | SRCREV_upx = "44e4bd0b5454ff8aee1ff3376974dfe6014300d9" | ||
10 | PV = "4.2.4+git${SRCPV}" | ||
11 | |||
12 | # SRCREVs are from: | ||
13 | # git submodule status | awk '{ commit_hash = $1; sub(/vendor\//, "", $2); gsub("-", "_", $2); printf "SRCREV_vendor_%s = \"%s\"\n", $2, commit_hash }' | ||
14 | # | ||
15 | # with two substitions for invalid SRCREVs (hence why the gitsm fetcher | ||
16 | # has issues) | ||
17 | SRCREV_vendor_doctest = "d5a5b267ecb2f45cdb83d569b24fb920f90e91ca" | ||
18 | SRCREV_vendor_lzma_sdk = "f9637f9f563d17b6ecf33ae2212dcd44866bfb25" | ||
19 | SRCREV_vendor_ucl = "a60611d342b0b7d2924c495ebaa1910e4c3c3fe6" | ||
20 | SRCREV_vendor_valgrind = "b054e44ea1b6d630853ed74d33e0934ef4642efc" | ||
21 | SRCREV_vendor_zlib = "0a41a7d0a974d0b43afe4afe4b8025c8f144474e" | ||
22 | |||
23 | # This is broken for commits newer than 4.2.4 with invalid SRCREVs being reported | ||
24 | # by the git submodules. We switch back to individual fetches while this is | ||
25 | # investigated. | ||
26 | # SRC_URI = "gitsm://github.com/upx/upx;protocol=https;;name=upx;branch=devel" | ||
27 | SRCREV_FORMAT = "upx" | ||
28 | SRC_URI = "git://github.com/upx/upx;name=upx;branch=devel;protocol=https \ | ||
29 | git://github.com/upx/upx-vendor-doctest;name=vendor_doctest;subdir=git/vendor/doctest;branch=upx-vendor;protocol=https \ | ||
30 | git://github.com/upx/upx-vendor-lzma-sdk;name=vendor_lzma_sdk;subdir=git/vendor/lzma-sdk;branch=upx-vendor;protocol=https \ | ||
31 | git://github.com/upx/upx-vendor-ucl;name=vendor_ucl;subdir=git/vendor/ucl;branch=upx-vendor;protocol=https \ | ||
32 | git://github.com/upx/upx-vendor-zlib;name=vendor_zlib;subdir=git/vendor/zlib;branch=upx-vendor;protocol=https \ | ||
33 | git://github.com/upx/upx-vendor-valgrind;name=vendor_valgrind;subdir=git/vendor/valgrind;branch=upx-vendor;protocol=https \ | ||
34 | " | ||
11 | 35 | ||
12 | S = "${WORKDIR}/git" | 36 | S = "${WORKDIR}/git" |
13 | 37 | ||