diff options
author | Xiangyu Chen <xiangyu.chen@windriver.com> | 2023-01-18 13:42:42 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-01-19 15:43:53 -0500 |
commit | f13ced4d8de6b4dbe03fa07f288d77d6f74b51db (patch) | |
tree | 4d6249b689cb77b3d2dd29a1148946b994977c2f | |
parent | 51a891439b51d99e83a997ccd42754ad5fb1fc82 (diff) | |
download | meta-virtualization-f13ced4d8de6b4dbe03fa07f288d77d6f74b51db.tar.gz |
libvirt: fix soruce code comments contain build folder path cause QA Issue warning
gendispatch.pl add build dir in code comments which was generated
by itself. those build dir information would cause yocto qa report
warnings like:
WARNING: libvirt-8.1.0-r0 do_package_qa: QA Issue:
File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapicheckqemu.h in package libvirt-src contains reference to TMPDIR
File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapichecklxc.h in package libvirt-src contains reference to TMPDIR
File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapicheckqemu.c in package libvirt-src contains reference to TMPDIR
File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapichecklxc.c in package libvirt-src contains reference to TMPDIR
File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapicheck.h in package libvirt-src contains reference to TMPDIR
File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapicheck.c in package libvirt-src contains reference to TMPDIR [buildpaths]
Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/libvirt/libvirt/0001-prevent-gendispatch.pl-generating-build-path-in-code.patch | 54 | ||||
-rw-r--r-- | recipes-extended/libvirt/libvirt_8.1.0.bb | 1 |
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt/0001-prevent-gendispatch.pl-generating-build-path-in-code.patch b/recipes-extended/libvirt/libvirt/0001-prevent-gendispatch.pl-generating-build-path-in-code.patch new file mode 100644 index 00000000..5a909b49 --- /dev/null +++ b/recipes-extended/libvirt/libvirt/0001-prevent-gendispatch.pl-generating-build-path-in-code.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From ba915b13b92f3a625633ede43789c1ba780371af Mon Sep 17 00:00:00 2001 | ||
2 | From: Xiangyu Chen <xiangyu.chen@windriver.com> | ||
3 | Date: Wed, 18 Jan 2023 03:19:07 +0000 | ||
4 | Subject: [PATCH] prevent gendispatch.pl generating build path in code comments | ||
5 | |||
6 | gendispatch.pl will add build dir in code comments which was generated | ||
7 | by itself. those build dir information would cause yocto qa report | ||
8 | warnings like: | ||
9 | |||
10 | WARNING: libvirt-8.1.0-r0 do_package_qa: | ||
11 | QA Issue: File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapicheckqemu.h in package libvirt-src contains reference to TMPDIR | ||
12 | File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapichecklxc.h in package libvirt-src contains reference to TMPDIR | ||
13 | File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapicheckqemu.c in package libvirt-src contains reference to TMPDIR | ||
14 | File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapichecklxc.c in package libvirt-src contains reference to TMPDIR | ||
15 | File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapicheck.h in package libvirt-src contains reference to TMPDIR | ||
16 | File /usr/src/debug/libvirt/8.1.0-r0/src/access/viraccessapicheck.c in package libvirt-src contains reference to TMPDIR [buildpaths] | ||
17 | |||
18 | Upstream-Status: Inappropriate [oe specific] | ||
19 | |||
20 | Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com> | ||
21 | --- | ||
22 | src/rpc/gendispatch.pl | 6 +++--- | ||
23 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
24 | |||
25 | diff --git a/src/rpc/gendispatch.pl b/src/rpc/gendispatch.pl | ||
26 | index 9f5bf0e..c73a9dd 100755 | ||
27 | --- a/src/rpc/gendispatch.pl | ||
28 | +++ b/src/rpc/gendispatch.pl | ||
29 | @@ -449,19 +449,19 @@ sub hyper_to_long | ||
30 | |||
31 | if ($mode eq "aclsym") { | ||
32 | print <<__EOF__; | ||
33 | -# Automatically generated from $protocol by gendispatch.pl. | ||
34 | +# Automatically generated by gendispatch.pl. | ||
35 | # Do not edit this file. Any changes you make will be lost. | ||
36 | __EOF__ | ||
37 | } elsif ($mode eq "aclapi") { | ||
38 | print <<__EOF__; | ||
39 | <!-- | ||
40 | - - Automatically generated from $protocol by gendispatch.pl. | ||
41 | + - Automatically generated by gendispatch.pl. | ||
42 | - Do not edit this file. Any changes you make will be lost. | ||
43 | --> | ||
44 | __EOF__ | ||
45 | } else { | ||
46 | print <<__EOF__; | ||
47 | -/* Automatically generated from $protocol by gendispatch.pl. | ||
48 | +/* Automatically generated by gendispatch.pl. | ||
49 | * Do not edit this file. Any changes you make will be lost. | ||
50 | */ | ||
51 | __EOF__ | ||
52 | -- | ||
53 | 2.33.1 | ||
54 | |||
diff --git a/recipes-extended/libvirt/libvirt_8.1.0.bb b/recipes-extended/libvirt/libvirt_8.1.0.bb index 1de2988c..0ffd510b 100644 --- a/recipes-extended/libvirt/libvirt_8.1.0.bb +++ b/recipes-extended/libvirt/libvirt_8.1.0.bb | |||
@@ -29,6 +29,7 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.xz;name=libvirt \ | |||
29 | file://hook_support.py \ | 29 | file://hook_support.py \ |
30 | file://gnutls-helper.py \ | 30 | file://gnutls-helper.py \ |
31 | file://0001-qemu-segmentation-fault-in-virtqemud-executing-qemuD.patch \ | 31 | file://0001-qemu-segmentation-fault-in-virtqemud-executing-qemuD.patch \ |
32 | file://0001-prevent-gendispatch.pl-generating-build-path-in-code.patch \ | ||
32 | " | 33 | " |
33 | 34 | ||
34 | SRC_URI[libvirt.sha256sum] = "3c6c43becffeb34a3f397c616206aa69a893ff8bf5e8208393c84e8e75352934" | 35 | SRC_URI[libvirt.sha256sum] = "3c6c43becffeb34a3f397c616206aa69a893ff8bf5e8208393c84e8e75352934" |