diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2025-01-08 17:55:31 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2025-01-17 19:17:09 +0000 |
commit | fb973818adde64652de52e4db0a15ece8e5d1ecb (patch) | |
tree | 0fb11dbad13360de8bd3358f77d5240f46d38503 | |
parent | f9ba743dad694445f7b7385e03aa0c62cbd71a9d (diff) | |
download | meta-virtualization-fb973818adde64652de52e4db0a15ece8e5d1ecb.tar.gz |
docker: update to v27.5.0-rc.2
Bumping moby to version v27.5.0-rc.2, which comprises the following commits:
a167bc5c9a libnetwork/drivers/windows: fix error-matching for hcsshim "not found"
bdd3a95a13 pkg/fileutils: deprecate GetTotalUsedFds
5f81af6eaa libnetwork/drivers/bridge: format errors with '%v' for consistency
0f45f60e9e libnetwork/drivers/windows: fix non-constant format string
17e8cb2b06 distribution: fix non-constant format string
60f9e333b6 daemon: adjust tests for changes in go1.24 JSON errors
95b2f2ed49 Restore labels when re-creating Windows networks
623af65208 Use the roundtripper during build
771d1dc44e docs/api: allow for an empty string for Isolation (api v1.25-v1.47)
68b39f825d docs: Update example section for SwarmJoinRequest
4767dbd713 api: Allow for an empty string for Isolation in Swagger specs This adds an empty string as a valid option for the Isolation field when inspecting a container. On non windows systems, this is always empty, so no error should be returned. Fixes #47452
4359c8b08e vendor: update buildkit to v0.18.2
bbd14fc508 vendor: update buildkit to v0.18.1
fd86c39cc3 vendor: update buildkit to v0.18.0
1fd14d845f vendor: update buildkit to v0.18.0-rc2
68b0c87e05 vendor: github.com/moby/buildkit 94d0f6ed85e5 (master / v0.18.0-rc.2)
74600d8425 vendor: update buildkit to v0.18.0-rc1
4830f6db66 builder: fall back to defaultKeepStorage if keepStorage is unset for GC policy
0e43d1f642 vendor: github.com/containerd/containerd v1.7.23, hcsshim v0.12.8
800d735171 vendor: github.com/Microsoft/hcsshim v0.12.7
a57c1848b6 vendor: sigs.k8s.io/yaml v1.4.0
26eeb6e414 vendor: github.com/Azure/go-ansiterm v0.0.0-20230124172434-306776ec8161
f6f7c9f231 vendor.mod: github.com/microsoft/hcsshim v0.12.5
bdecc9d58e pkg/reexec: deprecate and migrate to github.com/moby/sys/reexec
46a8e5f8c5 pkg/reexec: Command: separate public API from implementation
d175e4f1f1 pkg/reexec: make platform-agnostic (again)
ed5c0a79e7 pkg/reexec: use const for name of test binary
4bf113f9bd all: Remove redundant `units` alias for `go-units`
7a512a9531 vendor: go.opentelemetry.io/contrib/instrumentation/xxx v0.53.0
cf4e196e77 vendor: go.opentelemetry.io/otel v1.28.0
2a3cc83f36 vendor: google.golang.org/genproto/googleapis/api f6361c86f094
4141379d07 Discard ErrDumpInterrupted and return data after maxRetries
4c50153e2e Fix comments
c5e72db8e8 vendor: github.com/vishvananda/netlink v1.3.1-0.20240922070040-084abd93d350
14b30aeb61 Add linting rules to spot use of un-wrapped netlink functions.
87fc62a648 Fix merge problem
3ca9a3be70 Add nlutil functions to retry on netlink EINTR
4729e446ce vendor: github.com/vishvananda/netlink v1.3.0
cbe4488a6b vendor: github.com/vishvananda/netlink v1.2.1
eda0a20deb libnetwork/iptables: deprecate Passthrough
b51622dd0d libnet/iptables: deprecate type IPV
08de719cf2 libnetwork/drivers/bridge: setupIPChains: fix defer checking wrong err
6855ca1e62 integration-cli: don't skip AppArmor tests on SLES
224b30556d docs/api: document correct case for Api-Version header
5b92b3e7e0 Accurately reflect the canonical casing of `API-Version` and `OS-Type` headers
1df9e896f2 pkg/system: deprecate types and functions that are only used internally
3a1e495a0f daemon: info: remove bridge-nf-call-iptables / ip6tables warnings
4082abad8b Dockerfile: update runc binary to v1.2.3
a379aae924 man: vendor: github.com/cpuguy83/go-md2man v2.0.5
c3968c6ab7 update xx to v1.6.1 for compatibility with alpine 3.21
2e6ca227cf otel: Use non-noop tracer provider for grpc
a5f86f9279 integration/build_traces: Create own tracer provider
3a05c5dcad otel: Avoid excessive memory allocations if not configured
adb8773adb Jenkins: don't modprobe kernel module
ff176d42d5 Don't try to modprobe ip6_tables in the moby dev container
86126b9af1 Try to load kernel module ip6_tables, when necessary.
58318d26fc Use ioctl to try to trigger kernel module loads
4775621ab6 Dockerd rootless: make {/etc,/var/run}/cdi available
0e34b3956b update to go1.22.10
7919b806e7 [27.x] vendor: github.com/moby/buildkit v0.17.3
525b929947 registry: deprecate RepositoryInfo.Class
d6d43b2912 c8d/tag: Don't log a warning if the source image is not dangling
e3564b52af Jenkinsfile: modprobe br_netfilter
46f6b9a259 integration: add wait
18aa104041 daemon/graphdriver/zfs: ignore non-existent dataset on removal
052f7d6461 Fix br_netfilter module loading logic
151c7565a9 Remove buildkit init timeout
465eb6aee2 vendor: github.com/cenkalti/backoff/v4 v4.3.0
e4d5bae9c5 vendor: github.com/go-logr/logr v1.4.2
339572db5d vendor: github.com/prometheus/client_golang v1.20.5
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/docker/docker-moby_git.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb index b16f44fd..d8634da3 100644 --- a/recipes-containers/docker/docker-moby_git.bb +++ b/recipes-containers/docker/docker-moby_git.bb | |||
@@ -44,7 +44,7 @@ DESCRIPTION = "Linux container runtime \ | |||
44 | # so we get that tag, and make it our SRCREVS: | 44 | # so we get that tag, and make it our SRCREVS: |
45 | # | 45 | # |
46 | 46 | ||
47 | SRCREV_moby = "33b6b826c26b05c5e68adc106b6c3b4b44ca5360" | 47 | SRCREV_moby = "43fc912ef59a83054ea7f6706df4d53a7dea4d80" |
48 | SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c" | 48 | SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c" |
49 | SRCREV_cli = "d41cb083c352853f94b292a87df4859c4a96dcc2" | 49 | SRCREV_cli = "d41cb083c352853f94b292a87df4859c4a96dcc2" |
50 | SRCREV_FORMAT = "moby_libnetwork" | 50 | SRCREV_FORMAT = "moby_libnetwork" |
@@ -67,7 +67,7 @@ require docker.inc | |||
67 | LICENSE = "Apache-2.0" | 67 | LICENSE = "Apache-2.0" |
68 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" | 68 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" |
69 | 69 | ||
70 | DOCKER_VERSION = "27.4.0-rc.2" | 70 | DOCKER_VERSION = "27.5.0-rc.2" |
71 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" | 71 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" |
72 | 72 | ||
73 | CVE_PRODUCT = "docker mobyproject:moby" | 73 | CVE_PRODUCT = "docker mobyproject:moby" |