diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-05-31 13:37:42 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-05-31 13:38:28 +0000 |
commit | fd55e2a13b38136337060c0a52c47b7f70a556b6 (patch) | |
tree | 5972dd102daeb95ea3fcd0bd2c85b15cefecb3b5 | |
parent | 6bbe7c32059d8fe81751d63d47496e7f879d1cbc (diff) | |
download | meta-virtualization-fd55e2a13b38136337060c0a52c47b7f70a556b6.tar.gz |
xen: update to 4.18-tip
Bumping xen to version RELEASE-4.18.2-19-g01f7a3c792, which comprises the following commits:
01f7a3c792 update Xen version to 4.18.3-pre
7cdb1fa2ab x86/mtrr: avoid system wide rendezvous when setting AP MTRRs
f3d20dd317 tools/xentop: Fix cpu% sort order
dfabab2cd9 x86: respect mapcache_domain_init() failing
3999b675ca xen/sched: set all sched_resource data inside locked region for new cpu
8271f0e8f2 libxl: Fix handling XenStore errors in device creation
9966e54131 libxl: fix population of the online vCPU bitmap for PVH
a42c83b202 x86/ucode: Distinguish "ucode already up to date"
0673eae8e5 x86/cpu-policy: Fix migration from Ice Lake to Cascade Lake
2bc52041ca tools/libxs: Open /dev/xen/xenbus fds as O_CLOEXEC
a4c5bbb9db VT-d: correct ATS checking for root complex integrated devices
47cf06c09a xen/x86: Fix Syntax warning in gen-cpuid.py
026542c857 xen/xsm: Wire up get_dom0_console
f0ff1d9cb9 x86/spec: adjust logic that elides lfence
0b0c7dca70 x86/spec: fix reporting of BHB clearing usage from guest entry points
eb7059767c x86/MTRR: correct inadvertently inverted WC check
af0e9ba44a x86/rtc: Avoid UIP flag being set for longer than expected
8bdcb0b98b altcall: fix __alt_call_maybe_initdata so it's safe for livepatch
2d38302c33 x86/entry: Fix build with older toolchains
d152a04246 Update CHANGELOG.md with 4.18.2 line
b2863e468e Update Xen version to 4.18.2
40f2c69ad8 x86/spec-ctrl: Support the "long" BHB loop sequence
9be85b14aa x86/spec-ctrl: Wire up the Native-BHI software sequences
72a357f4fa x86/spec-ctrl: Software BHB-clearing sequences
73a4229807 x86/spec-ctrl: Support BHI_DIS_S in order to mitigate BHI
2be76f2018 x86/tsx: Expose RTM_ALWAYS_ABORT to guests
62844c4415 x86: Drop INDIRECT_JMP
9fd732d18d x86: Use indirect calls in reset-stack infrastructure
40a6795480 x86/spec-ctrl: Widen the {xen,last,default}_spec_ctrl fields
fb12e8d8f7 x86/vmx: Add support for virtualize SPEC_CTRL
a6cefb2686 x86/spec-ctrl: Detail the safety properties in SPEC_CTRL_ENTRY_*
ccc6603b79 x86/spec-ctrl: Simplify DO_COND_IBPB
5b28a4af1f x86/spec_ctrl: Hold SCF in %ebx across SPEC_CTRL_ENTRY_{PV,INTR}
9bc337497c x86/entry: Arrange for %r14 to be STACK_END across SPEC_CTRL_ENTRY_FROM_PV
e382cddcc2 x86/spec-ctrl: Rework conditional safety for SPEC_CTRL_ENTRY_*
57e5cab3de x86/spec-ctrl: Rename spec_ctrl_flags to scf
32cdecf1c3 x86/cpuid: Don't expose {IPRED,RRSBA,BHI}_CTRL to PV guests
a482be9211 x86/alternatives: fix .init section reference in _apply_alternatives()
855e261337 x86/tsx: Cope with RTM_ALWAYS_ABORT vs RTM mismatch
125b1a7808 x86/spec-ctrl: Move __read_mostly data into __ro_after_init
594dd0920f VMX: tertiary execution control infrastructure
4c2208d06c x86/CPU: convert vendor hook invocations to altcall
8a8c626281 x86/guest: finish conversion to altcall
b6fad02a54 x86: arrange for ENDBR zapping from <vendor>_ctxt_switch_masking()
0f6696a780 x86/spec-ctrl: Expose BHI_CTRL to guests
a546399829 x86/spec-ctrl: Expose RRSBA_CTRL to guests
fa7f2f9a86 x86/spec-ctrl: Expose IPRED_CTRL to guests
1fe30f552a IRQ: generalize [gs]et_irq_regs()
f7bd03b608 x86/MCE: switch some callback invocations to altcall
9fdbcd84d3 x86/MCE: separate BSP-only initialization
b06cf0701a x86/PV: avoid indirect call for I/O emulation quirk hook
a2922d8097 x86/MTRR: avoid several indirect calls
5c5d4eeee4 core-parking: use alternative_call()
ba951c5f29 x86/HPET: avoid an indirect call
a44c2c9f89 cpufreq: finish conversion to altcall
6b8ee35088 x86/APIC: finish genapic conversion to altcall
6d4055b9a5 x86/spec-ctrl: Fix BTC/SRSO mitigations
1166467ed3 hypercall_xlat_continuation: Replace BUG_ON with domain_crash
429a125dba x86/HVM: clear upper halves of GPRs upon entry from 32-bit code
17cf285d87 tests/resource: Fix HVM guest in !SHADOW builds
5c4aacab17 x86/boot: Support the watchdog on newer AMD systems
a790c670bb x86/boot: Improve the boot watchdog determination of stuck cpus
d0173bbed1 x86/livepatch: Relax permissions on rodata too
4fc27254de xen/virtual-region: Include rodata pointers
8c13f6c565 xen/virtual-region: Rename the start/end fields
b576e09b66 x86/cpu-policy: Fix visibility of HTT/CMP_LEGACY in max policies
03cc579ae3 x86/cpu-policy: Hide x2APIC from PV guests
0a8b92d0a4 tools/oxenstored: Make Quota.t pure
3f3158fc32 tools/oxenstored: Use Map instead of Hashtbl for quotas
c9ea3b49a5 x86/PoD: tie together P2M update and increment of entry count
cb7b84d3d5 x86/boot: Fix setup_apic_nmi_watchdog() to fail more cleanly
62d9ca19f9 x86/mm: use block_lock_speculation() in _mm_write_lock()
3d67ba0371 update Xen version to 4.18.2-pre
ea82c8cdbf update Xen version to 4.18.1
4da8ca9cb9 x86: protect conditional lock taking from speculative execution
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/xen/README.test | 84 | ||||
-rw-r--r-- | recipes-extended/xen/xen_4.18.bb | 4 |
2 files changed, 86 insertions, 2 deletions
diff --git a/recipes-extended/xen/README.test b/recipes-extended/xen/README.test new file mode 100644 index 00000000..4d45aab8 --- /dev/null +++ b/recipes-extended/xen/README.test | |||
@@ -0,0 +1,84 @@ | |||
1 | 1 xl | ||
2 | 2 xl list | ||
3 | 3 xl console | ||
4 | 4 xl console -n 0 | ||
5 | 5 xl -n0 console | ||
6 | 6 xl -n 0 console | ||
7 | 7 xl console -n 0 | ||
8 | 8 xl console Domain-0 | ||
9 | 9 xm | ||
10 | 10 wget | ||
11 | 11 wget https://www.alpinelinux.org/downloads/ | ||
12 | 12 wget https://dl-cdn.alpinelinux.org/alpine/v3.19/releases/x86_64/alpine-standard-3.19.1-x86_64.iso | ||
13 | 13 rm alpine-standard-3.19.1-x86_64.iso | ||
14 | 14 wget https://dl-cdn.alpinelinux.org/alpine/v3.19/releases/x86_64/alpine-virt-3.19.1-x86_64.iso | ||
15 | 15 mount -t iso9660 -o loop /data/alpine-virt-3.19.1-x86_64.iso /media/cdrom | ||
16 | 16 ll | ||
17 | 17 ls | ||
18 | 18 mount -t iso9660 -o loop alpine-virt-3.19.1-x86_64.iso /media/cdrom^ | ||
19 | 19 ls /media/ | ||
20 | 20 mkdir /media/cdrom | ||
21 | 21 mount -t iso9660 -o loop alpine-virt-3.19.1-x86_64.iso /media/cdrom | ||
22 | 22 ls /media/cdrom/ | ||
23 | 23 df -kh . | ||
24 | 24 dd if=/dev/zero of=/data/a1.img bs=1M count=300 | ||
25 | 25 mkdir /data | ||
26 | 26 dd if=/dev/zero of=/data/a1.img bs=1M count=300 | ||
27 | |||
28 | |||
29 | ------------------- | ||
30 | |||
31 | ssh from the host (if using slirp): https://docs.yoctoproject.org/dev-manual/qemu.html | ||
32 | |||
33 | ssh root@127.0.0.1 -p 2222 | ||
34 | |||
35 | ------------------- | ||
36 | |||
37 | Install a guest: | ||
38 | |||
39 | https://wiki.alpinelinux.org/wiki/Create_Alpine_Linux_PV_DomU | ||
40 | |||
41 | |||
42 | ---------------- | ||
43 | |||
44 | Add this: | ||
45 | autoballoon=0 | ||
46 | |||
47 | to: | ||
48 | |||
49 | /etc/xen/xl.conf | ||
50 | |||
51 | ---------------- | ||
52 | |||
53 | # /etc/xen/a1.cfg | ||
54 | |||
55 | # Alpine Linux PV DomU | ||
56 | |||
57 | # Kernel paths for install | ||
58 | kernel = "/media/cdrom/boot/vmlinuz-virt" | ||
59 | ramdisk = "/media/cdrom/boot/initramfs-virt" | ||
60 | extra="modules=loop,squashfs console=hvc0" | ||
61 | |||
62 | # Path to HDD and iso file | ||
63 | disk = [ | ||
64 | 'format=raw, vdev=xvda, access=w, target=/data/a1.img', | ||
65 | 'format=raw, vdev=xvdc, access=r, devtype=cdrom, target=/home/root/alpine-virt-3.19.1-x86_64.iso' | ||
66 | ] | ||
67 | |||
68 | # Network configuration | ||
69 | vif = ['bridge=br0'] | ||
70 | |||
71 | # DomU settings | ||
72 | memory = 512 | ||
73 | name = "wqalpine-a1" | ||
74 | vcpus = 1 | ||
75 | maxvcpus = 1 | ||
76 | |||
77 | device_model_version="qemu-xen" | ||
78 | device_model_override="/bin/true" | ||
79 | |||
80 | --------------------------- | ||
81 | |||
82 | xl create -f /etc/xen/a1.cfg -c | ||
83 | |||
84 | |||
diff --git a/recipes-extended/xen/xen_4.18.bb b/recipes-extended/xen/xen_4.18.bb index 2ad7704e..4f235bd3 100644 --- a/recipes-extended/xen/xen_4.18.bb +++ b/recipes-extended/xen/xen_4.18.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | # tag: RELEASE-4.18.0 | 1 | # tag: RELEASE-4.18.0 |
2 | SRCREV ?= "4da8ca9cb9cfdb92c9dd09d5270ae16a3b2dbc89" | 2 | SRCREV ?= "01f7a3c792241d348a4e454a30afdf6c0d6cd71c" |
3 | 3 | ||
4 | XEN_REL ?= "4.18" | 4 | XEN_REL ?= "4.18.2" |
5 | XEN_BRANCH ?= "stable-4.18" | 5 | XEN_BRANCH ?= "stable-4.18" |
6 | 6 | ||
7 | SRC_URI = " \ | 7 | SRC_URI = " \ |