diff options
author | Christopher Clark <christopher.w.clark@gmail.com> | 2021-04-24 01:30:58 -0700 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-04-29 23:05:11 -0400 |
commit | d82cc67a23f5599367a27252c715ef5b13675736 (patch) | |
tree | d1e4b1141f671823a9d55673d74e2cb680cfe415 /dynamic-layers/raspberrypi | |
parent | c3f729252f44ac1145116abeec45679d15046418 (diff) | |
download | meta-virtualization-d82cc67a23f5599367a27252c715ef5b13675736.tar.gz |
xen, rpi4, linux-yocto: enable linux-yocto 5.10 for RPi4
Added to the raspberrypi dynamic layer for use with Xen as
preparation for switching to it as the default preference.
Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'dynamic-layers/raspberrypi')
3 files changed, 14 insertions, 4 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend index 2a0416f7..8381e447 100644 --- a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend +++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend | |||
@@ -1,10 +1,8 @@ | |||
1 | # For a Xen-enabled distro on the Raspberry Pi, override the contents of cmdline.txt | 1 | # For a Xen-enabled distro on the Raspberry Pi, override the contents of cmdline.txt |
2 | # with Xen-on-ARM-specific command line options | 2 | # with Xen-on-ARM-specific command line options |
3 | 3 | ||
4 | DEFAULT_CMDLINE := "${CMDLINE}" | ||
5 | XEN_LINUX_CMDLINE ?= "console=hvc0 clk_ignore_unused earlycon=xenboot debug root=/dev/mmcblk0p2 rootwait" | ||
6 | CMDLINE = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${XEN_LINUX_CMDLINE}', '${DEFAULT_CMDLINE}', d)}" | ||
7 | |||
8 | KBRANCH_raspberrypi4-64 ?= "standard/bcm-2xxx-rpi" | 4 | KBRANCH_raspberrypi4-64 ?= "standard/bcm-2xxx-rpi" |
9 | KMACHINE_raspberrypi4-64 ?= "bcm-2xxx-rpi4" | 5 | KMACHINE_raspberrypi4-64 ?= "bcm-2xxx-rpi4" |
10 | COMPATIBLE_MACHINE_raspberrypi4-64 = "(raspberrypi4-64)" | 6 | COMPATIBLE_MACHINE_raspberrypi4-64 = "(raspberrypi4-64)" |
7 | |||
8 | require linux-yocto_xen-rpi.inc | ||
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_5.10.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_5.10.bbappend new file mode 100644 index 00000000..af92493d --- /dev/null +++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_5.10.bbappend | |||
@@ -0,0 +1,6 @@ | |||
1 | # Enable use of the linux-yocto 5.10 kernel for the Raspberry Pi 4 | ||
2 | KBRANCH_raspberrypi4-64 ?= "v5.10/standard/bcm-2xxx-rpi" | ||
3 | KMACHINE_raspberrypi4-64 ?= "bcm-2xxx-rpi4" | ||
4 | COMPATIBLE_MACHINE_raspberrypi4-64 = "(raspberrypi4-64)" | ||
5 | |||
6 | require linux-yocto_xen-rpi.inc | ||
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_xen-rpi.inc b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_xen-rpi.inc new file mode 100644 index 00000000..e8c120d4 --- /dev/null +++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_xen-rpi.inc | |||
@@ -0,0 +1,6 @@ | |||
1 | # For a Xen-enabled distro on the Raspberry Pi, override the contents of cmdline.txt | ||
2 | # with Xen-on-ARM-specific command line options | ||
3 | |||
4 | DEFAULT_CMDLINE := "${CMDLINE}" | ||
5 | XEN_LINUX_CMDLINE ?= "console=hvc0 clk_ignore_unused earlycon=xenboot debug root=/dev/mmcblk0p2 rootwait" | ||
6 | CMDLINE = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${XEN_LINUX_CMDLINE}', '${DEFAULT_CMDLINE}', d)}" | ||