diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-09-21 18:08:21 -0700 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-09-22 15:51:20 -0400 |
commit | 2ee6fcd29b34638f8c0e98e5068150b6af9c76be (patch) | |
tree | 5c69c78173d1c72a9d40c1d872dfde13e97b522c /dynamic-layers | |
parent | d945c7a9ededce73a5164089d84cea27a7db43c3 (diff) | |
download | meta-virtualization-2ee6fcd29b34638f8c0e98e5068150b6af9c76be.tar.gz |
dynamic-layers: add xilinx dynamic layer for Xen support
Although this dynamic layer currently only adds Xen support, it will
eventually hold other board and platform specific tweaks to core
meta-virt recipes.
Signed-off-by: Bruce Ashfield <bruce.ashfield@xilinx.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'dynamic-layers')
3 files changed, 16 insertions, 0 deletions
diff --git a/dynamic-layers/xilinx/recipes-extended/xen/xen-xilinx.inc b/dynamic-layers/xilinx/recipes-extended/xen/xen-xilinx.inc new file mode 100644 index 00000000..344061aa --- /dev/null +++ b/dynamic-layers/xilinx/recipes-extended/xen/xen-xilinx.inc | |||
@@ -0,0 +1,14 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
2 | |||
3 | DEPENDS += "u-boot-mkimage-native" | ||
4 | DEPENDS += "dtc-native" | ||
5 | |||
6 | XENIMAGE_KERNEL_LOADADDRESS ?= "0x6000000" | ||
7 | do_deploy_append() { | ||
8 | if [ -f ${DEPLOYDIR}/xen-${MACHINE} ]; then | ||
9 | uboot-mkimage -A arm64 -T kernel -a ${XENIMAGE_KERNEL_LOADADDRESS} -e ${XENIMAGE_KERNEL_LOADADDRESS} -C none -d ${DEPLOYDIR}/xen-${MACHINE} ${DEPLOYDIR}/xen.ub | ||
10 | fi | ||
11 | } | ||
12 | |||
13 | deltask do_deploy_setscene | ||
14 | deltask do_populate_sysroot_setscene | ||
diff --git a/dynamic-layers/xilinx/recipes-extended/xen/xen_4.14.bbappend b/dynamic-layers/xilinx/recipes-extended/xen/xen_4.14.bbappend new file mode 100644 index 00000000..54edd1ba --- /dev/null +++ b/dynamic-layers/xilinx/recipes-extended/xen/xen_4.14.bbappend | |||
@@ -0,0 +1 @@ | |||
include xen-xilinx.inc | |||
diff --git a/dynamic-layers/xilinx/recipes-extended/xen/xen_git.bbappend b/dynamic-layers/xilinx/recipes-extended/xen/xen_git.bbappend new file mode 100644 index 00000000..54edd1ba --- /dev/null +++ b/dynamic-layers/xilinx/recipes-extended/xen/xen_git.bbappend | |||
@@ -0,0 +1 @@ | |||
include xen-xilinx.inc | |||