diff options
author | Tim Orling <tim.orling@konsulko.com> | 2024-07-20 23:12:55 -0700 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-07-22 22:16:32 +0000 |
commit | 4e5c323154e6ea7da8ed54e65eecb724bb002ad7 (patch) | |
tree | 9a93178929e6922f1ce9df704f106f6604b87b9e /dynamic-layers | |
parent | 6c52d3e88b75e2b5e1a0230f684c8c156f23353a (diff) | |
download | meta-virtualization-4e5c323154e6ea7da8ed54e65eecb724bb002ad7.tar.gz |
xen-rpi-u-boot-scr: WORKDIR -> UNPACKDIR transition
Borrowed from Leon Anavi <leon.anavi@konsulko.com>
meta-raspberrypi: commit 434ed33c90b7659152b1e8d7c2d4d785db85105f
and from Martin Jansa <martin.jansa@gmail.com>
meta-raspberrypi: commit c39c2b165e68388767f54dc86acf4595a33ee1e1
This adapts to the oe-core rework to enforce a separate directory
for unpacking local sources (UNPACKDIR) instead of directly using
WORKDIR.
Follows the preliminary guideline from:
https://lists.openembedded.org/g/openembedded-architecture/message/2007
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/raspberrypi/recipes-bsp/xen-rpi-u-boot-scr/xen-rpi-u-boot-scr.bb | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-bsp/xen-rpi-u-boot-scr/xen-rpi-u-boot-scr.bb b/dynamic-layers/raspberrypi/recipes-bsp/xen-rpi-u-boot-scr/xen-rpi-u-boot-scr.bb index 87619d01..3f83c7f8 100644 --- a/dynamic-layers/raspberrypi/recipes-bsp/xen-rpi-u-boot-scr/xen-rpi-u-boot-scr.bb +++ b/dynamic-layers/raspberrypi/recipes-bsp/xen-rpi-u-boot-scr/xen-rpi-u-boot-scr.bb | |||
@@ -17,13 +17,16 @@ do_compile() { | |||
17 | -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \ | 17 | -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \ |
18 | -e 's/@@RPI_DOM0_MEM@@/${RPI_DOM0_MEM}/' \ | 18 | -e 's/@@RPI_DOM0_MEM@@/${RPI_DOM0_MEM}/' \ |
19 | -e 's/@@RPI_DEBUG_XEN_ARGS@@/${RPI_DEBUG_XEN_ARGS}/' \ | 19 | -e 's/@@RPI_DEBUG_XEN_ARGS@@/${RPI_DEBUG_XEN_ARGS}/' \ |
20 | "${WORKDIR}/boot.cmd.xen.in" > "${WORKDIR}/boot.cmd" | 20 | "${UNPACKDIR}/boot.cmd.xen.in" > "${WORKDIR}/boot.cmd" |
21 | 21 | ||
22 | mkimage -A ${UBOOT_ARCH} -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr | 22 | mkimage -A ${UBOOT_ARCH} -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr |
23 | } | 23 | } |
24 | 24 | ||
25 | inherit kernel-arch deploy nopackages | 25 | inherit kernel-arch deploy nopackages |
26 | 26 | ||
27 | S = "${WORKDIR}/sources" | ||
28 | UNPACKDIR = "${S}" | ||
29 | |||
27 | do_deploy() { | 30 | do_deploy() { |
28 | install -d ${DEPLOYDIR} | 31 | install -d ${DEPLOYDIR} |
29 | install -m 0644 boot.scr ${DEPLOYDIR} | 32 | install -m 0644 boot.scr ${DEPLOYDIR} |