summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-07-30 17:09:43 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-08-02 22:57:14 -0400
commit67c011572a6b700ea8eeee14ef37fe9c894f06e3 (patch)
tree018b89249ce539e44e4df446b6172bdbffab2683 /recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
parentb1c810c812cc57691659a13b75fba2d0620fa70c (diff)
downloadmeta-virtualization-67c011572a6b700ea8eeee14ef37fe9c894f06e3.tar.gz
criu: uprev to version 3.10
A fairly straightforward uprev requiring minimal patch refreshing since a few hunks were failing due to conflicts with upstream updates. Unfortunately upstream starting using the now overloaded "PYTHON" variable in their Makefiles, this is not the path to the python executable but rather the name 'python2' or 'python3' which is used to determine which local directories to include. Due to this we must explicitly assign values to 'PYTHON_FULL' and 'PYTHON'. We use 'python2' since we are using 'setuptools' and therefore are explicitly using python v2, at some point we might want to make this recipe work with either python v2 or v3 but for now we continue to explicitly use v2. Instead of using version specific filename we switch to using _git.bb which is inline with similar 'git' recipes found in oe-core and other repos. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch')
-rw-r--r--recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
index 59e7bcbf..70ccb287 100644
--- a/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
+++ b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch
@@ -17,12 +17,12 @@ diff --git a/lib/Makefile b/lib/Makefile
17index b1bb057..06f5c5d 100644 17index b1bb057..06f5c5d 100644
18--- a/lib/Makefile 18--- a/lib/Makefile
19+++ b/lib/Makefile 19+++ b/lib/Makefile
20@@ -56,7 +56,7 @@ install: lib-c lib-py crit/crit lib/c/criu.pc.in 20@@ -53,7 +53,7 @@ install: lib-c lib-py crit/crit lib/c/criu.pc.in
21 $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)/criu/),' lib/c/criu.pc.in > lib/c/criu.pc 21 $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)/criu/),' lib/c/criu.pc.in > lib/c/criu.pc
22 $(Q) install -m 644 lib/c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig 22 $(Q) install -m 644 lib/c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig
23 $(E) " INSTALL " crit 23 $(E) " INSTALL " crit
24- $(Q) $(PYTHON_BIN) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES) 24- $(Q) $(PYTHON) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES)
25+ $(Q) $(PYTHON_BIN) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES) --install-lib=$(DESTDIR)$(INSTALL_LIB) 25+ $(Q) $(PYTHON) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES) --install-lib=$(DESTDIR)$(INSTALL_LIB)
26 .PHONY: install 26 .PHONY: install
27 27
28 uninstall: 28 uninstall: