diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2017-09-08 17:02:31 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-09-10 22:36:02 -0400 |
commit | ba35378ce5e24f2bfcb85caa806774b873983d9f (patch) | |
tree | c57c52175acf67f02ffac62234a9c1b3c7927551 /recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch | |
parent | 8d40af1278ead368afe14bce8713145730b453a2 (diff) | |
download | meta-virtualization-ba35378ce5e24f2bfcb85caa806774b873983d9f.tar.gz |
criu: uprev to version 3.4
Our current version of criu is about a year old and has some
compilation issues with the latest gcc (currently it is
unbuildable). Since the version of criu and the kernel version are
fairly tightly coupled it wouldn't be surprising of this old criu
would also be exhibiting some runtime issues with our fairly new
kernel version.
With the above in mind we uprev to criu v3.4 which was recently
released. This requires several of the patches to be updated (mostly
context). We are able to drop the selinux related change as RSS
prevents the situation this was working around from happenning.
This was validated using https://criu.org/Simple_loop (and a few
variants).
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch')
-rw-r--r-- | recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch | 16 |
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch index 8bda8c42..c2512a0e 100644 --- a/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch +++ b/recipes-containers/criu/files/lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 2e0c5c66786016f6443da2c1ff15ad77f018ec9b Mon Sep 17 00:00:00 2001 | 1 | From 89f9b87904bd312b817ffaa7d83abfd5e84d723d Mon Sep 17 00:00:00 2001 |
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | 2 | From: Mark Asselstine <mark.asselstine@windriver.com> |
3 | Date: Mon, 24 Apr 2017 16:12:05 -0400 | 3 | Date: Fri, 8 Sep 2017 15:40:49 -0400 |
4 | Subject: [PATCH] lib/Makefile: overwrite install-lib, to allow multiarch | 4 | Subject: [PATCH] lib/Makefile: overwrite install-lib, to allow multiarch |
5 | 5 | ||
6 | I am not sure why Yocto installs python modules in arch specific | 6 | I am not sure why Yocto installs python modules in arch specific |
@@ -13,15 +13,15 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | |||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | 13 | 1 file changed, 1 insertion(+), 1 deletion(-) |
14 | 14 | ||
15 | diff --git a/lib/Makefile b/lib/Makefile | 15 | diff --git a/lib/Makefile b/lib/Makefile |
16 | index f1c0821..c714d12 100644 | 16 | index b1bb057..06f5c5d 100644 |
17 | --- a/lib/Makefile | 17 | --- a/lib/Makefile |
18 | +++ b/lib/Makefile | 18 | +++ b/lib/Makefile |
19 | @@ -56,7 +56,7 @@ install: lib-c lib-py ../crit/crit c/criu.pc.in | 19 | @@ -56,7 +56,7 @@ install: lib-c lib-py crit/crit lib/c/criu.pc.in |
20 | $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)),' c/criu.pc.in > c/criu.pc | 20 | $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)/criu/),' lib/c/criu.pc.in > lib/c/criu.pc |
21 | $(Q) install -m 644 c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig | 21 | $(Q) install -m 644 lib/c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig |
22 | $(E) " INSTALL " crit | 22 | $(E) " INSTALL " crit |
23 | - $(Q) python ../scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --record $(CRIT_SETUP_FILES) | 23 | - $(Q) $(PYTHON_BIN) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES) |
24 | + $(Q) python ../scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --record $(CRIT_SETUP_FILES) --install-lib=$(INSTALL_LIB) | 24 | + $(Q) $(PYTHON_BIN) scripts/crit-setup.py install --prefix=$(DESTDIR)$(PREFIX) --record $(CRIT_SETUP_FILES) --install-lib=$(DESTDIR)$(INSTALL_LIB) |
25 | .PHONY: install | 25 | .PHONY: install |
26 | 26 | ||
27 | uninstall: | 27 | uninstall: |