summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/files/protobuf-allow-running-python-scripts-from-anywhere.patch
diff options
context:
space:
mode:
authorZumeng Chen <zumeng.chen@windriver.com>2016-05-19 23:57:27 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-05-20 12:36:54 -0400
commit823c8cfcdf107a7cf6a7b2f39bc9c15fd81b9f78 (patch)
treea0a7cc22b4c61bc7b5d5f32bf582ebc821d19e37 /recipes-containers/criu/files/protobuf-allow-running-python-scripts-from-anywhere.patch
parent3c3293e6b8a8c7a180a8eb0e450c0f0a99e055f4 (diff)
downloadmeta-virtualization-823c8cfcdf107a7cf6a7b2f39bc9c15fd81b9f78.tar.gz
criu: remove protobuf-2.6.1 and the related
Since CRIU does not explicitly nominate the version of protobuf as 2.6.1, which should not be included just here. And it seems protobuf-2.5.0 is doable or this CRIU version based on a basic testing according to criu.org/Simple_loop as well, so remove it from criu. Signed-off-by: Zumeng Chen <zumeng.chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/criu/files/protobuf-allow-running-python-scripts-from-anywhere.patch')
-rw-r--r--recipes-containers/criu/files/protobuf-allow-running-python-scripts-from-anywhere.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/recipes-containers/criu/files/protobuf-allow-running-python-scripts-from-anywhere.patch b/recipes-containers/criu/files/protobuf-allow-running-python-scripts-from-anywhere.patch
deleted file mode 100644
index 13d4e848..00000000
--- a/recipes-containers/criu/files/protobuf-allow-running-python-scripts-from-anywhere.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From 46e331263eb92e47510e88478b255f226d30245c Mon Sep 17 00:00:00 2001
2From: Keith Holman <Keith.Holman@windriver.com>
3Date: Mon, 18 Aug 2014 15:19:35 -0400
4Subject: [PATCH] protobuf: allow running python scripts from anywhere
5
6The Makefile to generate the examples with Google Protocol Buffers
7generates some scripts for python. However, these generated scripts
8only work if they are ran in the same directory as the source files.
9This fix generates scripts to execute from anywhere on the system.
10
11Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
12---
13 examples/Makefile | 6 ++++--
14 1 file changed, 4 insertions(+), 2 deletions(-)
15
16diff --git a/examples/Makefile b/examples/Makefile
17index 8dc9083..a993d63 100644
18--- a/examples/Makefile
19+++ b/examples/Makefile
20@@ -48,11 +48,13 @@ list_people_java: javac_middleman
21 add_person_python: add_person.py protoc_middleman
22 @echo "Writing shortcut script add_person_python..."
23 @echo '#! /bin/sh' > add_person_python
24- @echo './add_person.py "$$@"' >> add_person_python
25+ @echo 'SCRIPT_DIR=$$(dirname $$0)' >> add_person_python
26+ @echo '$$SCRIPT_DIR/add_person.py "$$@"' >> add_person_python
27 @chmod +x add_person_python
28
29 list_people_python: list_people.py protoc_middleman
30 @echo "Writing shortcut script list_people_python..."
31 @echo '#! /bin/sh' > list_people_python
32- @echo './list_people.py "$$@"' >> list_people_python
33+ @echo 'SCRIPT_DIR=$$(dirname $$0)' >> list_people_python
34+ @echo '$$SCRIPT_DIR/list_people.py "$$@"' >> list_people_python
35 @chmod +x list_people_python
36--
371.9.3
38