diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-02-06 13:01:33 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-02-06 13:01:33 -0500 |
commit | 42ec3cb5bf5a93186bc2e709a5b67981718bb61a (patch) | |
tree | 151673dfa3788b9c4a7b846d37a6db597a086d2c /recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | |
parent | 7b8da52f5f7bc235df17321a1043d9f279aafe7d (diff) | |
download | meta-virtualization-42ec3cb5bf5a93186bc2e709a5b67981718bb61a.tar.gz |
docker-compose: update to 1.28.2
Along with the version bump, we refresh our dependency patch to
apply.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch')
-rw-r--r-- | recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | 19 |
1 files changed, 8 insertions, 11 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch index 2c25f69d..2576bb1d 100644 --- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch +++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | |||
@@ -14,11 +14,11 @@ Signed-off-by: Ming Liu <liu.ming50@gmail.com> | |||
14 | setup.py | 24 ++++++++++++------------ | 14 | setup.py | 24 ++++++++++++------------ |
15 | 1 file changed, 12 insertions(+), 12 deletions(-) | 15 | 1 file changed, 12 insertions(+), 12 deletions(-) |
16 | 16 | ||
17 | diff --git a/setup.py b/setup.py | 17 | Index: docker-compose-1.28.2/setup.py |
18 | index e0d4340e..80ffefe5 100644 | 18 | =================================================================== |
19 | --- a/setup.py | 19 | --- docker-compose-1.28.2.orig/setup.py |
20 | +++ b/setup.py | 20 | +++ docker-compose-1.28.2/setup.py |
21 | @@ -25,17 +25,17 @@ def find_version(*file_paths): | 21 | @@ -25,17 +25,17 @@ |
22 | 22 | ||
23 | 23 | ||
24 | install_requires = [ | 24 | install_requires = [ |
@@ -29,7 +29,7 @@ index e0d4340e..80ffefe5 100644 | |||
29 | - 'texttable >= 0.9.0, < 2', | 29 | - 'texttable >= 0.9.0, < 2', |
30 | - 'websocket-client >= 0.32.0, < 1', | 30 | - 'websocket-client >= 0.32.0, < 1', |
31 | - 'distro >= 1.5.0, < 2', | 31 | - 'distro >= 1.5.0, < 2', |
32 | - 'docker[ssh] >= 4.3.1, < 5', | 32 | - 'docker[ssh] >= 4.4.0, < 5', |
33 | - 'dockerpty >= 0.4.1, < 1', | 33 | - 'dockerpty >= 0.4.1, < 1', |
34 | - 'jsonschema >= 2.5.1, < 4', | 34 | - 'jsonschema >= 2.5.1, < 4', |
35 | - 'python-dotenv >= 0.13.0, < 1', | 35 | - 'python-dotenv >= 0.13.0, < 1', |
@@ -40,14 +40,14 @@ index e0d4340e..80ffefe5 100644 | |||
40 | + 'texttable >= 0.9.0', | 40 | + 'texttable >= 0.9.0', |
41 | + 'websocket-client >= 0.32.0', | 41 | + 'websocket-client >= 0.32.0', |
42 | + 'distro >= 1.5.0', | 42 | + 'distro >= 1.5.0', |
43 | + 'docker[ssh] >= 4.3.1', | 43 | + 'docker[ssh] >= 4.4.0', |
44 | + 'dockerpty >= 0.4.1', | 44 | + 'dockerpty >= 0.4.1', |
45 | + 'jsonschema >= 2.5.1', | 45 | + 'jsonschema >= 2.5.1', |
46 | + 'python-dotenv >= 0.13.0', | 46 | + 'python-dotenv >= 0.13.0', |
47 | ] | 47 | ] |
48 | 48 | ||
49 | 49 | ||
50 | @@ -51,7 +51,7 @@ if sys.version_info[:2] < (3, 4): | 50 | @@ -51,7 +51,7 @@ |
51 | extras_require = { | 51 | extras_require = { |
52 | ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'], | 52 | ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'], |
53 | ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], | 53 | ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], |
@@ -56,6 +56,3 @@ index e0d4340e..80ffefe5 100644 | |||
56 | 'tests': tests_require, | 56 | 'tests': tests_require, |
57 | } | 57 | } |
58 | 58 | ||
59 | -- | ||
60 | 2.28.0 | ||
61 | |||