diff options
author | Ming Liu <ming.liu@toradex.com> | 2020-06-26 18:16:01 +0200 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-07-01 12:43:16 -0400 |
commit | a1d06c7470c7a1e57c88fc2479559ace4b67db26 (patch) | |
tree | 4fdfd4cdabd061e201592eb4ae9c6423b619431c /recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | |
parent | 14a9247a1026842e9f813fe6f20e7c4ffd54bfb9 (diff) | |
download | meta-virtualization-a1d06c7470c7a1e57c88fc2479559ace4b67db26.tar.gz |
python3-docker-compose: uprev 1.25.5 > 1.26.0
The major changes include:
d4451659 Bump 1.26.0
3d94f442 Bump 1.26.0-rc5
1386a855 Merge pull request #7485 from ulyssessouza/fix-https-daemon
8034c96d Bump docker-py
48d09369 Fix flake8 errors
28bf47ce Pin wcwidth==0.1.9
d279b7a8 Bump 1.26.0-rc4
83371df2 Merge branch 'master' into 1.26.x
9c5351cf Merge pull request #7389 from ulyssessouza/general-bumps-for-1_26
836e2b7c General bumps
266d287e Merge pull request #7390 from ulyssessouza/remove-unused-resources
d64f3f39 Remove unused files
4e310a94 Merge pull request #7386 from ulyssessouza/bump-python-dotenv-1_13_0
d52b51e8 Bump python-dotenv from 0.11.0 to 0.13.0
64a6a48b Merge pull request #7345 from docker/dependabot/pip/certifi-2020.4.5.1
0979c7a1 Merge pull request #7380 from joehattori/simplify-code
ce782b59 Simplify code in compose/config/config.py
b7d6dc79 Bump certifi from 2019.11.28 to 2020.4.5.1
c22a2510 Merge pull request #7374 from ulyssessouza/fix-distro-guess
a62a1e1d Add "distro" package
afc5d205 Merge pull request #7371 from ulyssessouza/bump-openssl-111f
4d2afc07 Merge pull request #7372 from ulyssessouza/update-changelog
Have verified on arm/arm64/x86_64 against:
https://docs.docker.com/compose/gettingstarted
Signed-off-by: Ming Liu <ming.liu@toradex.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch')
-rw-r--r-- | recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | 13 |
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch index 6e5ca3d6..f517d05a 100644 --- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch +++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | |||
@@ -11,14 +11,14 @@ Upstream-Status: Inappropriate [OE Specific] | |||
11 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | 11 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> |
12 | Signed-off-by: Ming Liu <liu.ming50@gmail.com> | 12 | Signed-off-by: Ming Liu <liu.ming50@gmail.com> |
13 | --- | 13 | --- |
14 | setup.py | 22 +++++++++++----------- | 14 | setup.py | 26 +++++++++++++------------- |
15 | 1 file changed, 11 insertions(+), 11 deletions(-) | 15 | 1 file changed, 13 insertions(+), 13 deletions(-) |
16 | 16 | ||
17 | diff --git a/setup.py b/setup.py | 17 | diff --git a/setup.py b/setup.py |
18 | index 110441dc..eef28254 100644 | 18 | index 110441dc..eef28254 100644 |
19 | --- a/setup.py | 19 | --- a/setup.py |
20 | +++ b/setup.py | 20 | +++ b/setup.py |
21 | @@ -30,16 +30,16 @@ def find_version(*file_paths): | 21 | @@ -30,18 +30,18 @@ def find_version(*file_paths): |
22 | 22 | ||
23 | 23 | ||
24 | install_requires = [ | 24 | install_requires = [ |
@@ -28,29 +28,34 @@ index 110441dc..eef28254 100644 | |||
28 | - 'requests >= 2.20.0, < 3', | 28 | - 'requests >= 2.20.0, < 3', |
29 | - 'texttable >= 0.9.0, < 2', | 29 | - 'texttable >= 0.9.0, < 2', |
30 | - 'websocket-client >= 0.32.0, < 1', | 30 | - 'websocket-client >= 0.32.0, < 1', |
31 | - 'distro >= 1.5.0, < 2', | ||
31 | - 'docker[ssh] >= 3.7.0, < 5', | 32 | - 'docker[ssh] >= 3.7.0, < 5', |
32 | - 'dockerpty >= 0.4.1, < 1', | 33 | - 'dockerpty >= 0.4.1, < 1', |
33 | - 'six >= 1.3.0, < 2', | 34 | - 'six >= 1.3.0, < 2', |
34 | - 'jsonschema >= 2.5.1, < 4', | 35 | - 'jsonschema >= 2.5.1, < 4', |
36 | - 'python-dotenv >= 0.13.0, < 1', | ||
35 | + 'cached-property >= 1.2.0', | 37 | + 'cached-property >= 1.2.0', |
36 | + 'docopt >= 0.6.1', | 38 | + 'docopt >= 0.6.1', |
37 | + 'PyYAML >= 3.10', | 39 | + 'PyYAML >= 3.10', |
38 | + 'requests >= 2.20.0', | 40 | + 'requests >= 2.20.0', |
39 | + 'texttable >= 0.9.0', | 41 | + 'texttable >= 0.9.0', |
40 | + 'websocket-client >= 0.32.0', | 42 | + 'websocket-client >= 0.32.0', |
43 | + 'distro >= 1.5.0', | ||
41 | + 'docker[ssh] >= 3.7.0', | 44 | + 'docker[ssh] >= 3.7.0', |
42 | + 'dockerpty >= 0.4.1', | 45 | + 'dockerpty >= 0.4.1', |
43 | + 'six >= 1.3.0', | 46 | + 'six >= 1.3.0', |
44 | + 'jsonschema >= 2.5.1', | 47 | + 'jsonschema >= 2.5.1', |
48 | + 'python-dotenv >= 0.13.0', | ||
45 | ] | 49 | ] |
46 | 50 | ||
47 | 51 | ||
48 | @@ -58,7 +58,7 @@ extras_require = { | 52 | @@ -61,7 +61,7 @@ extras_require = { |
49 | ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0', | 53 | ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0', |
50 | 'ipaddress >= 1.0.16, < 2'], | 54 | 'ipaddress >= 1.0.16, < 2'], |
51 | ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], | 55 | ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], |
52 | - 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], | 56 | - 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], |
53 | + 'socks': ['PySocks >= 1.5.6, != 1.5.7'], | 57 | + 'socks': ['PySocks >= 1.5.6, != 1.5.7'], |
58 | 'tests': tests_require, | ||
54 | } | 59 | } |
55 | 60 | ||
56 | 61 | ||