summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-06-26 18:16:01 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-01 12:43:16 -0400
commita1d06c7470c7a1e57c88fc2479559ace4b67db26 (patch)
tree4fdfd4cdabd061e201592eb4ae9c6423b619431c /recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb
parent14a9247a1026842e9f813fe6f20e7c4ffd54bfb9 (diff)
downloadmeta-virtualization-a1d06c7470c7a1e57c88fc2479559ace4b67db26.tar.gz
python3-docker-compose: uprev 1.25.5 > 1.26.0
The major changes include: d4451659 Bump 1.26.0 3d94f442 Bump 1.26.0-rc5 1386a855 Merge pull request #7485 from ulyssessouza/fix-https-daemon 8034c96d Bump docker-py 48d09369 Fix flake8 errors 28bf47ce Pin wcwidth==0.1.9 d279b7a8 Bump 1.26.0-rc4 83371df2 Merge branch 'master' into 1.26.x 9c5351cf Merge pull request #7389 from ulyssessouza/general-bumps-for-1_26 836e2b7c General bumps 266d287e Merge pull request #7390 from ulyssessouza/remove-unused-resources d64f3f39 Remove unused files 4e310a94 Merge pull request #7386 from ulyssessouza/bump-python-dotenv-1_13_0 d52b51e8 Bump python-dotenv from 0.11.0 to 0.13.0 64a6a48b Merge pull request #7345 from docker/dependabot/pip/certifi-2020.4.5.1 0979c7a1 Merge pull request #7380 from joehattori/simplify-code ce782b59 Simplify code in compose/config/config.py b7d6dc79 Bump certifi from 2019.11.28 to 2020.4.5.1 c22a2510 Merge pull request #7374 from ulyssessouza/fix-distro-guess a62a1e1d Add "distro" package afc5d205 Merge pull request #7371 from ulyssessouza/bump-openssl-111f 4d2afc07 Merge pull request #7372 from ulyssessouza/update-changelog Have verified on arm/arm64/x86_64 against: https://docs.docker.com/compose/gettingstarted Signed-off-by: Ming Liu <ming.liu@toradex.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb')
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb b/recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb
new file mode 100644
index 00000000..37c62e85
--- /dev/null
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Multi-container orchestration for Docker"
2HOMEPAGE = "https://www.docker.com/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "f7d54de5db1f17322c09db8157bd160f"
9SRC_URI[sha256sum] = "7e836102d139aca667d6af53f0f4d942c9459ec24d6dd4f0203d74359b0fd311"
10
11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \
12 file://0001-setup.py-import-fastentrypoints.patch \
13 "
14
15DEPENDS += "${PYTHON_PN}-fastentrypoints-native"
16
17RDEPENDS_${PN} = "\
18 ${PYTHON_PN}-cached-property \
19 ${PYTHON_PN}-certifi \
20 ${PYTHON_PN}-chardet \
21 ${PYTHON_PN}-colorama \
22 ${PYTHON_PN}-distro \
23 ${PYTHON_PN}-docker \
24 ${PYTHON_PN}-docker-pycreds \
25 ${PYTHON_PN}-dockerpty \
26 ${PYTHON_PN}-docopt \
27 ${PYTHON_PN}-dotenv \
28 ${PYTHON_PN}-fcntl \
29 ${PYTHON_PN}-idna \
30 ${PYTHON_PN}-jsonschema \
31 ${PYTHON_PN}-misc \
32 ${PYTHON_PN}-paramiko \
33 ${PYTHON_PN}-pyyaml \
34 ${PYTHON_PN}-requests \
35 ${PYTHON_PN}-six \
36 ${PYTHON_PN}-terminal \
37 ${PYTHON_PN}-texttable \
38 ${PYTHON_PN}-urllib3 \
39 ${PYTHON_PN}-wcwidth \
40 ${PYTHON_PN}-websocket-client \
41"