summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxc/files/Generate-lxc-restore-net-properly.patch
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2017-06-06 14:46:54 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-06-13 18:26:15 -0400
commite73608d56e498a7075e7a3e5550aafd76987d7aa (patch)
tree4a1381c102f0f81513e90b119342f66cb7e13709 /recipes-containers/lxc/files/Generate-lxc-restore-net-properly.patch
parent3c427eafce21c615d5da76f261329497f7fcfeac (diff)
downloadmeta-virtualization-e73608d56e498a7075e7a3e5550aafd76987d7aa.tar.gz
lxc: 2.0.0 -> 2.0.8
1)Upgrade lxc from 2.0.0 to 2.0.8. 2)Delete two patches, since it is integrated upstream. Delete Generate-lxc-restore-net-properly.patch,this script has already been rearchitected out of existence by cba98d127bf490b018a016b792ae05fd2d29c5ee Delete Use-AC_HEADER_MAJOR-to-detect-major-minor-makedev.patch,this script has already been rearchitected out of existence by af6824fce9c9536fbcabef8d5547f6c486f55fdf from git://github.com/lxc/lxc.git 3)Modify two patches, since the data has been changed. automake-ensure-VPATH-builds-correctly.patch runtest.patch Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/lxc/files/Generate-lxc-restore-net-properly.patch')
-rw-r--r--recipes-containers/lxc/files/Generate-lxc-restore-net-properly.patch121
1 files changed, 0 insertions, 121 deletions
diff --git a/recipes-containers/lxc/files/Generate-lxc-restore-net-properly.patch b/recipes-containers/lxc/files/Generate-lxc-restore-net-properly.patch
deleted file mode 100644
index 5adb730c..00000000
--- a/recipes-containers/lxc/files/Generate-lxc-restore-net-properly.patch
+++ /dev/null
@@ -1,121 +0,0 @@
1From e08f3573b3561f1f0490624f7ca95b7ccd8157cb Mon Sep 17 00:00:00 2001
2Message-Id: <e08f3573b3561f1f0490624f7ca95b7ccd8157cb.1435177418.git.Jim.Somerville@windriver.com>
3From: Jim Somerville <Jim.Somerville@windriver.com>
4Date: Wed, 24 Jun 2015 16:16:38 -0400
5Subject: [PATCH 1/1] Generate lxc-restore-net properly
6
7It's a script that should be run through the configure
8mechanism the same as the others. We simply rename it
9to have a .in extension and add it to configure.ac .
10
11Also, by generating the script from a .in file, it gets
12placed into the build directory. This plays nice with
13build systems that keep the src separate from the build
14directory. Without this change, the install step won't
15find the lxc-restore-net script as it still just resides
16in the src directory and not in the build directory.
17
18Upstream-Status: Not applicable. This script has already
19been rearchitected out of existence by
20cba98d127bf490b018a016b792ae05fd2d29c5ee:
21"c/r: use criu option instead of lxc-restore-net
22
23As of criu 1.5, the --veth-pair argument supports an additional parameter that
24is the bridge name to attach to. This enables us to get rid of the goofy
25action-script hack that passed bridge names as environment variables.
26
27This patch is on top of the systemd/lxcfs mount rework patch, as we probably
28want to wait to use 1.5 options until it has been out for a while and is in
29distros.
30
31Signed-off-by: Tycho Andersen <tycho.andersen@canonical.com>
32Acked-by: Serge E. Hallyn <serge.hallyn@ubuntu.com>"
33
34Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com>
35---
36 configure.ac | 1 +
37 src/lxc/lxc-restore-net | 26 --------------------------
38 src/lxc/lxc-restore-net.in | 26 ++++++++++++++++++++++++++
39 3 files changed, 27 insertions(+), 26 deletions(-)
40 delete mode 100755 src/lxc/lxc-restore-net
41 create mode 100755 src/lxc/lxc-restore-net.in
42
43diff --git a/configure.ac b/configure.ac
44index 574b2cd..4972803 100644
45--- a/configure.ac
46+++ b/configure.ac
47@@ -768,6 +768,7 @@ AC_CONFIG_FILES([
48 src/lxc/legacy/lxc-ls
49 src/lxc/lxc.functions
50 src/lxc/version.h
51+ src/lxc/lxc-restore-net
52 src/python-lxc/Makefile
53 src/python-lxc/setup.py
54
55diff --git a/src/lxc/lxc-restore-net b/src/lxc/lxc-restore-net
56deleted file mode 100755
57index 6ae3c19..0000000
58--- a/src/lxc/lxc-restore-net
59+++ /dev/null
60@@ -1,26 +0,0 @@
61-#!/bin/sh
62-
63-set -e
64-
65-i=0
66-while true; do
67- eval "bridge=\$LXC_CRIU_BRIDGE$i"
68- eval "veth=\$LXC_CRIU_VETH$i"
69-
70- if [ -z "$bridge" ] || [ -z "$veth" ]; then
71- exit 0
72- fi
73-
74- if [ "$CRTOOLS_SCRIPT_ACTION" = "network-lock" ]; then
75- brctl delif $bridge $veth
76- fi
77-
78- if [ "$CRTOOLS_SCRIPT_ACTION" = "network-unlock" ]; then
79- brctl addif $bridge $veth
80- ip link set dev $veth up
81- fi
82-
83- i=$((i+1))
84-done
85-
86-exit 1
87diff --git a/src/lxc/lxc-restore-net.in b/src/lxc/lxc-restore-net.in
88new file mode 100755
89index 0000000..6ae3c19
90--- /dev/null
91+++ b/src/lxc/lxc-restore-net.in
92@@ -0,0 +1,26 @@
93+#!/bin/sh
94+
95+set -e
96+
97+i=0
98+while true; do
99+ eval "bridge=\$LXC_CRIU_BRIDGE$i"
100+ eval "veth=\$LXC_CRIU_VETH$i"
101+
102+ if [ -z "$bridge" ] || [ -z "$veth" ]; then
103+ exit 0
104+ fi
105+
106+ if [ "$CRTOOLS_SCRIPT_ACTION" = "network-lock" ]; then
107+ brctl delif $bridge $veth
108+ fi
109+
110+ if [ "$CRTOOLS_SCRIPT_ACTION" = "network-unlock" ]; then
111+ brctl addif $bridge $veth
112+ ip link set dev $veth up
113+ fi
114+
115+ i=$((i+1))
116+done
117+
118+exit 1
119--
1201.8.3.2
121