diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-05-29 01:31:08 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-05-29 13:23:51 +0000 |
commit | f487ea4aa007b25fd5a2dcd21996e0f94ef4d368 (patch) | |
tree | bcffa0044e7e254ab1da2cf3cbf5382805514f0c /recipes-containers/lxc/files/templates-use-curl-instead-of-wget.patch | |
parent | 33734783467f67420811b40e078b2c25ac7098ed (diff) | |
download | meta-virtualization-f487ea4aa007b25fd5a2dcd21996e0f94ef4d368.tar.gz |
lxc: update to v6.0.0
Bumping lxc to version v6.0.0, which comprises the following commits:
3dee5fb88 Release LXC 6.0.0
17ac6f691 lxc.spec: Align SPDX license id
5fe2de84c Makefile: Align SPDX license id
97f93be72 meson: Align SPDX license id
d4cd3741d COPYING: Clarify licensing of files without SPDX
8e67eb07c doc: Add SPDX headers and remove Author field
cb94edf53 src/include: Add SPDX headers
7bc33ef6e src/tests: Add SPDX headers
007642c89 hooks: Add SPDX headers
1e9e66be3 lxc.spec: Clear default changelog
202d649d1 lxc.spec: Use SPDX
85abd4026 template: Use SPDX
a074b3d27 config/yum: Use SPDX header
7ed43e5e9 COPYING: Remove whitespace
522721216 MAINTAINERS: Remove Dwight from the maintainer list
08bf8b9e2 lxc-checkconfig: Fix shellcheck
0f18db543 lxc-checkconfig: Show namespace limits
f71b8e3f8 lxc-ls: list names with whitespaces in `--active`.
816b8973d lxc/tools: set default log_priority to ERROR
989ea3969 tools/lxc_autostart: don't fail when there are no containers
dc4df2335 lxc/lxccontainer: specify file mode in open() call inside mod_rdep
630b46ed2 lxc/confile: do not print excess space before scale suffix for time.offset.boot
796f2ccb7 lxc/confile: do not print newline symbol in getter for lxc.time.offset.*
dcc4fb929 tests/parse_config_file: fix some typos
6fea67429 tests/parse_config_file: add tests for lxc.time.offset.*
ad8f55445 tree-wide: replace multiply_overflow with check_mul_overflow
4464cee19 lxccontainer: rework copy_file()
9d1aa932d lxccontainer: improve mod_rdep()
81c1bbf45 Revert "lxccontainer: fixes"
82fe01821 src/lxc/syscall_numbers.h: drop define -1
590a95d83 rexec: Avoid invalid free in rexec failure path
f9978b179 README: Correct 'armvl7' to 'armv7l'
046b63cd2 unshare: simplify lookup_name
7452ee8ab lxc-unshare: fix an buffer overflow issue in lxc_unshare
e88883445 lxc-net: Enable IPv6 by default
d78ca00bc tests/meson: attempt to fix ossfuzz builds
d18f993b3 github: master -> main
86799f554 meson: link with liblxc dynamically everywhere if possible
b90fecfda network: use IN_LIBLXC
9eee450d2 storage_utils: move get_fssize to utils
6eb0a73e2 storage_utils: unhide and rename is_valid_storage_type to lxc_is_valid_storage_type
42eeffcb0 confile: unhide lxc_config_parse_arch() helper
9bb318881 conf: reorganize/split code to utils.c
863c59dc3 conf: reorganize/split code to idmap_utils.c
b7591ad49 confile: unhide lxc_config_define*() helpers
f14656ebf meson: introduce IN_LIBLXC preprocessor macro
672b2172d confile: move lxc_fill_elevated_privileges() to tools/lxc_attach
8f9733d75 tests: remove old and broken cgroup handling code from tests
d51ea224e config: apparmor: add AppArmor profile for lxc-copy
627bb9460 tests: lxc-test-usernic: use iproute tool instead of brctl
df0665b6d oci: resolve cross-filesystem blob caching failure
ec85e5ca4 lxc-test-usernic: drop cgroup handling
27ec0b0f6 test-usernic: don't use ifconfig
44e845b3c Add x32 to the list of recognized architectures
07e3a516e lxc-download, lxc-local: preserve xattrs on unpack
9ac7c4895 tree-wide: use container_uses_namespace() in less trivial cases
64341ce7b tree-wide: use container_uses_namespace() helper
6b40e66c1 Fix error message.
c8189ee2a Add verbose output in download template.
84cc3155a Align columns in lxc-download.in template
872db5424 build: add more options for customizing install
df17ac417 Add loongarch64 support
112d5615e build(deps): bump actions/upload-artifact from 3 to 4
789457f1a config: try to create workdir if not exist
86f5c1226 lxc-local: Add --no-dev option to exclude /dev from the fstree
f885a3c56 lxc-local: Re-organize code to use more functions
7c025072e lxc-local: Improve usage info
faa38a197 lxc-local: Change LXC_CONFIG to LXC_METADATA to match args and be more clear
d65fe1b27 Disable IPv6 link-local addresses for bridged veth
8cff8fa1a don't try to delete vlan 0 from veth
0e932812a conf: fix ephemeral copies
abffab441 config/init: Drop upstart files
79a4a3cf8 doc: remove the warning mentionning upstart
7bf1695d0 hooks/ubuntu-cloud-prep: remove upstart handling
fb73c18d2 meson: Remove support for upstart
cc6819c69 reset root_nsuid_map and root_nsgid_map when idmaps is cleared
a87d6fcc9 lxc/checkconfig: use multiline `echo`
f3e01fa80 lxc/checkconfig: replace `echo -n` by printf
ba4f810bc lxc/checkconfig: minor cosmetic change
d52c345c8 lxc/checkconfig: avoid subshell (SC2235)
f84f03d1d lxc/checkconfig: remove superfluous (..) around test command (SC2234)
74b9faa64 lxc/checkconfig: check exit code directly (SC2181)
5cc69e440 lxc/checkconfig: replace `! -z` by `-n` (SC2236)
a4684eb11 lxc/checkconfig: add missing quotes to please shellcheck
8a611c0b2 lxc/checkconfig: remove some unneeded `echo -n`
cb2574319 lxc/checkconfig: replace `type` by `command`
003efe6db lxc/checkconfig: replace `cat | grep` with `grep`
adadfa372 lxc/lxccontainer: fix do_lxcapi_set_timeout retval
c02367e59 containers in the FREEZING state also need to be unfreeze
aca53bcf7 build(deps): bump actions/checkout from 3 to 4
84169158f lxccontainer.h: Move new fields to the end
e2696df93 Remove references to LXD
7cec54455 Update console perms to 0600
3f45443fd Fix start api call to split quoted strings in execute or init command.
fbc31691e github: Update for main branch
69e51b919 CONTRIBUTING: add a note on AI generated code
84cfe9772 get_hierarchy: dont WARN about no usable controller
64167f906 Add libarchive tar support for lxc download
213e2f68d github: Add DCO/target tests
cf2b20209 explicitly convert *mainloop_handler to __u64
8575ffeb7 tests: fix parse_config_file seccomp test
ca25f3bf6 src/tests: Fix container creation errors
539c39772 rename functions which clash with libsystemd's
b670f0e75 commands: support timeout in LXC_CMD_GET_STATE
0fed82b26 lxccontainer: extend lxccontainer API with set_timeout
7fd671dbc mainloop: io_uring: disable IORING_POLL_ADD_MULTI
715fb4eff terminal: make a terminal FDs non-blocking
7eff16cc4 file_utils: add fd_make_nonblocking helper
747c4df31 file_utils: rename fd_make_nonblocking to fd_make_blocking
ebea2b5a9 setproctitle(): Handle potential NULL return from strrchr()
f7f15b20a make setproctitle()'s /proc/pid/stat parsing safe
890de0759 lsm: apparmor: allow to change mount propagation
5894cf310 console-log test: make sure container is stopped before restarting
820d2a2b3 switch from libsystemd's dbus to dbus-1
3c1453a38 tree-wide: convert fcntl(FD_CLOEXEC) to SOCK_CLOEXEC
4ea0b361f Allow fuse mounts in apparmor start-container.
1a2da75b6 Add support for squashfs images in oci via atomfs
db3cbfa75 apparmor: don't try to mmap empty files
304bf58fa initutils: use PRIu64 for uint64_t in setproctitle
4de047f51 lxc-net.in: fix nftables syntax for IPv6 NAT
311bb8c53 Fix strlcat's return value checks
588b53b19 Fix typo: bev_type -> bdev_type
7914c259f drop broken lxc-test-fuzzers
849d80877 Fix build error on sparc64 caused by using the gold linker
43ad7816d lxc-default-cgns apparmor profile: allow overlay mounts
4fa83282b lxc_user_nic: fix get_mtu() error handling
1b0469530 Patching an incoming CVE (CVE-2022-47952)
a8e1070c6 build: force linking against liblxc
c27ea96f7 checkconfig: Fix filesystem capability check
3f361da61 checkconfig: Tweak cgroup handling
3ab04999d checkconfig: Tweak layout
e027ca711 checkconfig: Hide version if no lxc-start
914fec51b checkconfig: Fix mixed tabs/spaces
70b176b0d src/lxc/meson.build: fix build without apparmor
42b22da6d cgroups: fix cgroup layout detection in __initialize_cgroups
0072919dd state: additional check in lxc_wait to prevent OOB
62b94d3ec cgroups: check snprintf retval in unpriv_systemd_create_scope
93d545e37 cgroups: fix buffer out-of-bounds access in enable_controllers_delegation
f8aa61f97 network: always initialize struct nl_handler
6ea4a6c06 apparmor: properly check lxc_strmmap ret value
b37cce95b github: fix coverity (add libpam-dev)
a8dcf88d0 github: fix coverity build
7e7393413 conf: ensure mount tunnel is a dependent mount
01ae6d471 apparmor: allow shared mounts in start-container.in
81d94a4ee conf: create separate peer group for container's root
68020412c cgroups: only allocate user namespace if we have to
27f69d45b cgroups: use userns_exec_full() during cgroup removal
1029c2a06 README: remove lgtm
dcf85308c meson.build: strip newline for variable assignments
8aac58866 meson.build: strip newlines from git output
16c6ff226 tests: lxc-test-reboot: Fix build on ia64
64eb31d02 src/lxc/meson.build: fix the static library path
c6c705bfa build: drop build-time systemd dependency
f321cd610 build: use cc.get_define to detect FS_CONFIG_* symbols
5aff4ea37 build: only build init.lxc.static if libcap is statically linkable
c1f87c811 build: fix handling of dependancies to fix build on openSUSE
bc318926d cgroups: fix -Waddress warning
4deaa28c0 Unroll IN_SET since the max usage is 2 elements check
73fd9bf55 tests: lxc-test-checkpoint-restore: use trap to do cleanup
8480c56a4 tools: lxc-destroy: update help message for --force
3cac3fce4 build: add libsystemd to oss fuzz dependencies
f7cadaa34 lxc/attach: Detect EACCES from execvp and convert to 126 exit status
4ebca5a00 lxc-attach: Fix lost return codes of spawned processes that are killed
09233897b Update README.md
4a66dabf8 conf: allow cross-device links
dc4f1220f build(deps): bump actions/checkout from 2 to 3
2b802090f Update cifuzz.yml
20cc78456 fix error message when use tools with -? option
b0abedf60 use sd_bus_call_method_async to replace the asyncv one
589a930f1 tree-wide: split open helpers into open_utils.h
7b1836bce build: prevent the inclusion of linux/mount.h with a hack
da8c29853 mount_utils: remove conf.h include
74c2f58e1 mount: move mount utilities from syscall_wrappers.h into mount_utils.h
68cf56489 tree-wide: minimize liburing.h inclusion
06f99c259 meson: fix docbook2x detection
133aa416c tree-wide: use struct open_how directly
63468abd3 tree-wide: use struct clone_args directly
4771699fd tree-wide: wipe direct or indirect linux/mount.h inclusion
16ebb29dc meson.build: allow explicit distrosysconfdir
cbabe8abf build: check for FS_CONFIG_* header symbol in sys/mount.h
ef1e0607b build: detect sys/pidfd.h availability
c1115e150 build: detect where struct mount_attr is declared
e452c8945 gitignore: Simplify
32a071519 lxc-usernsexec: allow to select which {g,u}id to switch to
7f6643071 README: update security mails
5e704fe38 meson.build: fix build without stack-protector
7d7235489 meson.build: fix build with -Dcapabilities=false
8ee887908 src/lxc/log.h: fix STRERROR_R_CHAR_P
353f0f992 meson: add remaining still-in-use config checks
3d360cf9d Store mount options in correct variable
df3301046 Fix off-by-one error constructing mount options
8ee615c27 add check for statvfs
07a00b78f start: fix namespace sharing
eae44ce19 conf: fix append_ttyname()
6c50e09f2 start: record inherited namespaces earlier to make it available for idmapped rootfs setup
7317d2a8a start: don't overwrite file descriptors during namespace preservation
fc133a9f3 conf: log file descriptors on error during idmapped mount setup
26de6cbc8 fix for issue 4026: set broadcast to 0.0.0.0 for /31 and /32
c55353f84 use systemd dbus StartTransientUnit for unpriv cgroup2
b203e1a14 Fix uninitialized read in parse_cap when libcap is not used
e73520adf meson: Set DEVEL flag post release
f4d02217e tools: Provide multicall lxc binary
289d6413e meson: Generate compile commands by iterating over an array
132ff8e28 lxccontainer: rework copy_file()
f357cb290 lxccontainer: improve mod_rdep()
b576a47d5 Read list until process exits
We also:
- drop two patches that were backported
- refresh the context of one
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/lxc/files/templates-use-curl-instead-of-wget.patch')
-rw-r--r-- | recipes-containers/lxc/files/templates-use-curl-instead-of-wget.patch | 23 |
1 files changed, 10 insertions, 13 deletions
diff --git a/recipes-containers/lxc/files/templates-use-curl-instead-of-wget.patch b/recipes-containers/lxc/files/templates-use-curl-instead-of-wget.patch index e9af8335..76704bb3 100644 --- a/recipes-containers/lxc/files/templates-use-curl-instead-of-wget.patch +++ b/recipes-containers/lxc/files/templates-use-curl-instead-of-wget.patch | |||
@@ -14,11 +14,11 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
14 | templates/lxc-download.in | 8 ++++---- | 14 | templates/lxc-download.in | 8 ++++---- |
15 | 1 file changed, 4 insertions(+), 4 deletions(-) | 15 | 1 file changed, 4 insertions(+), 4 deletions(-) |
16 | 16 | ||
17 | diff --git a/templates/lxc-download.in b/templates/lxc-download.in | 17 | Index: git/templates/lxc-download.in |
18 | index a62ddf482..690307338 100755 | 18 | =================================================================== |
19 | --- a/templates/lxc-download.in | 19 | --- git.orig/templates/lxc-download.in |
20 | +++ b/templates/lxc-download.in | 20 | +++ git/templates/lxc-download.in |
21 | @@ -59,9 +59,9 @@ cleanup() { | 21 | @@ -45,9 +45,9 @@ |
22 | fi | 22 | fi |
23 | } | 23 | } |
24 | 24 | ||
@@ -30,16 +30,16 @@ index a62ddf482..690307338 100755 | |||
30 | return 0 | 30 | return 0 |
31 | fi | 31 | fi |
32 | done | 32 | done |
33 | @@ -70,7 +70,7 @@ wget_wrapper() { | 33 | @@ -59,7 +59,7 @@ |
34 | } | 34 | if [ "${DOWNLOAD_VERBOSE}" = "true" ]; then |
35 | 35 | echo "Download file: https://${DOWNLOAD_SERVER}$1" | |
36 | download_file() { | 36 | fi |
37 | - if ! wget_wrapper --user-agent="lxc/@PACKAGE_VERSION@ compat:${DOWNLOAD_COMPAT_LEVEL}" -T 30 -q "https://${DOWNLOAD_SERVER}/$1" -O "$2" >/dev/null 2>&1; then | 37 | - if ! wget_wrapper --user-agent="lxc/@PACKAGE_VERSION@ compat:${DOWNLOAD_COMPAT_LEVEL}" -T 30 -q "https://${DOWNLOAD_SERVER}/$1" -O "$2" >/dev/null 2>&1; then |
38 | + if ! curl_wrapper -L --user-agent "lxc/@PACKAGE_VERSION@ compat:${DOWNLOAD_COMPAT_LEVEL}" -m 30 -s "https://${DOWNLOAD_SERVER}/$1" -o "$2" >/dev/null 2>&1; then | 38 | + if ! curl_wrapper -L --user-agent "lxc/@PACKAGE_VERSION@ compat:${DOWNLOAD_COMPAT_LEVEL}" -m 30 -s "https://${DOWNLOAD_SERVER}/$1" -o "$2" >/dev/null 2>&1; then |
39 | if [ "$3" = "noexit" ]; then | 39 | if [ "$3" = "noexit" ]; then |
40 | return 1 | 40 | return 1 |
41 | else | 41 | else |
42 | @@ -176,7 +176,7 @@ while :; do | 42 | @@ -167,7 +167,7 @@ |
43 | done | 43 | done |
44 | 44 | ||
45 | # Check for required binaries | 45 | # Check for required binaries |
@@ -48,6 +48,3 @@ index a62ddf482..690307338 100755 | |||
48 | if ! command -V "${bin}" >/dev/null 2>&1; then | 48 | if ! command -V "${bin}" >/dev/null 2>&1; then |
49 | echo "ERROR: Missing required tool: ${bin}" 1>&2 | 49 | echo "ERROR: Missing required tool: ${bin}" 1>&2 |
50 | exit 1 | 50 | exit 1 |
51 | -- | ||
52 | 2.25.1 | ||
53 | |||