summaryrefslogtreecommitdiffstats
path: root/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2025-01-15 17:54:58 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2025-01-17 19:17:09 +0000
commitea15fd06143702f3a2366d706656bcbc0812fb16 (patch)
tree45f73c17454dafe8006c789b188d62fe2ab6c93d /recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch
parent79db703e34cc35dfa707596431aa2a1686f2cf3a (diff)
downloadmeta-virtualization-ea15fd06143702f3a2366d706656bcbc0812fb16.tar.gz
runc: drop runc-docker
The changes carried in runc-docker are no longer required, and if they become relevant again, they don't belong in the base recipe. This is the first part of the change, we drop runc-docker + patches and update runc-opencontainers to RPROVIDE runc-docker in case there are referenced that we don't know about. There shouldn't be any, since virtual-runc has been the RPROVIDE of choice for some time. We keep runc-opencontainers for now, since there may be alternate runc implementations in the future. In about a year, we'll unify the .inc and .bb if no new implementations have been proposed. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch')
-rw-r--r--recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch b/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch
deleted file mode 100644
index cb0ddc37..00000000
--- a/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 3fff2a3505fba1d1ff0074edff15708a77f6cfa9 Mon Sep 17 00:00:00 2001
2From: Jason Wessel <jason.wessel@windriver.com>
3Date: Wed, 12 Jul 2017 13:35:03 -0700
4Subject: [PATCH] runc: Add --console-socket=/dev/null
5
6This allows for setting up a detached session where you do not want to
7set the terminal to false in the config.json. More or less this is a
8runtime override.
9
10Upstream-Status: Inappropriate [embedded specific]
11
12Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
13---
14 utils_linux.go | 5 +++++
15 1 file changed, 5 insertions(+)
16
17Index: git/src/import/utils_linux.go
18===================================================================
19--- git.orig/src/import/utils_linux.go
20+++ git/src/import/utils_linux.go
21@@ -267,6 +267,11 @@
22 }
23
24 func (r *runner) run(config *specs.Process) (int, error) {
25+ if (r.consoleSocket == "/dev/null") {
26+ r.detach = false
27+ r.consoleSocket = ""
28+ config.Terminal = false
29+ }
30 var err error
31 defer func() {
32 if err != nil {