summaryrefslogtreecommitdiffstats
path: root/recipes-core/runx/runx_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-03-26 11:11:13 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-03-26 11:12:29 -0400
commit438ed8b5065aac2bfd69c57e807befb42c8cc889 (patch)
tree4a074073888f56634a8de9b150fd5d61b1006217 /recipes-core/runx/runx_git.bb
parent690761393c5bba906a0332f2c5a4cb9d17a3d3ad (diff)
downloadmeta-virtualization-438ed8b5065aac2bfd69c57e807befb42c8cc889.tar.gz
runx: update to v1.0
bumping runX to the 1.0 tag - drop patches that are part of the release - bump kernel to v5.4.104 to work with our gcc10 - tweak initrd install to use externally provided busybox Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-core/runx/runx_git.bb')
-rw-r--r--recipes-core/runx/runx_git.bb14
1 files changed, 6 insertions, 8 deletions
diff --git a/recipes-core/runx/runx_git.bb b/recipes-core/runx/runx_git.bb
index 48a57766..89783a0e 100644
--- a/recipes-core/runx/runx_git.bb
+++ b/recipes-core/runx/runx_git.bb
@@ -2,7 +2,7 @@ HOMEPAGE = "https://github.com/lf-edge/runx"
2SUMMARY = "runx stuff" 2SUMMARY = "runx stuff"
3DESCRIPTION = "Xen Runtime for OCI" 3DESCRIPTION = "Xen Runtime for OCI"
4 4
5SRCREV_runx = "f24efd33fb18469e9cfe4d1bfe8e2c90ec8c4e93" 5SRCREV_runx = "edc9350a79ede0365066c9743080e3dc6430d602"
6 6
7KERNEL_SRC_VER="linux-5.4" 7KERNEL_SRC_VER="linux-5.4"
8KERNEL_URL_VER="v5.x" 8KERNEL_URL_VER="v5.x"
@@ -11,14 +11,10 @@ SRC_URI = "\
11 git://github.com/lf-edge/runx;nobranch=1;name=runx \ 11 git://github.com/lf-edge/runx;nobranch=1;name=runx \
12 https://www.kernel.org/pub/linux/kernel/${KERNEL_URL_VER}/${KERNEL_SRC_VER}.tar.xz;destsuffix=git/kernel/build \ 12 https://www.kernel.org/pub/linux/kernel/${KERNEL_URL_VER}/${KERNEL_SRC_VER}.tar.xz;destsuffix=git/kernel/build \
13 file://0001-make-kernel-cross-compilation-tweaks.patch \ 13 file://0001-make-kernel-cross-compilation-tweaks.patch \
14 file://0001-make-initrd-cross-install-tweaks.patch \ 14 file://0001-make-kernel-bump-to-v5.4.104-for-gcc10-fixes.patch \
15 file://0001-runX-add-bounded-looping-timeout.patch \ 15 file://0001-make-initrd-allow-externally-provided-busybox.patch \
16 " 16 "
17 17
18SRC_URI += "file://0001-Add-busybox-cross-build-for-arm64.patch \
19 file://0002-don-t-call-busybox-install.patch \
20 "
21
22SRC_URI[md5sum] = "ce9b2d974d27408a61c53a30d3f98fb9" 18SRC_URI[md5sum] = "ce9b2d974d27408a61c53a30d3f98fb9"
23SRC_URI[sha256sum] = "bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491" 19SRC_URI[sha256sum] = "bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491"
24 20
@@ -26,7 +22,7 @@ LICENSE = "Apache-2.0"
26LIC_FILES_CHKSUM = "file://LICENSE;md5=945fc9aa694796a6337395cc291ddd8c" 22LIC_FILES_CHKSUM = "file://LICENSE;md5=945fc9aa694796a6337395cc291ddd8c"
27 23
28S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
29PV = "0.1-git${SRCREV_runx}" 25PV = "v1.0-git${SRCREV_runx}"
30 26
31inherit features_check 27inherit features_check
32REQUIRED_DISTRO_FEATURES = "vmsep" 28REQUIRED_DISTRO_FEATURES = "vmsep"
@@ -42,6 +38,7 @@ DEPENDS += "resolvconf"
42 38
43# for the kernel build phase 39# for the kernel build phase
44DEPENDS += "openssl-native coreutils-native util-linux-native xz-native bc-native" 40DEPENDS += "openssl-native coreutils-native util-linux-native xz-native bc-native"
41DEPENDS += "elfutils-native"
45DEPENDS += "qemu-native bison-native" 42DEPENDS += "qemu-native bison-native"
46 43
47RDEPENDS_${PN} += " jq bash" 44RDEPENDS_${PN} += " jq bash"
@@ -91,6 +88,7 @@ do_compile() {
91 cp ${STAGING_DIR_HOST}/bin/busybox.nosuid ${WORKDIR}/busybox 88 cp ${STAGING_DIR_HOST}/bin/busybox.nosuid ${WORKDIR}/busybox
92 export QEMU_USER="`which qemu-${HOST_ARCH}` -L ${STAGING_BASELIBDIR}/.." 89 export QEMU_USER="`which qemu-${HOST_ARCH}` -L ${STAGING_BASELIBDIR}/.."
93 export BUSYBOX="${WORKDIR}/busybox" 90 export BUSYBOX="${WORKDIR}/busybox"
91 export busybox="${WORKDIR}/busybox"
94 export CROSS_COMPILE="${TARGET_PREFIX}" 92 export CROSS_COMPILE="${TARGET_PREFIX}"
95 else 93 else
96 bbnote "runx: using internal busybox" 94 bbnote "runx: using internal busybox"