diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-10-29 09:51:13 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-11-02 09:57:03 -0400 |
commit | ac399ad09105dce73bccde9574216377613a98de (patch) | |
tree | 6fd16ce13d7ee10e9fb2ee8ec85c18cc4d4dec0b /recipes-devtools/go | |
parent | 03689b86cc1b5eb935f5271697336ce5cb6b4e69 (diff) | |
download | meta-virtualization-ac399ad09105dce73bccde9574216377613a98de.tar.gz |
global: add explicit branch to all SRC_URIs
As introduced in the oe-core post:
https://lists.openembedded.org/g/openembedded-core/message/157623
SRC_URIs without an explicit branch will generate warnings, and
eventually be an error.
We run the provided conversion script to make sure that meta-virt
is ready for the change.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools/go')
-rw-r--r-- | recipes-devtools/go/compose-file_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-capability_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-cli_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-connections_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-context_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-dbus_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-fsnotify_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-libtrust_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-logrus_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-md2man_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-metalinter_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-mux_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-patricia_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/go-pty_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/grpc-go_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go/notary_git.bb | 2 |
16 files changed, 16 insertions, 16 deletions
diff --git a/recipes-devtools/go/compose-file_git.bb b/recipes-devtools/go/compose-file_git.bb index e93cba3b..1571265a 100644 --- a/recipes-devtools/go/compose-file_git.bb +++ b/recipes-devtools/go/compose-file_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=9cd86830b557232ce55e2a6b4 | |||
7 | SRCNAME = "compose-file" | 7 | SRCNAME = "compose-file" |
8 | 8 | ||
9 | PKG_NAME = "github.com/aanand/${SRCNAME}" | 9 | PKG_NAME = "github.com/aanand/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}" | 10 | SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master" |
11 | 11 | ||
12 | SRCREV = "a3e58764f50597b6217fec07e9bff7225c4a1719" | 12 | SRCREV = "a3e58764f50597b6217fec07e9bff7225c4a1719" |
13 | PV = "3.0+git${SRCPV}" | 13 | PV = "3.0+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-capability_git.bb b/recipes-devtools/go/go-capability_git.bb index 25b7bebb..5c180e73 100644 --- a/recipes-devtools/go/go-capability_git.bb +++ b/recipes-devtools/go/go-capability_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=a7304f5073e7be4ba7bffabbf9f2bbca" | |||
7 | SRCNAME = "gocapability" | 7 | SRCNAME = "gocapability" |
8 | 8 | ||
9 | PKG_NAME = "github.com/syndtr/${SRCNAME}" | 9 | PKG_NAME = "github.com/syndtr/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "2c00daeb6c3b45114c80ac44119e7b8801fdd852" | 12 | SRCREV = "2c00daeb6c3b45114c80ac44119e7b8801fdd852" |
13 | PV = "0.0+git${SRCPV}" | 13 | PV = "0.0+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-cli_git.bb b/recipes-devtools/go/go-cli_git.bb index 01487e15..7db5fc5d 100644 --- a/recipes-devtools/go/go-cli_git.bb +++ b/recipes-devtools/go/go-cli_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ed9b539ed65d73926f30ff1f1587dc44" | |||
7 | SRCNAME = "cli" | 7 | SRCNAME = "cli" |
8 | 8 | ||
9 | PKG_NAME = "github.com/codegangsta/${SRCNAME}" | 9 | PKG_NAME = "github.com/codegangsta/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "27ecc97192df1bf053a22b04463f2b51b8b8373e" | 12 | SRCREV = "27ecc97192df1bf053a22b04463f2b51b8b8373e" |
13 | PV = "1.1.0+git${SRCPV}" | 13 | PV = "1.1.0+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-connections_git.bb b/recipes-devtools/go/go-connections_git.bb index 529b99c4..1bf6e94b 100644 --- a/recipes-devtools/go/go-connections_git.bb +++ b/recipes-devtools/go/go-connections_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=04424bc6f5a5be60691b9824d | |||
7 | SRCNAME = "go-connections" | 7 | SRCNAME = "go-connections" |
8 | 8 | ||
9 | PKG_NAME = "github.com/docker/${SRCNAME}" | 9 | PKG_NAME = "github.com/docker/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}" | 10 | SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master" |
11 | 11 | ||
12 | SRCREV = "4ccf312bf1d35e5dbda654e57a9be4c3f3cd0366" | 12 | SRCREV = "4ccf312bf1d35e5dbda654e57a9be4c3f3cd0366" |
13 | PV = "0.2.1+git${SRCPV}" | 13 | PV = "0.2.1+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-context_git.bb b/recipes-devtools/go/go-context_git.bb index da9093dd..ba0368b9 100644 --- a/recipes-devtools/go/go-context_git.bb +++ b/recipes-devtools/go/go-context_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c50f6bd9c1e15ed0bad3bea18e3c1b7f" | |||
7 | SRCNAME = "context" | 7 | SRCNAME = "context" |
8 | 8 | ||
9 | PKG_NAME = "github.com/gorilla/${SRCNAME}" | 9 | PKG_NAME = "github.com/gorilla/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "14f550f51af52180c2eefed15e5fd18d63c0a64a" | 12 | SRCREV = "14f550f51af52180c2eefed15e5fd18d63c0a64a" |
13 | 13 | ||
diff --git a/recipes-devtools/go/go-dbus_git.bb b/recipes-devtools/go/go-dbus_git.bb index e17151d3..39b14a5b 100644 --- a/recipes-devtools/go/go-dbus_git.bb +++ b/recipes-devtools/go/go-dbus_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=09042bd5c6c96a2b9e45ddf1bc517eed" | |||
7 | SRCNAME = "dbus" | 7 | SRCNAME = "dbus" |
8 | 8 | ||
9 | PKG_NAME = "github.com/godbus/${SRCNAME}" | 9 | PKG_NAME = "github.com/godbus/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "5f6efc7ef2759c81b7ba876593971bfce311eab3" | 12 | SRCREV = "5f6efc7ef2759c81b7ba876593971bfce311eab3" |
13 | PV = "4.0.0+git${SRCPV}" | 13 | PV = "4.0.0+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-fsnotify_git.bb b/recipes-devtools/go/go-fsnotify_git.bb index 3f533aa9..2ae27b1b 100644 --- a/recipes-devtools/go/go-fsnotify_git.bb +++ b/recipes-devtools/go/go-fsnotify_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c38914c9a7ab03bb2b96d4baaee10769" | |||
7 | SRCNAME = "fsnotify" | 7 | SRCNAME = "fsnotify" |
8 | 8 | ||
9 | PKG_NAME = "github.com/fsnotify/${SRCNAME}" | 9 | PKG_NAME = "github.com/fsnotify/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "836bfd95fecc0f1511dd66bdbf2b5b61ab8b00b6" | 12 | SRCREV = "836bfd95fecc0f1511dd66bdbf2b5b61ab8b00b6" |
13 | PV = "1.2.11+git${SRCPV}" | 13 | PV = "1.2.11+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-libtrust_git.bb b/recipes-devtools/go/go-libtrust_git.bb index 448a68b6..404baf5d 100644 --- a/recipes-devtools/go/go-libtrust_git.bb +++ b/recipes-devtools/go/go-libtrust_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8" | |||
7 | SRCNAME = "libtrust" | 7 | SRCNAME = "libtrust" |
8 | 8 | ||
9 | PKG_NAME = "github.com/docker/${SRCNAME}" | 9 | PKG_NAME = "github.com/docker/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "9cbd2a1374f46905c68a4eb3694a130610adc62a" | 12 | SRCREV = "9cbd2a1374f46905c68a4eb3694a130610adc62a" |
13 | PV = "0.0+git${SRCPV}" | 13 | PV = "0.0+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-logrus_git.bb b/recipes-devtools/go/go-logrus_git.bb index 97e1a35c..b54b32b3 100644 --- a/recipes-devtools/go/go-logrus_git.bb +++ b/recipes-devtools/go/go-logrus_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8dadfef729c08ec4e631c4f6fc5d43a0" | |||
7 | SRCNAME = "logrus" | 7 | SRCNAME = "logrus" |
8 | 8 | ||
9 | PKG_NAME = "github.com/Sirupsen/${SRCNAME}" | 9 | PKG_NAME = "github.com/Sirupsen/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "d26492970760ca5d33129d2d799e34be5c4782eb" | 12 | SRCREV = "d26492970760ca5d33129d2d799e34be5c4782eb" |
13 | PV = "0.11.0+git${SRCPV}" | 13 | PV = "0.11.0+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-md2man_git.bb b/recipes-devtools/go/go-md2man_git.bb index a62f4832..d02f3244 100644 --- a/recipes-devtools/go/go-md2man_git.bb +++ b/recipes-devtools/go/go-md2man_git.bb | |||
@@ -9,7 +9,7 @@ BBCLASSEXTEND = "native" | |||
9 | GO_IMPORT = "github.com/cpuguy83/go-md2man" | 9 | GO_IMPORT = "github.com/cpuguy83/go-md2man" |
10 | #GO_INSTALL = "${GO_IMPORT}/bin/go-md2man" | 10 | #GO_INSTALL = "${GO_IMPORT}/bin/go-md2man" |
11 | 11 | ||
12 | SRC_URI = "git://${GO_IMPORT}.git" | 12 | SRC_URI = "git://${GO_IMPORT}.git;branch=master" |
13 | 13 | ||
14 | SRCREV = "f79a8a8ca69da163eee19ab442bedad7a35bba5a" | 14 | SRCREV = "f79a8a8ca69da163eee19ab442bedad7a35bba5a" |
15 | PV = "1.0.10+git${SRCPV}" | 15 | PV = "1.0.10+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-metalinter_git.bb b/recipes-devtools/go/go-metalinter_git.bb index 50402e39..3bef3b5c 100644 --- a/recipes-devtools/go/go-metalinter_git.bb +++ b/recipes-devtools/go/go-metalinter_git.bb | |||
@@ -9,7 +9,7 @@ BBCLASSEXTEND = "native" | |||
9 | SRCNAME = "gometalinter" | 9 | SRCNAME = "gometalinter" |
10 | 10 | ||
11 | PKG_NAME = "github.com/alecthomas/${SRCNAME}" | 11 | PKG_NAME = "github.com/alecthomas/${SRCNAME}" |
12 | SRC_URI = "git://${PKG_NAME}.git" | 12 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
13 | 13 | ||
14 | SRCREV = "e8d801238da6f0dfd14078d68f9b53fa50a7eeb5" | 14 | SRCREV = "e8d801238da6f0dfd14078d68f9b53fa50a7eeb5" |
15 | PV = "0.0+git${SRCPV}" | 15 | PV = "0.0+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-mux_git.bb b/recipes-devtools/go/go-mux_git.bb index b5a78d9b..c0db0501 100644 --- a/recipes-devtools/go/go-mux_git.bb +++ b/recipes-devtools/go/go-mux_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c50f6bd9c1e15ed0bad3bea18e3c1b7f" | |||
7 | SRCNAME = "mux" | 7 | SRCNAME = "mux" |
8 | 8 | ||
9 | PKG_NAME = "github.com/gorilla/${SRCNAME}" | 9 | PKG_NAME = "github.com/gorilla/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "136d54f81f00414c45c3c68dd47e98cc97519c5e" | 12 | SRCREV = "136d54f81f00414c45c3c68dd47e98cc97519c5e" |
13 | 13 | ||
diff --git a/recipes-devtools/go/go-patricia_git.bb b/recipes-devtools/go/go-patricia_git.bb index 4e546abc..10985607 100644 --- a/recipes-devtools/go/go-patricia_git.bb +++ b/recipes-devtools/go/go-patricia_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=9949b99212edd6b1e24ce702376c3baf" | |||
7 | SRCNAME = "go-patricia" | 7 | SRCNAME = "go-patricia" |
8 | 8 | ||
9 | PKG_NAME = "github.com/tchap/${SRCNAME}" | 9 | PKG_NAME = "github.com/tchap/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "666120de432aea38ab06bd5c818f04f4129882c9" | 12 | SRCREV = "666120de432aea38ab06bd5c818f04f4129882c9" |
13 | PV = "2.2.6+git${SRCPV}" | 13 | PV = "2.2.6+git${SRCPV}" |
diff --git a/recipes-devtools/go/go-pty_git.bb b/recipes-devtools/go/go-pty_git.bb index f6eeaa29..0baa70d7 100644 --- a/recipes-devtools/go/go-pty_git.bb +++ b/recipes-devtools/go/go-pty_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://License;md5=93958070863d769117fa33b129020050" | |||
7 | SRCNAME = "pty" | 7 | SRCNAME = "pty" |
8 | 8 | ||
9 | PKG_NAME = "github.com/creack/${SRCNAME}" | 9 | PKG_NAME = "github.com/creack/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git" | 10 | SRC_URI = "git://${PKG_NAME}.git;branch=master" |
11 | 11 | ||
12 | SRCREV = "05017fcccf23c823bfdea560dcc958a136e54fb7" | 12 | SRCREV = "05017fcccf23c823bfdea560dcc958a136e54fb7" |
13 | 13 | ||
diff --git a/recipes-devtools/go/grpc-go_git.bb b/recipes-devtools/go/grpc-go_git.bb index 363e79dc..188ad71c 100644 --- a/recipes-devtools/go/grpc-go_git.bb +++ b/recipes-devtools/go/grpc-go_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=3b83ef96387f14655fc854ddc | |||
7 | SRCNAME = "grpc-go" | 7 | SRCNAME = "grpc-go" |
8 | 8 | ||
9 | PKG_NAME = "google.golang.org/grpc" | 9 | PKG_NAME = "google.golang.org/grpc" |
10 | SRC_URI = "git://github.com/grpc/${SRCNAME}.git;destsuffix=git/src/${PKG_NAME}" | 10 | SRC_URI = "git://github.com/grpc/${SRCNAME}.git;destsuffix=git/src/${PKG_NAME};branch=master" |
11 | 11 | ||
12 | SRCREV = "5d8e5aad40bedb696205b96b786f1d0e1326b3f8" | 12 | SRCREV = "5d8e5aad40bedb696205b96b786f1d0e1326b3f8" |
13 | PV = "1.41.0+git${SRCPV}" | 13 | PV = "1.41.0+git${SRCPV}" |
diff --git a/recipes-devtools/go/notary_git.bb b/recipes-devtools/go/notary_git.bb index 105a4cb8..3e908a0c 100644 --- a/recipes-devtools/go/notary_git.bb +++ b/recipes-devtools/go/notary_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=3596b980bb036e0875174ed15 | |||
7 | SRCNAME = "notary" | 7 | SRCNAME = "notary" |
8 | 8 | ||
9 | PKG_NAME = "github.com/docker/${SRCNAME}" | 9 | PKG_NAME = "github.com/docker/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}" | 10 | SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master" |
11 | 11 | ||
12 | SRCREV = "d6e1431feb32348e0650bf7551ac5cffd01d857b" | 12 | SRCREV = "d6e1431feb32348e0650bf7551ac5cffd01d857b" |
13 | PV = "0.6.1+git${SRCPV}" | 13 | PV = "0.6.1+git${SRCPV}" |