summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch
diff options
context:
space:
mode:
authorZumeng Chen <zumeng.chen@windriver.com>2016-05-19 23:57:28 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-05-20 12:36:54 -0400
commit0afa6e168ea6421fdaeedb426c2131b7db1f9ed9 (patch)
tree23f6011d064f270dcc573587e8c1b081fde517f9 /recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch
parent823c8cfcdf107a7cf6a7b2f39bc9c15fd81b9f78 (diff)
downloadmeta-virtualization-0afa6e168ea6421fdaeedb426c2131b7db1f9ed9.tar.gz
protobuf: add protobuf-2.5.0 into devtool
Protocol Buffers(a.k.a., protobuf) are language-neutral, platform-neutral, extensible mechanism for serializing structured data, so it is reasonable to be a part of development tool recipe. Signed-off-by: Zumeng Chen <zumeng.chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch')
-rw-r--r--recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch b/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch
new file mode 100644
index 00000000..8b293428
--- /dev/null
+++ b/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch
@@ -0,0 +1,38 @@
1From 46e331263eb92e47510e88478b255f226d30245c Mon Sep 17 00:00:00 2001
2From: Keith Holman <Keith.Holman@windriver.com>
3Date: Mon, 18 Aug 2014 15:19:35 -0400
4Subject: [PATCH] protobuf: allow running python scripts from anywhere
5
6The Makefile to generate the examples with Google Protocol Buffers
7generates some scripts for python. However, these generated scripts
8only work if they are ran in the same directory as the source files.
9This fix generates scripts to execute from anywhere on the system.
10
11Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
12---
13 examples/Makefile | 6 ++++--
14 1 file changed, 4 insertions(+), 2 deletions(-)
15
16diff --git a/examples/Makefile b/examples/Makefile
17index 8dc9083..a993d63 100644
18--- a/examples/Makefile
19+++ b/examples/Makefile
20@@ -48,11 +48,13 @@ list_people_java: javac_middleman
21 add_person_python: add_person.py protoc_middleman
22 @echo "Writing shortcut script add_person_python..."
23 @echo '#! /bin/sh' > add_person_python
24- @echo './add_person.py "$$@"' >> add_person_python
25+ @echo 'SCRIPT_DIR=$$(dirname $$0)' >> add_person_python
26+ @echo '$$SCRIPT_DIR/add_person.py "$$@"' >> add_person_python
27 @chmod +x add_person_python
28
29 list_people_python: list_people.py protoc_middleman
30 @echo "Writing shortcut script list_people_python..."
31 @echo '#! /bin/sh' > list_people_python
32- @echo './list_people.py "$$@"' >> list_people_python
33+ @echo 'SCRIPT_DIR=$$(dirname $$0)' >> list_people_python
34+ @echo '$$SCRIPT_DIR/list_people.py "$$@"' >> list_people_python
35 @chmod +x list_people_python
36--
371.9.3
38