summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-sqlalchemy_0.9.7.bb
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2015-03-12 21:42:44 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-03-17 09:46:32 -0400
commit938c1cb12706691387c75d69dce47fdcaef09bdf (patch)
tree56342617e8c78ae156c6917da6d060ab30f93368 /recipes-devtools/python/python-sqlalchemy_0.9.7.bb
parent33ea7df40bc5aa9a34f4362e976775be1076e876 (diff)
downloadmeta-virtualization-938c1cb12706691387c75d69dce47fdcaef09bdf.tar.gz
docker: Add dependencies for docker and docker-registry
These are a set of dependencies required to build and run docker and docker-registry which had previously existed in meta-cloud-services. By moving these from meta-cloud-services to meta-virtualization we can build and use docker without needing to include meta-cloud-services. Since meta-cloud-services depends on meta-virtualization these recipes will still be available for use with packages/images in meta-cloud-services. There is a concern that meta-cloud-services contains many python packages as there exists tight dependency for specific package versions, this move does not prevent this tight binding from continuing using various mechanisms made available to layers. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'recipes-devtools/python/python-sqlalchemy_0.9.7.bb')
-rw-r--r--recipes-devtools/python/python-sqlalchemy_0.9.7.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-sqlalchemy_0.9.7.bb b/recipes-devtools/python/python-sqlalchemy_0.9.7.bb
new file mode 100644
index 00000000..6207233e
--- /dev/null
+++ b/recipes-devtools/python/python-sqlalchemy_0.9.7.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6c90a3830628085e8ba945f94d622cb2"
6RDEPENDS_${PN} += "python-numbers"
7
8SRCNAME = "SQLAlchemy"
9SRC_URI = "https://pypi.python.org/packages/source/S/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "e3c8f836ea9b48886718f59b9d8646ff"
12SRC_URI[sha256sum] = "5fff261d0cff21c39913f9d30682659a52bfa2875699b2b7d908d0225df42a15"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools