diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-03-29 09:50:52 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-03-29 10:04:49 -0400 |
commit | c77f64d10075cba0cd01ed3e1f4ed32be1f17e2b (patch) | |
tree | edd1ba07e1690f37b75d2146a20770c22b396bc0 /recipes-extended/kvmtool/files/external-crosscompiler.patch | |
parent | cd8f8873a0d6fbdc0886b3dd6a24fd4ae46c470d (diff) | |
download | meta-virtualization-c77f64d10075cba0cd01ed3e1f4ed32be1f17e2b.tar.gz |
kvmtool: update to -tip
Bumping kvmtool to latest, which comprises the following commits:
faae833 Revert "kvm tools: Filter out CPU vendor string"
1b76b6e Add --no-pvtime command line argument
7d4671e aarch64: Add stolen time support
ff69582 aarch64: Populate the vCPU struct before target->init()
95f4796 arm: pci: Generate "msi-parent" property only with a MSI controller
c334a68 arm: Use pr_debug() to print memory layout when loading a firmware image
9b681b0 Remove initrd magic check
2108c86 virtio/pci: Signal INTx interrupts as level instead of edge
20b93be x86: Set the correct APIC ID
d4d6f15 x86: Fix initialization of irq mptable
cdd7d8c riscv: Generate PCI host DT node
721da16 riscv: Handle SBI calls forwarded to user space
7c9aac0 riscv: Generate FDT at runtime for Guest/VM
762224e riscv: Add PLIC device emulation
42bfe44 riscv: Implement Guest/VM VCPU arch functions
867159a riscv: Implement Guest/VM arch functions
2e99678 riscv: Initial skeletal support
5968b5f update_headers: Sync-up ABI headers with Linux-5.16-rc1
642f35b Makefile: Calculate the correct kvmtool version
7a60af0 arm/pci: update interrupt-map only for legacy interrupts
39181fc vfio/pci: Align MSIX Table and PBA size to guest maximum page size
b20d6e3 vfio/pci: Print an error when offset is outside of the MSIX table or PBA
f93acc0 vfio/pci: Rework MSIX table and PBA physical size allocation
5f44d5d vfio/pci: Rename PBA offset in device descriptor to fd_offset
34bfe5f pci: Fix pci_dev_* print macros
3d3dca0 vfio/pci.c: Remove double include for assert.h
e3b0ade arm/gicv2m: Set errno when gicv2_update_routing() fails
dc66461 arm64: Be more permissive when parsing the kernel header
5303f09 arm64: Use the default offset when the kernel image magic is not found
5613ae2 Add --nodefaults command line argument
a5253f7 builtin-run: Move kernel command line generation to a separate function
39ab3a0 Use kvm->nr_disks instead of kvm->cfg.image_count
cce9616 builtin-run: Abstract argument validation into a separate function
638630c builtin-run: Do not attempt to find vmlinux if --firmware
6cbec43 builtin-run: Warn when ignoring initrd because --firmware was specified
6810e75 builtin-run: Treat specifying both --kernel and --firmware as an error
2e7380d virtio/pci: Size the MSI-X bar according to the number of MSI-X
bdb86d0 kvmtool: arm64: Configure VM with the minimal required IPA space
066b5c0 kvmtool: arm64: Use the maximum supported IPA size when creating the VM
4250819 kvmtool: Abstract KVM_VM_TYPE into a weak function
25c1dc6 arm/arm64: vfio: Add PCI Express Capability Structure
e69b766 arm/arm64: Add PCI Express 1.1 support
6b74f68 arm/fdt.c: Don't generate the node if generator function is NULL
070fb91 Move fdt_irq_fn typedef to fdt.h
415f92c arm: Fail early if KVM_CAP_ARM_PMU_V3 is not supported
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/kvmtool/files/external-crosscompiler.patch')
-rw-r--r-- | recipes-extended/kvmtool/files/external-crosscompiler.patch | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-extended/kvmtool/files/external-crosscompiler.patch b/recipes-extended/kvmtool/files/external-crosscompiler.patch index ab030c73..b8780245 100644 --- a/recipes-extended/kvmtool/files/external-crosscompiler.patch +++ b/recipes-extended/kvmtool/files/external-crosscompiler.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From b89ba4256cb6074aee74ea5386bc5ca8e75d4653 Mon Sep 17 00:00:00 2001 | 1 | From 91b7123682c67ec8b0c50147c9ebd59efa563f26 Mon Sep 17 00:00:00 2001 |
2 | From: Stefan Agner <stefan@agner.ch> | 2 | From: Stefan Agner <stefan@agner.ch> |
3 | Date: Tue, 6 Sep 2016 11:51:40 -0700 | 3 | Date: Tue, 6 Sep 2016 11:51:40 -0700 |
4 | Subject: [PATCH] kvmtool: add lightweight hypervisor native Linux KVM tool | 4 | Subject: [PATCH] kvmtool: add lightweight hypervisor native Linux KVM tool |
@@ -14,12 +14,12 @@ be linked against the cross-compiled libfdt library. | |||
14 | 1 file changed, 1 insertion(+), 7 deletions(-) | 14 | 1 file changed, 1 insertion(+), 7 deletions(-) |
15 | 15 | ||
16 | diff --git a/Makefile b/Makefile | 16 | diff --git a/Makefile b/Makefile |
17 | index 35bb118..3787df2 100644 | 17 | index e9121dc..c05b2c0 100644 |
18 | --- a/Makefile | 18 | --- a/Makefile |
19 | +++ b/Makefile | 19 | +++ b/Makefile |
20 | @@ -18,12 +18,6 @@ export E Q | 20 | @@ -19,12 +19,6 @@ include config/utilities.mak |
21 | include config/utilities.mak | ||
22 | include config/feature-tests.mak | 21 | include config/feature-tests.mak |
22 | -include $(OUTPUT)KVMTOOLS-VERSION-FILE | ||
23 | 23 | ||
24 | -CC := $(CROSS_COMPILE)gcc | 24 | -CC := $(CROSS_COMPILE)gcc |
25 | -CFLAGS := | 25 | -CFLAGS := |
@@ -30,7 +30,7 @@ index 35bb118..3787df2 100644 | |||
30 | FIND := find | 30 | FIND := find |
31 | CSCOPE := cscope | 31 | CSCOPE := cscope |
32 | TAGS := ctags | 32 | TAGS := ctags |
33 | @@ -319,7 +313,7 @@ $(warning No static libc found. Skipping guest init) | 33 | @@ -343,7 +337,7 @@ $(warning No static libc found. Skipping guest init) |
34 | endif | 34 | endif |
35 | 35 | ||
36 | ifeq (y,$(ARCH_WANT_LIBFDT)) | 36 | ifeq (y,$(ARCH_WANT_LIBFDT)) |