diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-07-10 03:45:58 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-07-10 15:59:26 +0000 |
commit | 61cec3e210f58e0c6d05cde1012d0cf6ea072795 (patch) | |
tree | 38adf6664cb0dd9f86a5c9e780ed1500fa6173b9 /recipes-extended/libvirt/libvirt-python.inc | |
parent | 7d0768c428517ed91d589ffd3ec5956e9704e20b (diff) | |
download | meta-virtualization-61cec3e210f58e0c6d05cde1012d0cf6ea072795.tar.gz |
libvirt: update to v10.5.0 and convert to git
Rather than waiting for release tarballs for the main libvirt
release, we can just use the git repository directory and
avoid patch backporting for CVEs, etc.
As part of this change, we adjust to git, refresh our
meson build patch, and add a new meson patch for the
tests.
We also split out LIBVIRT_VERSION, so that nested builds
can use it to locate tarballs.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/libvirt/libvirt-python.inc')
-rw-r--r-- | recipes-extended/libvirt/libvirt-python.inc | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc index 40c362d6..471d33d6 100644 --- a/recipes-extended/libvirt/libvirt-python.inc +++ b/recipes-extended/libvirt/libvirt-python.inc | |||
@@ -18,9 +18,9 @@ FILES:${PN}-python = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*" | |||
18 | # Currently the libvirt-python debug libraries contain buildpaths | 18 | # Currently the libvirt-python debug libraries contain buildpaths |
19 | INSANE_SKIP:${PN}-dbg += "buildpaths" | 19 | INSANE_SKIP:${PN}-dbg += "buildpaths" |
20 | 20 | ||
21 | SRC_URI += "http://libvirt.org/sources/python/${BPN}-python-${PV}.tar.gz;name=libvirt_python;subdir=${BP}" | 21 | SRC_URI += "http://libvirt.org/sources/python/${BPN}-python-${LIBVIRT_VERSION}.tar.gz;name=libvirt_python;subdir=${BP}" |
22 | 22 | ||
23 | SRC_URI[libvirt_python.sha256sum] = "a82588f0e7db53eda7b7dbcbc448b0ec43e00a8c77cac69644495299b410c20d" | 23 | SRC_URI[libvirt_python.sha256sum] = "785023500f58d3e8e829af98647d43eee97e517aacc9d9e7ded43594ea52d032" |
24 | 24 | ||
25 | export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml" | 25 | export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml" |
26 | export LIBVIRT_CFLAGS = "-I${S}/include" | 26 | export LIBVIRT_CFLAGS = "-I${S}/include" |
@@ -46,7 +46,7 @@ do_compile:append() { | |||
46 | # the syroot staged pkgconfig entries. So we clear the sysroot | 46 | # the syroot staged pkgconfig entries. So we clear the sysroot |
47 | # for just this portion. | 47 | # for just this portion. |
48 | export PKG_CONFIG_SYSROOT_DIR= | 48 | export PKG_CONFIG_SYSROOT_DIR= |
49 | cd ${S}/${BPN}-python-${PV} && \ | 49 | cd ${UNPACKDIR}/${BP}/${BPN}-python-${LIBVIRT_VERSION} && \ |
50 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py build | 50 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py build |
51 | cd - | 51 | cd - |
52 | fi | 52 | fi |
@@ -58,7 +58,7 @@ do_install:append() { | |||
58 | # the syroot staged pkgconfig entries. So we clear the sysroot | 58 | # the syroot staged pkgconfig entries. So we clear the sysroot |
59 | # for just this portion. | 59 | # for just this portion. |
60 | export PKG_CONFIG_SYSROOT_DIR= | 60 | export PKG_CONFIG_SYSROOT_DIR= |
61 | cd ${S}/${BPN}-python-${PV} && \ | 61 | cd ${UNPACKDIR}/${BP}/${BPN}-python-${LIBVIRT_VERSION} && \ |
62 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py install \ | 62 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py install \ |
63 | --install-lib=${D}/${PYTHON_SITEPACKAGES_DIR} ${LIBVIRT_INSTALL_ARGS} | 63 | --install-lib=${D}/${PYTHON_SITEPACKAGES_DIR} ${LIBVIRT_INSTALL_ARGS} |
64 | cd - | 64 | cd - |