summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libvirt/libvirt/0001-to-fix-build-error.patch
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-06-05 10:01:48 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-06-05 12:01:01 -0400
commit343b40ba0d44caeb22013a1586ae2159e415bd4c (patch)
tree3c5fdb72c38b060aeefccff3cd85091b5a5421c3 /recipes-extended/libvirt/libvirt/0001-to-fix-build-error.patch
parent1fd1ff3720140baa3680d795f6d97597e5113e90 (diff)
downloadmeta-virtualization-343b40ba0d44caeb22013a1586ae2159e415bd4c.tar.gz
libvirt: uprev to the latest release, v4.3.0
We have been using the 1.3.x release series for a long time now which has been great for stability but is slowly becoming harder and harder to track and port bug and CVE fixes. This is a big jump to the latest upstream release which gives us access to a myriad of fixes as well as puts us in a better position to contribute to the upstream project when issues are found. Several patches have been dropped as they are either no longer valid against this release or have equivalent updates already applied to the upstream project. Some patches were consolidated which should ease future uprevs of this recipe. The majority of the updates were related to ptest patches, which is not a huge surprise given this code has no upstream equivalent. The overall runtime behavior remains much the same from v1.3.5 with the only notable configuration change being for 'seccomp_sandbox' which has been disabled here but should possibly be revisited in the near future. As usual the normal runtime usecases for qemu/kvm and lxc have been run successfully along with ptest results which are by and large OK: ==================================== Testsuite summary for libvirt 4.3.0 ==================================== # TOTAL: 119 # PASS: 115 # SKIP: 0 # XFAIL: 0 # FAIL: 4 # XPASS: 0 # ERROR: 0 Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/libvirt/libvirt/0001-to-fix-build-error.patch')
-rw-r--r--recipes-extended/libvirt/libvirt/0001-to-fix-build-error.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt/0001-to-fix-build-error.patch b/recipes-extended/libvirt/libvirt/0001-to-fix-build-error.patch
new file mode 100644
index 00000000..c920139e
--- /dev/null
+++ b/recipes-extended/libvirt/libvirt/0001-to-fix-build-error.patch
@@ -0,0 +1,49 @@
1From 8353dc1e642011199c3b3ba057d51d8768e4cd54 Mon Sep 17 00:00:00 2001
2From: Lei Maohui <leimaohui@cn.fujitsu.com>
3Date: Fri, 31 Jul 2015 03:17:07 +0900
4Subject: [PATCH] to fix build error
5
6The error likes as following
7
8| Generating internals/command.html.tmp
9| /bin/sh: line 3: internals/command.html.tmp: No such file or directory
10| rm: Generating internals/locking.html.tmp
11| cannot remove `internals/command.html.tmp': No such file or directory
12| make[3]: *** [internals/command.html.tmp] Error 1
13| make[3]: *** Waiting for unfinished jobs....
14
15Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
16[ywei: rebased to libvirt-1.3.2]
17Signed-off-by: Yunguo Wei <yunguo.wei@windriver.com>
18[MA: rebase to v4.3.0]
19Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
20---
21 docs/Makefile.am | 5 ++---
22 1 file changed, 2 insertions(+), 3 deletions(-)
23
24diff --git a/docs/Makefile.am b/docs/Makefile.am
25index 9620587..060a82b 100644
26--- a/docs/Makefile.am
27+++ b/docs/Makefile.am
28@@ -183,7 +183,7 @@ EXTRA_DIST= \
29 hvsupport.pl \
30 $(schema_DATA)
31
32-acl_generated = aclperms.htmlinc
33+acl.html:: $(srcdir)/aclperms.htmlinc
34
35 $(srcdir)/aclperms.htmlinc: $(top_srcdir)/src/access/viraccessperm.h \
36 $(srcdir)/genaclperms.pl Makefile.am
37@@ -247,8 +247,7 @@ MAINTAINERCLEANFILES += \
38 %.png: %.fig
39 convert -rotate 90 $< $@
40
41-%.html.tmp: %.html.in site.xsl subsite.xsl page.xsl \
42- $(acl_generated)
43+%.html.tmp: %.html.in site.xsl subsite.xsl page.xsl
44 $(AM_V_GEN)name=`echo $@ | sed -e 's/.tmp//'`; \
45 dir=`dirname $@` ; \
46 if test "$$dir" = "."; \
47--
481.9.1
49