diff options
author | Christopher Clark <christopher.w.clark@gmail.com> | 2019-04-16 13:35:37 -0700 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2019-04-18 09:32:40 -0400 |
commit | 9168b0ce83104b2c10b74aacda09f0aeeafc6aa9 (patch) | |
tree | 226036786b0399e7fce60f29825ea5491b9da277 /recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-env-vars-as-setup.py-ar.patch | |
parent | 15caed2f436afd6ab07a0865b161c54f51bab6a4 (diff) | |
download | meta-virtualization-9168b0ce83104b2c10b74aacda09f0aeeafc6aa9.tar.gz |
xen: upgrade to 4.12.0
Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-env-vars-as-setup.py-ar.patch')
-rw-r--r-- | recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-env-vars-as-setup.py-ar.patch | 63 |
1 files changed, 0 insertions, 63 deletions
diff --git a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-env-vars-as-setup.py-ar.patch b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-env-vars-as-setup.py-ar.patch deleted file mode 100644 index 03c39fe7..00000000 --- a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-env-vars-as-setup.py-ar.patch +++ /dev/null | |||
@@ -1,63 +0,0 @@ | |||
1 | From d79dcc2002008c58683de82f06c168d6eea57991 Mon Sep 17 00:00:00 2001 | ||
2 | From: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> | ||
3 | Date: Fri, 19 Oct 2018 11:01:37 +0200 | ||
4 | Subject: [PATCH] python,pygrub: pass DISTUTILS env vars as setup.py args | ||
5 | |||
6 | Allow to respect the target install dir (PYTHON_SITEPACKAGES_DIR) | ||
7 | as well as other parameters set by the OpenEmbedded build system. | ||
8 | This is especially useful when the target libdir is not the default one | ||
9 | (/usr/lib), but for example /usr/lib64. | ||
10 | |||
11 | Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> | ||
12 | --- | ||
13 | tools/pygrub/Makefile | 5 +++-- | ||
14 | tools/python/Makefile | 4 ++-- | ||
15 | 2 files changed, 5 insertions(+), 4 deletions(-) | ||
16 | |||
17 | diff --git a/tools/pygrub/Makefile b/tools/pygrub/Makefile | ||
18 | index 536af07932b4..e1c773101412 100644 | ||
19 | --- a/tools/pygrub/Makefile | ||
20 | +++ b/tools/pygrub/Makefile | ||
21 | @@ -10,14 +10,15 @@ INSTALL_LOG = build/installed_files.txt | ||
22 | all: build | ||
23 | .PHONY: build | ||
24 | build: | ||
25 | - CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build | ||
26 | + CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS) | ||
27 | |||
28 | .PHONY: install | ||
29 | install: all | ||
30 | $(INSTALL_DIR) $(DESTDIR)/$(bindir) | ||
31 | CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \ | ||
32 | setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \ | ||
33 | - --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force | ||
34 | + --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force \ | ||
35 | + $(DISTUTILS_INSTALL_ARGS) | ||
36 | set -e; if [ $(bindir) != $(LIBEXEC_BIN) -a \ | ||
37 | "`readlink -f $(DESTDIR)/$(bindir)`" != \ | ||
38 | "`readlink -f $(LIBEXEC_BIN)`" ]; then \ | ||
39 | diff --git a/tools/python/Makefile b/tools/python/Makefile | ||
40 | index 541858e2f886..4d4a344f1d33 100644 | ||
41 | --- a/tools/python/Makefile | ||
42 | +++ b/tools/python/Makefile | ||
43 | @@ -10,7 +10,7 @@ INSTALL_LOG = build/installed_files.txt | ||
44 | |||
45 | .PHONY: build | ||
46 | build: | ||
47 | - CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build | ||
48 | + CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS) | ||
49 | |||
50 | .PHONY: install | ||
51 | install: | ||
52 | @@ -18,7 +18,7 @@ install: | ||
53 | |||
54 | CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \ | ||
55 | setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \ | ||
56 | - --root="$(DESTDIR)" --force | ||
57 | + --root="$(DESTDIR)" --force $(DISTUTILS_INSTALL_ARGS) | ||
58 | |||
59 | $(INSTALL_PROG) scripts/convert-legacy-stream $(DESTDIR)$(LIBEXEC_BIN) | ||
60 | $(INSTALL_PROG) scripts/verify-stream-v2 $(DESTDIR)$(LIBEXEC_BIN) | ||
61 | -- | ||
62 | 2.7.4 | ||
63 | |||