diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2017-01-11 17:12:35 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-01-12 14:01:36 -0500 |
commit | 9152441483600a4f102320c805e892a4cd0252dd (patch) | |
tree | aa2a9f660c34d6c9bd30588443179f9c2f59652d /recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch | |
parent | dbe846086b49fc07d278adbefa476d34bbbb0c13 (diff) | |
download | meta-virtualization-9152441483600a4f102320c805e892a4cd0252dd.tar.gz |
openvswitch: uprev to 2.6.1
Pick up the latest features, including compatability with the latest
DPDK as well as bug fixes.
The patches for TARGET_PYTHON and TARGET_PERL can be dropped as
configure now lets us pass these in the env (which we set).
The systemd service files have been shuffled some upstream and we make
adjustments in the recipe to accomodate these. The sysvinit scripts
remain functional as they are.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch')
-rw-r--r-- | recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch | 48 |
1 files changed, 0 insertions, 48 deletions
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch b/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch deleted file mode 100644 index 98224b42..00000000 --- a/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | From 569ac1066cd3046b8ac899153df9f07908d45145 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | ||
3 | Date: Fri, 21 Jun 2013 11:16:00 -0400 | ||
4 | Subject: [PATCH] openvswitch: add target perl handling | ||
5 | |||
6 | Allow the build to specify a path for the perl instead of reusing | ||
7 | the PERL variable which can lead to inconsistencies if we are cross | ||
8 | compiling. The TARGET_PERL variable will be used for script | ||
9 | substitutions to ensure the scripts will be able to properly execute | ||
10 | if the target system has a different path for the perl. | ||
11 | |||
12 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | ||
13 | --- | ||
14 | Makefile.am | 1 + | ||
15 | configure.ac | 7 +++++++ | ||
16 | utilities/ovs-parse-leaks.in | 2 +- | ||
17 | 3 files changed, 9 insertions(+), 1 deletion(-) | ||
18 | |||
19 | Index: openvswitch-2.0.0/Makefile.am | ||
20 | =================================================================== | ||
21 | --- openvswitch-2.0.0.orig/Makefile.am | ||
22 | +++ openvswitch-2.0.0/Makefile.am | ||
23 | @@ -114,6 +114,7 @@ | ||
24 | -e 's,[@]LOGDIR[@],$(LOGDIR),g' \ | ||
25 | -e 's,[@]DBDIR[@],$(DBDIR),g' \ | ||
26 | -e 's,[@]PERL[@],$(PERL),g' \ | ||
27 | + -e 's,[@]TARGET_PERL[@],$(TARGET_PERL),g' \ | ||
28 | -e 's,[@]PYTHON[@],$(PYTHON),g' \ | ||
29 | -e 's,[@]TARGET_PYTHON[@],$(TARGET_PYTHON),g' \ | ||
30 | -e 's,[@]RUNDIR[@],$(RUNDIR),g' \ | ||
31 | Index: openvswitch-2.0.0/configure.ac | ||
32 | =================================================================== | ||
33 | --- openvswitch-2.0.0.orig/configure.ac | ||
34 | +++ openvswitch-2.0.0/configure.ac | ||
35 | @@ -115,6 +115,13 @@ | ||
36 | AC_SUBST(KARCH) | ||
37 | OVS_CHECK_LINUX | ||
38 | |||
39 | +if test "$TARGET_PERL"; then | ||
40 | + TARGET_PERL=$TARGET_PERL | ||
41 | +else | ||
42 | + TARGET_PERL=$PERL | ||
43 | +fi | ||
44 | +AC_SUBST(TARGET_PERL) | ||
45 | + | ||
46 | if test "$TARGET_PYTHON"; then | ||
47 | TARGET_PYTHON=$TARGET_PYTHON | ||
48 | else | ||