diff options
author | Hongzhi.Song <hongzhi.song@windriver.com> | 2019-01-30 02:46:52 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2019-02-03 03:49:55 +0000 |
commit | f9acf9a26617fe3eb4aac5d648f488ad0023a6ff (patch) | |
tree | 5f87f6b50a0edfb7a52b8f3a3a9a9ef1a1f46166 /recipes-networking/openvswitch/openvswitch-git/kernel_module.patch | |
parent | 274a72a5dba083f1f09ffedf19ac6e7838e20a41 (diff) | |
download | meta-virtualization-f9acf9a26617fe3eb4aac5d648f488ad0023a6ff.tar.gz |
openvswitch: uprev from v2.10.1 to v2.11
The v2.11 version fixed a bug as follow.
Error info:
ovs|00002|db_ctl_base|ERR|external-ids:hostname=: argument does not
end in "=" followed by a value.
The result of ptest between v2.11 and v2.10.1 is similar.
v2.11:
ERROR: 2765 tests were run,
317 failed (1 expected failure).
85 tests were skipped.
v2.10.1:
ERROR: 2662 tests were run,
311 failed (1 expected failure).
85 tests were skipped.
I checked the detailed result. The failed tests were mostly related
to python2 as the image only use python3.
Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch-git/kernel_module.patch')
-rw-r--r-- | recipes-networking/openvswitch/openvswitch-git/kernel_module.patch | 25 |
1 files changed, 14 insertions, 11 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch b/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch index c177202f..5e5a38d9 100644 --- a/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch +++ b/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch | |||
@@ -1,26 +1,29 @@ | |||
1 | From adfd2380d71dff1a31efaf63cf7ac97470466ec9 Mon Sep 17 00:00:00 2001 | 1 | From 9b7fb1346702d59af67435487254ef35940bc16a Mon Sep 17 00:00:00 2001 |
2 | From: Amy Fong <amy.fong@windriver.com> | 2 | From: "Hongzhi.Song" <hongzhi.song@windriver.com> |
3 | Date: Thu, 29 Jan 2015 09:56:03 -0500 | 3 | Date: Wed, 23 Jan 2019 03:41:30 -0500 |
4 | Subject: [PATCH] Specify install path for kernel module | 4 | Subject: [PATCH] datapatch/linux: Specify install path for kernel module |
5 | 5 | ||
6 | Signed-off-by: Amy Fong <amy.fong@windriver.com> | 6 | Signed-off-by: Amy Fong <amy.fong@windriver.com> |
7 | 7 | Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> | |
8 | --- | 8 | --- |
9 | datapath/linux/Makefile.main.in | 4 ++-- | 9 | datapath/linux/Makefile.main.in | 4 ++-- |
10 | 1 file changed, 2 insertions(+), 2 deletions(-) | 10 | 1 file changed, 2 insertions(+), 2 deletions(-) |
11 | 11 | ||
12 | diff --git a/datapath/linux/Makefile.main.in b/datapath/linux/Makefile.main.in | 12 | diff --git a/datapath/linux/Makefile.main.in b/datapath/linux/Makefile.main.in |
13 | index 7d18253..63c520f 100644 | 13 | index 328bbfb..6dcc8d0 100644 |
14 | --- a/datapath/linux/Makefile.main.in | 14 | --- a/datapath/linux/Makefile.main.in |
15 | +++ b/datapath/linux/Makefile.main.in | 15 | +++ b/datapath/linux/Makefile.main.in |
16 | @@ -71,8 +71,8 @@ default: | 16 | @@ -71,8 +71,8 @@ default: |
17 | $(MAKE) -C $(KSRC) M=$(builddir) modules | 17 | $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules |
18 | 18 | ||
19 | modules_install: | 19 | modules_install: |
20 | - $(MAKE) -C $(KSRC) M=$(builddir) modules_install | 20 | - $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules_install |
21 | - depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h` | 21 | - /sbin/depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h` |
22 | + $(MAKE) -C $(KSRC) M=$(builddir) modules_install INSTALL_MOD_PATH=${INSTALL_MOD_PATH} | 22 | + $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules_install INSTALL_MOD_PATH=${INSTALL_MOD_PATH} |
23 | + # depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h` | 23 | + #/sbin/depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h` |
24 | endif | 24 | endif |
25 | 25 | ||
26 | # Much of the kernel build system in this file is derived from Intel's | 26 | # Much of the kernel build system in this file is derived from Intel's |
27 | -- | ||
28 | 2.8.1 | ||
29 | |||