diff options
author | Bin Lan <bin.lan.cn@windriver.com> | 2024-10-21 19:23:43 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-11-02 00:03:41 -0400 |
commit | 2747f11e79c29ed4bced84e3b536ae9549aacc79 (patch) | |
tree | 56d313fa44c332303e10f344134878c25bc38f5d /recipes-networking/openvswitch/openvswitch-git | |
parent | b4fe1f4933a754c4c869a3e47a9772d71987b3f5 (diff) | |
download | meta-virtualization-2747f11e79c29ed4bced84e3b536ae9549aacc79.tar.gz |
openvswitch: fix ptest contains reference to TMPDIR [buildpaths]
The EGREP in ptest/tests/atlocal contains the build paths.
The CFLAGS in ptest/tests/atlocal contains the build paths.
This change set fixs:
- set EGREP to "grep -E" in ptest/tests/atlocal
- set CFLAGS to " " in ptest/tests/atlocal
by updating the patch
openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch.
Signed-off-by: Bin Lan <bin.lan.cn@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch-git')
-rw-r--r-- | recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch | 11 |
1 files changed, 10 insertions, 1 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch index 571753a5..abad1458 100644 --- a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch +++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch | |||
@@ -16,6 +16,13 @@ Signed-off-by: He Zhe <zhe.he@windriver.com> | |||
16 | refresh patch to fix patch-fuzz warning | 16 | refresh patch to fix patch-fuzz warning |
17 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | 17 | Signed-off-by: Changqing Li <changqing.li@windriver.com> |
18 | 18 | ||
19 | Refresh patch to fix file ptest/tests/atlocal | ||
20 | contains reference to TMPDIR [buildpaths]. The fix is: | ||
21 | - set EGREP to "grep -E" in ptest/tests/atlocal | ||
22 | - set CFLAGS to " " in ptest/tests/atlocal | ||
23 | |||
24 | Signed-off-by: Bin Lan <bin.lan.cn@windriver.com> | ||
25 | |||
19 | Upstream-Status: Inappropriate [embedded specific] | 26 | Upstream-Status: Inappropriate [embedded specific] |
20 | --- | 27 | --- |
21 | Makefile.am | 1 + | 28 | Makefile.am | 1 + |
@@ -37,7 +44,7 @@ new file mode 100644 | |||
37 | index 0000000..0b4587c | 44 | index 0000000..0b4587c |
38 | --- /dev/null | 45 | --- /dev/null |
39 | +++ b/test.mk | 46 | +++ b/test.mk |
40 | @@ -0,0 +1,74 @@ | 47 | @@ -0,0 +1,76 @@ |
41 | +TEST_DEST ?= ${prefix}/lib/openvswitch | 48 | +TEST_DEST ?= ${prefix}/lib/openvswitch |
42 | +TEST_ROOT ?= ${prefix}/lib/openvswitch | 49 | +TEST_ROOT ?= ${prefix}/lib/openvswitch |
43 | +TEST_DEPEND = | 50 | +TEST_DEPEND = |
@@ -112,3 +119,5 @@ index 0000000..0b4587c | |||
112 | + sed -i 's|$$srcdir|$$abs_srcdir|g' $(TEST_DEST)/tests/testsuite | 119 | + sed -i 's|$$srcdir|$$abs_srcdir|g' $(TEST_DEST)/tests/testsuite |
113 | + sed -i 's|ovs-appctl-bashcomp\.bash|/etc/bash_completion.d/ovs-appctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite | 120 | + sed -i 's|ovs-appctl-bashcomp\.bash|/etc/bash_completion.d/ovs-appctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite |
114 | + sed -i 's|ovs-vsctl-bashcomp\.bash|/etc/bash_completion.d/ovs-vsctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite | 121 | + sed -i 's|ovs-vsctl-bashcomp\.bash|/etc/bash_completion.d/ovs-vsctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite |
122 | + sed -i 's|EGREP=.*|EGREP='"'"'grep -E'"'"'|g' $(TEST_DEST)/tests/atlocal | ||
123 | + sed -i 's|CFLAGS=.*|CFLAGS='"'"' '"'"'|g' $(TEST_DEST)/tests/atlocal | ||