summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/openvswitch-git
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2015-01-29 09:56:03 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-02-03 14:10:55 -0500
commit2905d87e7e4f11573e9c12ed85ff70e4aefc701f (patch)
treebcb2033089912d510b6e1f4d00b1a30e8973aca3 /recipes-networking/openvswitch/openvswitch-git
parentb327673b51002ac95a32b104a6029218984a3184 (diff)
downloadmeta-virtualization-2905d87e7e4f11573e9c12ed85ff70e4aefc701f.tar.gz
Package openvswitch git
This revision corresponds to git rev 1667bb34988358aaf1c92d0d21fad4b1c8698780 (based on 2.3.90) Signed-off-by: Amy Fong <amy.fong@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch-git')
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch18
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/kernel_module.patch20
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/non_reproducible_builds_cleanup.patch18
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch69
4 files changed, 125 insertions, 0 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch b/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch
new file mode 100644
index 00000000..1ad5d6f4
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch
@@ -0,0 +1,18 @@
1Disable m4 file test where sources are built from git.
2
3Signed-off-by: Amy Fong <amy.fong@windriver.com>
4---
5 Makefile.am | 2 +-
6 1 file changed, 1 insertion(+), 1 deletion(-)
7
8--- a/Makefile.am
9+++ b/Makefile.am
10@@ -185,7 +185,7 @@
11 # Makefile in datapath/linux, needed to get the list of files to
12 # distribute, requires GNU make extensions.
13 if GNU_MAKE
14-ALL_LOCAL += dist-hook-git
15+# ALL_LOCAL += dist-hook-git
16 dist-hook-git: distfiles
17 @if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1; then \
18 (cd datapath && $(MAKE) distfiles); \
diff --git a/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch b/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch
new file mode 100644
index 00000000..033cfb8a
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch
@@ -0,0 +1,20 @@
1Specify install path for kernel module
2
3Signed-off-by: Amy Fong <amy.fong@windriver.com>
4---
5 datapath/linux/Makefile.main.in | 4 ++--
6 1 files changed, 2 insertions(+), 2 deletions(-)
7
8--- a/datapath/linux/Makefile.main.in
9+++ b/datapath/linux/Makefile.main.in
10@@ -71,8 +71,8 @@
11 $(MAKE) -C $(KSRC) M=$(builddir) modules
12
13 modules_install:
14- $(MAKE) -C $(KSRC) M=$(builddir) modules_install
15- depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h`
16+ $(MAKE) -C $(KSRC) M=$(builddir) modules_install INSTALL_MOD_PATH=${INSTALL_MOD_PATH}
17+ # depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h`
18 endif
19
20 # Much of the kernel build system in this file is derived from Intel's
diff --git a/recipes-networking/openvswitch/openvswitch-git/non_reproducible_builds_cleanup.patch b/recipes-networking/openvswitch/openvswitch-git/non_reproducible_builds_cleanup.patch
new file mode 100644
index 00000000..999f2ea7
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/non_reproducible_builds_cleanup.patch
@@ -0,0 +1,18 @@
1Remove __DATE__, __TIME__ - error messages on non-reproducible builds
2
3Signed-off-by: Amy Fong <amy.fong@windriver.com>
4---
5 datapath/datapath.c | 2 +-
6 1 files changed, 1 insertions(+), 1 deletions(-)
7
8--- a/datapath/datapath.c
9+++ b/datapath/datapath.c
10@@ -2142,7 +2142,7 @@
11
12 BUILD_BUG_ON(sizeof(struct ovs_skb_cb) > FIELD_SIZEOF(struct sk_buff, cb));
13
14- pr_info("Open vSwitch switching datapath %s, built "__DATE__" "__TIME__"\n",
15+ pr_info("Open vSwitch switching datapath %s\n",
16 VERSION);
17
18 err = action_fifos_init();
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch
new file mode 100644
index 00000000..76e312ca
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch
@@ -0,0 +1,69 @@
1Add test-install rule to support ptest execution
2
3Signed-off-by: Radu Patriu <radu.patriu@enea.com>
4
5---
6 Makefile.am | 2 ++
7 test.mk | 49 +++++++++++++++++++++++++++++++++++++++++++++++++
8 2 files changed, 51 insertions(+)
9
10--- a/Makefile.am
11+++ b/Makefile.am
12@@ -369,3 +369,5 @@
13 include vtep/automake.mk
14 include datapath-windows/automake.mk
15 include datapath-windows/include/automake.mk
16+include test.mk
17+
18--- /dev/null
19+++ b/test.mk
20@@ -0,0 +1,49 @@
21+TEST_DEST ?= ${prefix}/lib/openvswitch
22+TEST_ROOT ?= ${prefix}/lib/openvswitch
23+TEST_DEPEND =
24+
25+if HAVE_OPENSSL
26+TEST_DEPEND += $(TESTPKI_FILES)
27+endif
28+
29+test-install: $(TEST_DEPEND)
30+ @list='$(noinst_PROGRAMS) $(EXTRA_DIST) $(dist_check_SCRIPTS) $(TEST_DEPEND) tests/atlocal tests/atconfig' ;\
31+ install -d $(TEST_DEST)/tests ;\
32+ install -d $(TEST_DEST)/python ;\
33+ install -d $(TEST_DEST)/python/ovs ;\
34+ install -d $(TEST_DEST)/python/ovs/db ;\
35+ install -d $(TEST_DEST)/python/ovs/unixctl ;\
36+ install -d $(TEST_DEST)/vswitchd ;\
37+ install vswitchd/vswitch.ovsschema $(TEST_DEST)/vswitchd ;\
38+ install -d $(TEST_DEST)/debian ;\
39+ install debian/ovs-monitor-ipsec $(TEST_DEST)/debian ;\
40+ install -d $(TEST_DEST)/build-aux ;\
41+ install build-aux/check-structs $(TEST_DEST)/build-aux ;\
42+ install -d $(TEST_DEST)/xenserver ;\
43+ install xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync $(TEST_DEST)/xenserver ;\
44+ install xenserver/opt_xensource_libexec_interface-reconfigure $(TEST_DEST)/xenserver ;\
45+ install xenserver/opt_xensource_libexec_InterfaceReconfigure.py $(TEST_DEST)/xenserver ;\
46+ install xenserver/opt_xensource_libexec_InterfaceReconfigureBridge.py $(TEST_DEST)/xenserver ;\
47+ install xenserver/opt_xensource_libexec_InterfaceReconfigureVswitch.py $(TEST_DEST)/xenserver ;\
48+ install -d $(TEST_DEST)/vtep ;\
49+ install vtep/vtep.ovsschema $(TEST_DEST)/vtep ;\
50+ for p in $$list ; do \
51+ echo $$p ;\
52+ p=$${p#./} ;\
53+ pre=$${p#tests\/} ;\
54+ if test $$pre != $$p ; then \
55+ echo installing $$p to $(TEST_DEST)/tests/$$pre ;\
56+ install $$p $(TEST_DEST)/tests/$$pre ;\
57+ continue ;\
58+ fi ;\
59+ pre=$${p#python\/ovs\/} ;\
60+ if test $$pre != $$p ; then \
61+ echo installing $$p to $(TEST_DEST)/python/ovs/$$pre ;\
62+ install $$p $(TEST_DEST)/python/ovs/$$pre ;\
63+ continue ;\
64+ fi; \
65+ done ;\
66+ sed -i 's|abs_builddir=.*|abs_builddir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig
67+ sed -i 's|abs_srcdir=.*|abs_srcdir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig
68+ sed -i 's|abs_top_srcdir=.*|abs_top_srcdir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig
69+ sed -i 's|abs_top_builddir=.*|abs_top_builddir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig